Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Kurz-Anleitung] Video-Programme (Xine etc.) installieren

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Benutzeravatar
NewLinuxer
Newbie
Newbie
Beiträge: 5
Registriert: 25. Aug 2004, 09:26
Wohnort: Hannover

Beitrag von NewLinuxer »

danke den Tipp hab ich schon oft gelesen wegen apt und so, aber wenn man gerade mal weiss wie man Linux schreibt ist es echt schwer. Bin eben einfach noch die leichten exe Datein von Windows gewöhnt...Und zu dem muss man auch die Sevrer kennen für die Updates. aber danke ich habe es auch derweil geschaft....smile

habe dafür nen anderes Problem.
Woher bekomme ich die Datei Libdvdcss und was mache ich mit ihr....und bitte nicht sagen die muss ich kompilieren damit allein ist mir eben nicht geholfen denn ich weiss nicht wie und was da geht....

Danke und Gruss
Michael
Linux ist wie der Aufbau einer guten Beziehung!
Windows ist wie der Gang zu einer Prostituierten!
Gast

Beitrag von Gast »

Mensch lies doch mal was hier (ganz oben) geschrieben steht:

Geh' zu packman, such nach libdvdcss und tu was dort steht!
Benutzeravatar
NewLinuxer
Newbie
Newbie
Beiträge: 5
Registriert: 25. Aug 2004, 09:26
Wohnort: Hannover

Beitrag von NewLinuxer »

habe ich ja auch gemacht und so, aber ich verstehe es eben nicht, vielleicht bin ich ja auch nur zu doof....smile
Ich habe ja nun einiges schon gelernt, aber das begreiff ich einfach nicht.
vielleciht weiss ja wer was für mich....

michael
Linux ist wie der Aufbau einer guten Beziehung!
Windows ist wie der Gang zu einer Prostituierten!
Thomas Reinhart
Member
Member
Beiträge: 51
Registriert: 31. Aug 2004, 19:03
Wohnort: Winterthur - Schweiz

Kaffeine verlangt "libxine.so.1"

Beitrag von Thomas Reinhart »

Ich habe Suse 9.1 professional update (64 bit) installiert. Beim Abspielen von Videos funktionierte nur der Ton, ohne Bild (unter XP ging es problemlos).
Ich habe versucht, Xine zu installieren, nach der obigen Anleitung von aurial. Die libdvdcss 1.2.8 habe ich über rpmseek von atrpms.physik.fu-berlin.de geholt. Die Pakete von Packman habe ich unter YAST heruntergeladen; als Adresse für den Download habe ich "packman.iu-bremen.de/suse/9.1" eingegeben. Gemäss YAST waren alle Abhängigkeiten OK. Wenn ich jetzt kaffeine aufrufe, erhalte ich die Fehlermeldung:
"error while loading shared libraries: libxine.so.1: cannot open shared object file: No such file or directory."

Was ist das libxine.so.1 ?
Hat jemand eine Ahnung, was ich falsch gemacht habe?

Bitte helft einem Newbie, endlich von XP wegzukommen!

Meine Hardware:
AMD 64 3200+
Abit AV8 Max3
2*512 MB
ATI Radeon 9200 SE
miha
Newbie
Newbie
Beiträge: 4
Registriert: 26. Sep 2004, 20:39
Kontaktdaten:

alles okay - ABER DVD Wiedergabe ruckelt

Beitrag von miha »

So liebe Leute - bin bereits begeistert von Eurem Forum wo ich seit gestern so einiges mit ausprobiere und auch meistens richtig hinbekomme...ABER:

Ich habe wie in der obigen Anleitung alle SuSE Kastrate rausgeschmissen, bei packman alles angegebene gezogen und korrekt installiert.
Xine läuft, alle Codecs usw. laufen auch einwandfrei...
Nur bei der DVD-Wiedergabe (die GRUNDSÄTZLICH funktioniert) ruckeln Bild und Ton. Nun habe ich versucht unter kaffeine in den Xine-Einstellungen das eine oder andere zu ändern - was Bild, Ton, Downmix usw angeht - dachte dass vielleicht da was nicht stimmt. Es scheint aber daran zu liegen, dass mein DVD-Laufwerk immer beim Nachlesen in den Pufferspeicher den kompletten Ablauf stört....Prebuffering ist an - denke das sollte auch so gut sein - und solange der Puffer voll ist geht das auch !
Ausschalten des Pufferns bringt aber auch nichts. Nutze SuSE 9.0, die RPMS von Packman habe ich auch für diese Distri gezogen. Der Kernel ist der 2.4er mit Optimierung für AthlonXP. Liegts am fehlenden DMA-modus der erst im 2.6er Kernel dabei ist ??? System: AthlonXP2400+ auf ASRockK7S8X, 1GB Ram, LG 16x DVD-ROM...
Wäre für jeden Tip dankbar.
Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel »

mal dma-modus für dein dvd-laufwerk aktivieren ;)

hdparm

siehe dazu in der boardsuche plz...
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild
tias
Newbie
Newbie
Beiträge: 1
Registriert: 27. Sep 2004, 21:55

Beitrag von tias »

hatte das selbe probelm: einfach dma-modus für dein dvd-laufwerk aktivieren :-)

cu @
miha
Newbie
Newbie
Beiträge: 4
Registriert: 26. Sep 2004, 20:39
Kontaktdaten:

Beitrag von miha »

super DANKE !
Habe DMA über Yast aktiviert - läuft alles spitze.
sollte hdparm wirklich so gut sein wie es verspricht werd ich mir das auch mal noch zu Gemüte führen...wenn ich irgendwann noch mehr Datendurchsatz brauche.
:D
moroquai
Newbie
Newbie
Beiträge: 1
Registriert: 14. Aug 2005, 23:15

Beitrag von moroquai »

Hab mal alles nach Anleitung deinstalliert und mit apt wieder installiert.
(bis auf die libxine1-w32dll & co -außer der "libxine1" findet apt nichts).

Einen Film kann ich mir inzwischen anschauen, allerdings nur mit dem mplayer,
und dass dann auch nur, wenn ich über die Konsole gehe.

Wenn ich den Film über Mausclicks mit dem Mplayer starte, kommt die Fehlermeldung:
"Fatal error!" "Error opening/initializing the selected viedo_out (-vo) device.

und kaffeine meldet mir: xine findet kein plugin um diese Quelle zu handhaben

[abschweif]
Jetzt hat sich Suse so schön entwickelt.
Es gibt sofort eine rießen Auswahl an Software, die im gegensatz zu windows stabil läuft; optisch ist Suse schöner als windows (skins & co)
Das einzige, was einem die Laune wieder verdierbt ist, das Suse wegen juristischer Probleme diese ganze Divx & Co Sache nicht mitliefern kann...
[/abschweif]

Kann mir jemand helfen, warum ich die Film nicht direkt per Mausclick starten kann?
Ich gebe nämlich die Hoffnung nicht auf, das mein Firefox dann endlich die Filme direkt abspielen (ohne das ich im html code nach der quelle suchen muss, herunterladen und dann über die Konsole öffnen)[/quote]
Betriebsystem:
Suse 9.3 & windows 2003 server
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4417
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 »

Moin moroquai,

wenn Du dir alles per apt installiert hast und es dann immer noch nicht richtig läuft, habe ich den Verdacht das Du packmann nicht mit in deine sources.list aufgenommen hast. Ließ dir am besten den gepinnten Thread dazu durch.
Zum Problem mit dem nicht starten durch Mausklick: Anscheinend ist in deinem KDE-Menü eine Option auf ein Ausgabegerät aktiviert das bei dir nicht läuft. Kontrollzentrum>>Arbeitsfläche>>Kontrolleisten, der Reiter 'Menü'>>K-Menü bearbeiten>> Den entsprechenden Eintrag suchen und bei Befehl schauen ob dort anderes angegeben ist als Du in der Konsole eingibst.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
lenhard
Newbie
Newbie
Beiträge: 1
Registriert: 22. Feb 2006, 05:05
Wohnort: Neudrossenfeld

Multimedia

Beitrag von lenhard »

Vielen Dank für deinen Tipp. Bin Linux Anfänger, aber mit rpm Paketen hat es sofort funkioniert. :D . Will entlich von MS weg.
linuxduck
Newbie
Newbie
Beiträge: 13
Registriert: 22. Sep 2005, 08:44
Wohnort: Freiburg
Kontaktdaten:

Großes Lob Terratec DVCB-c 1200 läuft!

Beitrag von linuxduck »

Hallo,
konnte mit diesen Anleitungen zum alles über Apt installieren.
(kaffeine vorher deinstalliert).
Jetzt läuft meine neue Terratec DVB-c 1200 wunderbar unter
OSSuSe10-
Ich kann in guter Qualität TV ansehen und aufnehmen !!
Herzlichen Dank für diese Hilfestellungen und Tipps.
GROSSES LOB !!!!
gm4288
Newbie
Newbie
Beiträge: 22
Registriert: 6. Mär 2006, 19:09
Wohnort: WOB

Beitrag von gm4288 »

Hallo ich kann volgende Packete nicht finden was einer wo ich sie runterladen kann?
libxine1-alsa09 (für ALSA-Sound-Unterstützung)
libxine1-dvd (für Unterstützung von DVD und Menü-Navigation)
libxine1-ogg (für Unterstützung von OGG-Sound)
libxine1-w32dll (NUR damit funktioniert die Unterstützung von Windows-Videos!)
*edit*
hab grad gelesen das ich im Yast libxine1 anklicken muss ich hab aber mit dem Linux rechner keine Inet verbindung wo kriege ich die her oder sind sie schon in der libxine1-1.1.1-16.pm.0.i586.rpm enthalten?
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

gm4288 hat geschrieben:Hallo ich kann volgende Packete nicht finden was einer wo ich sie runterladen kann?
libxine1-alsa09 (für ALSA-Sound-Unterstützung)
libxine1-dvd (für Unterstützung von DVD und Menü-Navigation)
libxine1-ogg (für Unterstützung von OGG-Sound)
libxine1-w32dll (NUR damit funktioniert die Unterstützung von Windows-Videos!)
*edit*
hab grad gelesen das ich im Yast libxine1 anklicken muss ich hab aber mit dem Linux rechner keine Inet verbindung wo kriege ich die her oder sind sie schon in der libxine1-1.1.1-16.pm.0.i586.rpm enthalten?
Das von die genannte sollte alles bei libxine1 von Packman dabei sein.
Quelle: http://packman.links2linux.de/?action=124
(achte auf die korrekte Suse-Version!)

Tipp zur Installation:
Füge dir Packman als alternative Installationsquelle in YaST ein
http://www.linux-club.de/viewtopic.php?t=27988
und installiere "libxine1" über YaST.
Paketabhängigkeiten (libxine1 hat einige) werden so automatisch aufgelöst.
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
gm4288
Newbie
Newbie
Beiträge: 22
Registriert: 6. Mär 2006, 19:09
Wohnort: WOB

Beitrag von gm4288 »

naja ausser einer libjs für gxine ist nichts mehr erforderlich
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

gm4288 hat geschrieben:naja ausser einer libjs für gxine ist nichts mehr erforderlich
libjs gibt es ebenfalls bei Packman:
http://packman.links2linux.de/?action=637
Achte bitte wieder auf deine Suse-Version oder installiere über YaST (Packman als alternative Installationsquelle).

Hast du oben bereits über YaST installiert? Dann hätte libjs eigentlich gefunden und installiert werden müssen.
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
gm4288
Newbie
Newbie
Beiträge: 22
Registriert: 6. Mär 2006, 19:09
Wohnort: WOB

Beitrag von gm4288 »

Wie gesagt ich habe mit dem Linux Rechner keinen Internet zugriff.
Griffin
Guru
Guru
Beiträge: 3235
Registriert: 10. Mai 2005, 14:11
Kontaktdaten:

Beitrag von Griffin »

Dann dieser allgemeine Hinweis:

Suse Pakete besitzen immer nur Abhängigkeiten zu anderen Suse Paketen. Die Abhängigkeiten findest du also auf der Suse DVD oder im Base:
ftp://ftp4.gwdg.de/linux/suse/apt/SuSE/ ... RPMS.base/

Packman Pakete besitzen immer nur Abhängigkeiten zu anderen Packman Paketen oder zu Suse Paketen. Deren Abhängigkeiten findest du also bei Packman, auf der Suse DVD oder im Base (siehe oben).
Packman: http://packman.links2linux.de/
oder: http://packman.iu-bremen.de/suse/10.0/

Wenn du also bei der Installation von Paketen auf Abhängigkeiten triffst, such in den oben genannten Quellen. :wink:

Den Link zu libjs hatte ich dir ja bereits oben genannt:
http://packman.links2linux.de/?action=637
Achte auf die richtige Suse-Version!
Für Suse 10.0 also hier:
http://packman.links2linux.de/index.php ... n=637&vn=3
"Komm zur dunklen Seite, Luke. Hier gibt es Milch und Kekse!" - Darth Vader

Yoda: "Dunkel die andere Seite ist, Obi Wan"-"Sei still und iss endlich deinen Toast"
Der Nippeser
Newbie
Newbie
Beiträge: 19
Registriert: 15. Jun 2006, 17:35
Wohnort: Köln

Beitrag von Der Nippeser »

:oops:
Vielleicht b in ich ja auch völlig blind, aber ich finde folgende Bibliotheken

libxine1-alsa09 (für ALSA-Sound-Unterstützung)
libxine1-dvd (für Unterstützung von DVD und Menü-Navigation)
libxine1-ogg (für Unterstützung von OGG-Sound)
libxine1-w32dll (NUR damit funktioniert die Unterstützung von Windows-Videos!)

weder unter http://packman.links2linux.de/?action=124 noch unter http://packman.iu-bremen.de/suse/10.1/

Ich würde aber schon gerne DVDs unter SUSE 10.1 gucken (und nur das!)

Sind die Dinger vom Netz genommen? Oder verlagert? Gibt es Umgehungslösungen?

Viele Grüße aus Köln
Harald
Freecoffee
Guru
Guru
Beiträge: 1750
Registriert: 29. Sep 2004, 17:00
Wohnort: Bayern

Beitrag von Freecoffee »

Wie schon oben gesagt wurde: Installier das Paket libxine1, und es sollte funktionieren.
Gruß, Freecoffee
Antworten