[Kurz-Anleitung] Video-Programme (Xine etc.) installieren

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Gast

[Kurz-Anleitung] Video-Programme (Xine etc.) installieren

Beitrag von Gast » 13. Mär 2004, 17:33

Hallo allerseits,

ZUNÄCHST erst einmal: Die Benutzung mancher in diesem Beitrag erwähnten Pakete ist in Deutschland nach derzeit gültiger Rechtslage verboten. Es muss jeder für sich selbst entscheiden, ob er / sie sich darüber hinwegsetzt, oder nicht. Wie üblich übernimmt der Autor dieser Zeilen keinerlei Haftung für Schäden welcher Art auch immer. Wem das Risiko zu hoch ist, bzw. wer sich nicht strafbar machen will, der liest hier einfach NICHT weiter.

Damit die Video-Wiedergabe unter SuSE reibungslos funktioniert, sollten erst einmal folgende bei SuSE mitgelieferten Pakete entfernt werden (sofern diese installiert sind):

kaffeine
kdemultimedia3-video-xine
totem
xine-devel
xine-lib
xine-ui

Das Entfernen dieser Pakete ist notwendig, weil SuSE - siehe oben - diese Pakete aufgrund juristischer Probleme nur in abgespeckter ("kastrierter") Form anbietet. Etliche Video- und Tonformate funktionieren damit nicht. Gegebenenfalls sollte man auch noch sicherheitshalber sämtliche Einstellungen dieser Programme im Home-Verzeichnis entfernen, also z.B. die Datei .kde/share/config/kaffeinerc, das komplette .xine-Verzeichnis löschen, usw.usf.

Anschließend besorgt man sich von [1] (oder auch viel einfacher mit Hilfe von apt [2], denn damit werden auch gleich sämtliche Paketabhängigkeiten berücksichtigt - dazu weiter unten noch mehr) mindestens folgende Pakete:

gxine
kaffeine
totem
xine-ui
libxine1
libxine1-alsa09 (für ALSA-Sound-Unterstützung)
libxine1-arts (für Unterstützung des KDE-arts-Soundservers)
libxine1-dvd (für Unterstützung von DVD und Menü-Navigation)
libxine1-ogg (für Unterstützung von OGG-Sound)
libxine1-w32dll (NUR damit funktioniert die Unterstützung von Windows-Videos!)

Wer will, kann der Vollständigkeit halber auch gleich die restlichen libxine1-*-Pakete mitsaugen. Das Ganze dann mit Hilfe einer Root-Konsole und dem Befehl

rpm -Uhv *.rpm

installieren (sofern diese nicht bereits durch das Anklicken des rpm-Paketes im Konqueror automatisch installiert wurden).

An dieser Stelle ist (eigentlich) unnötig zu erwähnen, dass eventuell aufgrund von Paketabhängigkeiten je nach Installationsgrad einer SuSE-Distribution noch etliche zusätzliche Pakete besorgt werden müssen, damit die Installation klappt. Insbesondere für die kürzlich erschienene ComputerBild-Version von SuSE gilt das, da hier aufgrund des begrenzten Platzes von nur einer CD etliche benötigte Pakete fehlen, diese also bei der Erst-Installation nicht gleich mit installiert wurden.

Daher auch der Tipp, sich die Pakete am besten mit apt zu besorgen, denn hier werden unter Einbindung der Quellen "base", "packman" und "packman-i686" sämtliche Paketabhängigkeiten automatisch aufgelöst.

Für eine "Komplett-Installation" benötigt man danach noch ggf. die Pakete

w32codec (oder man kopiert von der Windows-Partition die Codecs nach /usr/lib/win32)
divx4linux (wie der Name schon sagt: DivX für Linux)
xvid (ein weiteres Videoformat; manche sagen, es sei besser als DivX)

und schließlich natürlich noch die berühmt-berüchtigte libdvdcss zwecks Entschlüsselung; nur damit können die allermeisten Kauf-DVDs angeschaut werden.

Unter [3] gibt es aufgrund rechtlicher Problematiken nur noch den Quellcode nebst einer Anleitung, wie man es compiliert und / oder das benötigte RPM-Paket erstellt. Ist nicht gar so schwer. Einfacher geht's (wieder einmal) per apt, denn damit lässt sich auch ein bereits vorkompiliertes, betriebsbereites libdvdcss-Paket aus den Tiefen mancher ftp-server installieren.

Viel Glück bei den umfangreichen Installations-Fummeleien, und viel Spaß beim künftigen Video-Schauen.


[1] http://packman.links2linux.de/?action=index

[2] ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... suser-rbos

[3] http://packman.links2linux.de/?action=122

Werbung:
aurial

Kleine Ergänzung

Beitrag von aurial » 20. Mär 2004, 18:42

Wäre noch zu ergänzen, dass, wenn man bspw. mit

Code: Alles auswählen

rpm -Uhv *.rpm
Pakete in einer Root-Konsole installiert hat, man bei SuSE danach auch immer noch die zwei Befehle

Code: Alles auswählen

ldconfig
SuSEconfig
durchführen sollte (natürlich ebenfalls als root)

Grüße

aurial

Noch eine kleine Ergänzung

Beitrag von aurial » 4. Apr 2004, 19:08

Hallo allerseits,

(wollte das eigentlich schon viel früher schreiben, aber hab's immer wieder vergessen :-) )

Kleine weitere Ergänzung zum ersten Beitrag betreffs dem Entfernen alter Einstellungen im Home-Verzeichnis: Es gibt außer der Datei .kde/share/config/kaffeinerc entgegen einer früheren Aussage von mir doch noch eine zweite Einstellungs-Ablage für das Xine-Frontend Kaffeine, und zwar schlicht und ergreifend das Verzeichnis .kaffeine im Home-Verzeichnis.

Also zusammengefasst: Nachdem man die originalen Pakete, die bei SuSE mitgeliefert werden, entfernt hat, sollte man zusätzlich noch die Datei

Code: Alles auswählen

.kde/share/config/kaffeinerc
sowie die beiden Verzeichnisse

Code: Alles auswählen

.kaffeine
.xine
löschen. Danach wie oben beschrieben die diversen Packman-Pakete installieren, und alles sollte dann reibungslos ohne Probleme funktionieren.

Wenn man übrigens (S)VCDs, DVDs, AVIs, RealVideo, Quicktime usw. nur wiedergeben will, ist die zusätzliche Installation des Mplayers nicht notwendig. Zumal Xine / Kaffeine im Gegensatz zum Mplayer auch die DVD-Menü-Navigation beherrschen.

Die zusätzliche Installation des Mplayers ist nur dann notwendig, wenn man neben der Wiedergabe auch Videos (neu) codieren will, denn in dem Mplayer-Paket ist neben dem Player auch noch der Kodierer Mencode enthalten.

Herzliche Grüße

aurial

Neu libxine1-Pakete

Beitrag von aurial » 9. Apr 2004, 16:34

Hallo allerseits,

heute sind neue libxine1-*-Pakete von Packman erschienen und ab sofort in den apt-Quellen verfügbar (die Anderen müssen warten, bis die allseits bekannten Packman-Webseiten upgedatet werden).

Mit diesen neuen Paketen klappt unter anderem die DVD-Menü-Navigation von "Findet Nemo" korrekt, die vorher wenig bis gar nicht funktioniert hatte.

Da hat aber jemand schnell reagiert :-)

Herzliche Grüße

gfred

bin den tränen nahe

Beitrag von gfred » 21. Apr 2004, 02:27

hallo,

hab alles gemacht wie oben beschrieben und bin wirklich begeistert. schaut zwar aus wie ein riesen akt ist aber wirklich garnicht so schlimm. vielen dank an den autor.

ich kann jetzt wirklich alles abspielen nur hab ich ein problem und das ist wirklich tragisch. xine kann meine twin peaks folgen nicht vernünftig wiedergeben obwohls bei windows geht, doch das stürzt alle paar minuten ab .
ich krieg die krise. jetzt bin ich bei folge 11 und kann nicht weiter schauen.
die serie ist ganz normal im avi format.
alles andere spielt er ob divx oder avi oder sonst was.
nur nicht die twin peaks avi.
da hör ich den ton das bild verschwimmt die ganze zeit in riesige kästchen.

jetzt meine eigentliche frage:
wie kann ich wie oben erwähnt die codecs von der windows partition kopieren - ich finde sie einfach nicht.

vielen dank.

gfred
alle zeit der welt

gfred

hab was entdeckt

Beitrag von gfred » 21. Apr 2004, 02:35

die twinpeaks folgen sind in diesem format
iso mpeg-4 (ffmpag) (624 mal 480)
mercy

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 21. Apr 2004, 02:43

die codecs einfach kopieren geht leider nicht...wie auch windows-->linux...??

versuchs mal mit dem vlc media player...der spielt so ziehmlich alles ab was es nur gibt....
http://packman.links2linux.de/?action=377
:wink:
Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

Gast

Verflixtes libdvd

Beitrag von Gast » 7. Mai 2004, 16:57

Hallo zusammen.

libdvdcss treibt mich zum Wahnsinn :x .
Nach der Anleitung habe ich xine mit den diversen 686er-plugins von packman installiert, auch die libdvdcss umgebaut, aber Kaffeine gibt mir, beim Versuch einen DVD-Film zu starten, trotzdem die Fehlermeldung: "Kein Plugin gefunden um diese Quelle zu handhaben".
Ansonsten kann ich alle Formate ansehen. Jetzt bin ich einigermaßen ratlos und genervt.- Was kann ich denn jetzt noch tun?
Für jeden Tip bin ich dankbar!

Übrigens: ich nutze SuSe 9.0, KDE 3.21 mit Athlon 1400

aurial

Beitrag von aurial » 7. Mai 2004, 17:21

Hallo Gast,
Nach der Anleitung habe ich xine mit den diversen 686er-plugins von packman installiert, auch die libdvdcss umgebaut, aber Kaffeine gibt mir, beim Versuch einen DVD-Film zu starten, trotzdem die Fehlermeldung: "Kein Plugin gefunden um diese Quelle zu handhaben".
libdvdcss wirklich korrekt installiert? (im Yast-Paketmanager mal nach diesem Paket suchen und es sich anzeigen lassen)

Kaffeine von Packman, und nicht das von SuSE installiert?

Und nicht zuletzt: libxine1-dvd (!!!) bereits installiert?

Was passiert, wenn Du xine in der Konsole startest und dann auf DVD-Wiedergabe klickst (Textausgabe der Konsole hier posten)

Herzliche Grüße

Gast (meloup)

libdvdcss-wahnsinn

Beitrag von Gast (meloup) » 8. Mai 2004, 00:04

@auriel

libxinedvd ist installiert und Kaffeine 0.42 von packman. Die Konsole zeigt nach Startversuch einer DVD:
Dies ist xine (X11 gui) - Ein freier Video-Player v0.99.1.
(c) 2000-2003 Das xine Projektteam.
libdvdnav: Using dvdnav version 1-rc4 from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
libdvdnav: vm: faild to open/read the DVD

Was meinst Du dazu?

Herzlichen Gruß,
Gast (meloup)

aurial

Beitrag von aurial » 8. Mai 2004, 00:32

Hallo meloup,
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Du hast im /dev-Verzeichnis keinen dvd-Eintrag. Dadurch kann /dev/dvd nicht angesteuert / geöffnet werden. Du musst im /dev-Verzeichnis einen Symlink erzeugen, der auf Dein DVD-Laufwerk verweist.

siehe auch http://xinehq.de/index.php/faq (in diesem Dokument nach dem Begriff /dev/dvd suchen.

Herzliche Grüße

Benutzeravatar
meloup
Newbie
Newbie
Beiträge: 1
Registriert: 8. Mai 2004, 00:11
Wohnort: Ostfildern
Kontaktdaten:

Beitrag von meloup » 8. Mai 2004, 11:05

@aurial

der fehlende dev/dvd Eintrag war der entscheidende Hinweis :D .
Vielen Dank und herzlichen Gruß,
meloup
Have a nice day and allways good company

linupaule
Newbie
Newbie
Beiträge: 1
Registriert: 5. Jun 2004, 12:50
Kontaktdaten:

Beitrag von linupaule » 5. Jun 2004, 16:11

Wollte mir mal die Pakete alle zusammensuchen und dann loslegen, bin dann aber am Totem gescheitert, weil ich dafür kein RPM für i686 gefunden hab.
Kann mir jemand der sich das schon besorgt hat sagen wo's das gibt?
(Bei Packman war ich unfündig).
THX im voraus.
------------------------
Eigentlich ein Neuling
------------------------

Benutzeravatar
Sauritzius
Newbie
Newbie
Beiträge: 3
Registriert: 13. Jun 2004, 18:12
Wohnort: Orwisch
Kontaktdaten:

Beitrag von Sauritzius » 29. Jun 2004, 19:19

Hallo,

Ich habe ein Problem.
Ich finde fogende Packete nicht unter diesem Link http://packman.links2linux.de/?action=index

libxine1
libxine1-alsa09 (für ALSA-Sound-Unterstützung)
libxine1-arts (für Unterstützung des KDE-arts-Soundservers)
libxine1-dvd (für Unterstützung von DVD und Menü-Navigation)
libxine1-ogg (für Unterstützung von OGG-Sound)
libxine1-w32dll (NUR damit funktioniert die Unterstützung von Windows-Videos!)


Kann mir einer weiter helfen?

Benutzeravatar
Gimpel
Guru
Guru
Beiträge: 1983
Registriert: 11. Feb 2004, 13:58
Wohnort: Mjunik .... "no a hoibe, resi!"
Kontaktdaten:

Beitrag von Gimpel » 29. Jun 2004, 19:43

Bild on AMD Athlon64 X2 5600+|64bit|6GB DDR2 800MHz|nVidia GF 8500GT|2.6.29-rc1-moo1|BTRFS|KDE-4.2 SVN trunk + Compiz++|M-Audio Audiophile 2496
----
Bild

SchmerzKeks
Newbie
Newbie
Beiträge: 4
Registriert: 9. Jul 2004, 09:54
Wohnort: Kiel
Kontaktdaten:

Beitrag von SchmerzKeks » 10. Jul 2004, 09:35

Hallo, ist schon etwas Älter der Beitrag hab mich dennoch mal drann versucht und alles anch Anleitung gemacht, nun bin ich auch einen Ganzen Schritt weiter als vorher wenn ich nun ein AVI Film abspielen möchte bekomme ich keine Fehler oder Warnmeldungen mehr und bekomme sogar den Sound auf meine Ohren nur leider Bleibt mein Bildschirmfenster schwarz... :(
Hat jemand einen Tip für mich?!?
Danke Kek
-Autsch-

Benutzeravatar
NewLinuxer
Newbie
Newbie
Beiträge: 5
Registriert: 25. Aug 2004, 09:26
Wohnort: Hannover

Re: Video-Programme (Xine etc.) installieren (Kurz-Anleitung

Beitrag von NewLinuxer » 25. Aug 2004, 09:54

aurial hat geschrieben:Hallo allerseits,

Daher auch der Tipp, sich die Pakete am besten mit apt zu besorgen, denn hier werden unter Einbindung der Quellen "base", "packman" und "packman-i686" sämtliche Paketabhängigkeiten automatisch aufgelöst.

und schließlich natürlich noch die berühmt-berüchtigte libdvdcss zwecks Entschlüsselung; nur damit können die allermeisten Kauf-DVDs angeschaut werden.

Unter [3] gibt es aufgrund rechtlicher Problematiken nur noch den Quellcode nebst einer Anleitung, wie man es compiliert und / oder das benötigte RPM-Paket erstellt. Ist nicht gar so schwer. Einfacher geht's (wieder einmal) per apt, denn damit lässt sich auch ein bereits vorkompiliertes, betriebsbereites libdvdcss-Paket aus den Tiefen mancher ftp-server installieren.
Hallo auch ich bin ja gaaanz doof und arbeite seit kurzem erst mit Linux 9.1 der Wechsel war zwar leicht dass konfigurieren nicht. Nun hab ich deine schöne Anleitung genutzt, aber zwei Dinge verstehe ich nicht erstens wie ich dass libdvdcss bekomme bzw installiere compiliere etc. und zweitens meldet er, obwohl ich in dem server bin mit yast das er kdelibs3 braucht und qt3 auch und beide nicht findet um Kaffeine zu installieren. Was soll ich tun und wie???? Und was ist APT??? Danke für Eure tolle Hilfe, so wird der Umstieg besser und man wagt ihn auch.
Gruss Michael :oops: :oops: :oops:
Linux ist wie der Aufbau einer guten Beziehung!
Windows ist wie der Gang zu einer Prostituierten!

Benutzeravatar
NewLinuxer
Newbie
Newbie
Beiträge: 5
Registriert: 25. Aug 2004, 09:26
Wohnort: Hannover

Beitrag von NewLinuxer » 25. Aug 2004, 10:53

also zum einen habe ich die fehler wegen der libs gefunden. Musste sie nur aktuallisieren....smile sorry mein fehler....
aber dass mit dem css verstehe ich trotzdem nicht wie ich da einfügen kan....hat da wer nen tipp denn ich verstehe???
Linux ist wie der Aufbau einer guten Beziehung!
Windows ist wie der Gang zu einer Prostituierten!

Benutzeravatar
NewLinuxer
Newbie
Newbie
Beiträge: 5
Registriert: 25. Aug 2004, 09:26
Wohnort: Hannover

Beitrag von NewLinuxer » 25. Aug 2004, 11:44

wo bekomme ich denn die aktuellen versionen. ich habe ein update versucht abr der will die version kdelibs 3.2.2 ich habe nur 3.2.1 weiss nicht wie es noch höher geht für kaffein....
michael
Linux ist wie der Aufbau einer guten Beziehung!
Windows ist wie der Gang zu einer Prostituierten!

Thomas4000
Member
Member
Beiträge: 178
Registriert: 8. Aug 2004, 20:20
Wohnort: Bayern

Beitrag von Thomas4000 » 25. Aug 2004, 18:49

Hallo NewLinuxer,
lies einfach mehr in Forum...habs damit auch geschafft.
Für die neuesten libs am besten in Yast eine neue Quelle anlegen, das ist im ersten Thread ("Wichtig") in diesem Unterforum beschrieben.http://www.linux-club.de/viewtopic.php?t=9039
Oder apt installieren.

Ich habe auch per Yast die kdelibs aktualisiert wie gefordert, dann ging aber der Konqueror nicht mehr, hab dann gleich auf KDE 3.3 upgedatet.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste