Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse 9.0 + firewall + adsl problem

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
ghostbones
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jan 2004, 12:03
Kontaktdaten:

Suse 9.0 + firewall + adsl problem

Beitrag von ghostbones »

hi
habe folgendes problem:

Habe suse 9 installiert, und auch die adsl verbindung eingerichtet. komm auch wunderbar ins internet, aber sobald ich "rcnetwork restart" eingeb, geht das nicht mehr. muss dann wieder das setup für das adsl machen.

wenn ich die firewall installier, und das masq. einstell, welches ich für das netzwerk brauch, dann "schmeißt" mir das setup programm auch die konfiguration vom modem hinaus. komm daher nachher auch nicht mehr ins internet.

wenn ich online bin, komm ich dafür nicht ins internet netz, (ip_foraward ist auf yes), da der pc nur bei der netzwerkkarte hinausgeht, an der das modem hängt.


wäre sehr dankbar, wenn mir da jemand hilft, oder auch nur einen tipp gibt.

vlg
Benutzeravatar
BlueTurtle
Member
Member
Beiträge: 157
Registriert: 13. Mär 2004, 17:22

Beitrag von BlueTurtle »

Hallo ghostbones,

führe nach Deinem "rcnetwork" bitte mal ein "ifconfig ppp0" aus und sieh nach, ob die Adresse, die der Karte zugewiesen ist noch eine öffentliche ist.
Triton
Member
Member
Beiträge: 88
Registriert: 22. Feb 2004, 17:20

Beitrag von Triton »

Es wird die Default Route gelöscht deshalb kommst nimmer ins Internet.

# ifconfig ppp0

P-t-P:62.104.190.38 <- Diese Adresse dir merken

Dann musst Du die Default Route wieder setzen mit

# route add default gw 62.104.190.38

# netstat -rn

62.104.190.38 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
0.0.0.0 62.104.190.38 0.0.0.0 UG 0 0 0 ppp0

So in etwa muss dann die Routing-Tabelle aussehen.


Grüße
ghostbones
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jan 2004, 12:03
Kontaktdaten:

Danke

Beitrag von ghostbones »

So jetzt gehts. danke

habe aber dafür jetzt ein anders problem:

Ich komm jetzt mit jedem x belibigen pc von internen netzwerk via ping bis ans modem. aber nicht ins internet. (mim Server aber schon)

Hab die SuSEFirewall2 aktiviert. (Masq. eingeschalten), aber warum komm ich nicht aus dem netzwerk ins internet? Was kann bzw hab ich da falsch gemacht?

lg
Triton
Member
Member
Beiträge: 88
Registriert: 22. Feb 2004, 17:20

Beitrag von Triton »

Du musst Deinem Kernel noch sagen dass er Forwarding machen soll.

# echo "1" > /proc/sys/net/ipv4/ip_forward

Dann sollte Ping von jedem beliebigen PC aus Deinem lokalen Netz funktionieren. Alleine Masquerading reicht nicht, der Kernel braucht IP-Forward.
Beachte aber wenn Du deinen Linux-Rechner runterfährst immer den oben genannten Befehl eingeben musst bei Neustart.

Gruss
jado
Member
Member
Beiträge: 170
Registriert: 4. Mär 2004, 11:00
Wohnort: Hamburg

Beitrag von jado »

Um die Routing-Funktion dauerhaft zu konfigurieren,
kann man auch in der Datei /etc/sysconfig/sysctl
den Parameter IP_FORWARD="yes" setzen.
ghostbones
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jan 2004, 12:03
Kontaktdaten:

Beitrag von ghostbones »

Hab mit yast das ip_forward schon auf yes gestellt, geht aber leider tortzdem nicht.
ghostbones
Newbie
Newbie
Beiträge: 19
Registriert: 11. Jan 2004, 12:03
Kontaktdaten:

Geschaft

Beitrag von ghostbones »

Hab heut noch mal die meisten einstellungen überprüft, und da bin ich drauf gekommen, das was mit den dns einträgen nicht ganz stimmt. hab das problem behoben, und jetzt funktioniert alles. :D

Danke an alle die mir geholfen haben, oder helfen wollten.

lg
Antworten