Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SUSE 9.0: WG511-> Firmware wird nicht geladen!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Jenny
Newbie
Newbie
Beiträge: 1
Registriert: 9. Mär 2004, 22:33
Wohnort: Hamburg

SUSE 9.0: WG511-> Firmware wird nicht geladen!

Beitrag von Jenny »

:roll: Liebes Forum!

Ich benutze Suse 9.0 und habe mir die Netgear WG511 gekauft. Als treiber habe ich die prism54.org Treiber installiert und der frirmware.agent und die firmware liegen in den dort beschriebenen Verzeichnissen.

Die Karte wird auch erkannt, doch es blinken keinerlei LEDs auf. In der /var/log/messages habe ich nun entdeckt, dass die offenbar die firmware nicht geladen werden kann. Hier mal ein kurzer Ausschnitt aus der Datei:

Mar 9 18:18:39 linux kernel: Loaded prism54 driver, version 1.0.2.2
Mar 9 18:18:39 linux kernel: eth0: prism54 driver detected card model: Netgear WG511
Mar 9 18:18:39 linux insmod: Using /lib/modules/2.4.21-99-default/kernel/lib/firmware_class.o
Mar 9 18:18:39 linux insmod: Symbol version prefix ''
Mar 9 18:18:39 linux insmod: Using /lib/modules/2.4.21-99-default/kernel/drivers/net/wireless/prism54/prism54.o
Mar 9 18:18:40 linux /etc/hotplug/pci.agent[1110]: writing pcmcia-1 to /var/run/hotplug/net
Mar 9 18:18:40 linux /etc/hotplug/net.agent[1152]: Using HW description eth-pcmcia-1
Mar 9 18:18:40 linux kernel: eth0: islpci_open()
Mar 9 18:18:40 linux kernel: eth0: resetting device...
Mar 9 18:18:40 linux kernel: eth0: uploading firmware...
Mar 9 18:18:40 linux kernel: firmware_class.c:call_helper: firmware: /sbin/hotplug firmware add
Mar 9 18:18:41 linux kernel: prism54: request_firmware() failed for 'isl3890'
Mar 9 18:18:41 linux kernel: eth0: could not upload firmware ('isl3890')
Mar 9 18:18:41 linux /etc/hotplug/net.agent[1152]: SIOCSIFFLAGS: No such file or directory
Mar 9 18:18:46 linux kernel: eth0: islpci_open()
Mar 9 18:18:46 linux kernel: eth0: resetting device...
Mar 9 18:18:46 linux kernel: eth0: uploading firmware...
Mar 9 18:18:46 linux kernel: firmware_class.c:call_helper: firmware: /sbin/hotplug firmware add
Mar 9 18:18:46 linux kernel: remove_proc_entry: 06:00.0/loading busy, count=1
Mar 9 18:18:46 linux kernel: remove_proc_entry: firmware/06:00.0 busy, count=1
Mar 9 18:18:46 linux kernel: prism54: request_firmware() failed for 'isl3890'
Mar 9 18:18:46 linux kernel: eth0: could not upload firmware ('isl3890')

Hat jemand von Euch so was ähnliches schon mal gehabt? Bin für jede Hilfe von Euch dankbar!

Viele liebe Grüße,
Jenny
:P
derQuader
Newbie
Newbie
Beiträge: 3
Registriert: 29. Apr 2004, 17:55
Kontaktdaten:

Beitrag von derQuader »

Hi Jenny, ich weiß nicht, ob dir schon geholfen wurde, aber ich glaube, daß du die Firmware, die du im Verzeichnis /usr/lib/hotplug/firmware hast nicht in "isl3890" um benannt hast... bei mir war das jedenfalls das Problem und die Fehlermeldung sah einigermaßen ähnlich aus...
viel Erfolg :-)
Christian Kotz
Newbie
Newbie
Beiträge: 2
Registriert: 5. Jul 2004, 10:51
Wohnort: Wien
Kontaktdaten:

Beitrag von Christian Kotz »

Bei mir SuSE 9.0 Professional ung Netgear WG511 kann die Firmware, wie bei Dir ebenfalls scheinbar nicht geladen werden - obwohl ich Sie in isl3890 umbenannt habe. Auch mit isl3890.arm geht es nicht.
Nach Durchlesen des firmware.agent scripts fand ich heraus, dass diese in ein Verzeichnis oder eine Datei /proc/????/data zu kopieren ist, wobei ????? für das Device steht, dass der Kernel übergibt. Leider konnte ich es aber nicht von Hand probieren, da ich den Namen dieses Verzeichnis/Datei auf meiner Installation nicht herausfinden konnte.

Wer kann mir weiterhelfen?
Mad Elk
Member
Member
Beiträge: 133
Registriert: 12. Apr 2004, 18:56

Beitrag von Mad Elk »

Christian Kotz
Newbie
Newbie
Beiträge: 2
Registriert: 5. Jul 2004, 10:51
Wohnort: Wien
Kontaktdaten:

Problem gelöst

Beitrag von Christian Kotz »

in meiner Version von firmware.agent waren HTML tags enthalten (konkret > als >) Nach Ausbesserung lief alles OK.
Catscratch1
Newbie
Newbie
Beiträge: 7
Registriert: 3. Jul 2004, 13:23

Beitrag von Catscratch1 »

Also ich weiß nicht wie es bei der 9.0 Version ist,
aber in der 9.1 Version kannst beim YOU (Yast Online Update) den Prim54 Treiber auswählen, so dass du selbst nix machen musst!
Meine WG511 funktioniert einwandfrei!!
Antworten