Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse 9.0 W-LAN mit ACX-Chip + Integration in Bootprozess

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
DaBomb

Suse 9.0 W-LAN mit ACX-Chip + Integration in Bootprozess

Beitrag von DaBomb »

Hallo W-Lan Freunde,

ich erlaube mir hier ein kleines Turtorial zu verfassen, welches Euch bei der Einrichtung von W-Lan unter SuSE (TestSuSE 9.0 pro) helfen soll.

Wichtig: Kernelversion: "unterhalb" der 2.6.x Version

Dieses Turtorial bezieht sich auf Karten mit ACX-Chips (z.B. D-Link DWL650+), welche nicht durch die mitgelieferten Treiber supportet werden.

#####################################################
Ich werde es in zwei Schritten erklären.
Schritt 1: Treiber installation + Wireless Lan startklar machen
Schritt 2: Bootreihenfolge ändern, sodass Wireless Lan nach dem Booten funktioniert
#####################################################

Schritt 1: Der Treiber:

Kurz vorweg: zur Sicherheit solltet Ihr die Kernel-Sourcen und PCMCIA Kernel-Sourcen installieren
YAST - Software - SystemUpdate -

Weitergehts mit der Installation des acx - Treibers.
Zuerst Downloaden des Treibers unter http://sourceforge.net/projects/acx100/.
Nun ist der Treiber nach (z.B. : /home/xxx/wlan) zu kopieren und mit "tar -xvzf name_des_treibers" zu entpacken. Anschließend wechseln wir in das neu entstandene Verzeichnis /acx100.... und gebt "make driver" und dann "make install" ein (als root)..

Nachdem der Treiber installiert wurde, müsst Ihr noch ein Script anpassen (/home/xxx/wlan/acx100/scripts). In diesem Pfad befindet sich ein Script Namens "start_net". Öffnet eine Konsole und entsprechnd das Script.
Ich setze hier einen Beispielauszug rein. Ihr müsst nur Euere KonfigDaten einsetzen:

# Please edit here

DEV=wlan0
IP=192.168.1.3
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
ESSID="Wireless" # THIS IS CASE SeNsItIvE!! any == associate to any ESSID
# Default rate configured as 11Mbps to not cause connection problems with non-22Mbps hardware...
RATE=22M
CHAN=6 # it's useful to try to stick to channels 1, 6 or 11 only, since these don't overlap with other channels
#TXPOWER=16 # 16 == 16.5dBm, 18 == 18dBm (default)
MODE=Managed
DEBUG=0xb
KEY="DeinKeyHierEintragen" # WEP128
ALG=restricted # open == Open System, restricted == Shared Key

# Usually no editing should be required below this line...
# -- unless you want this script to fetch stuff with dhcp

#########################################

Nachdem Ihr das Script angepasst habt, ist noch ein wichtiger Schritt auszuführen:

Die Windowstreiber Eurer Karte downloaden, oder von CD einspielen und in folgenden Pfad kopieren:
/home/xxx/wlan/acx100.../firmware
jetzt in das Verzeichnis /firmware wechseln und folgenden Befehl eingeben:
mv WLANGEN.bin WLANGEN.BIN

Jetzt gilt es noch einen DNS (nameserver) bekannt zu machen:
Pfad: /etc/resolv.conf
Inhalt:
nameserver 194.25.2.129
search local


So, fertig.
Jetzt mit der Konsole in /home/xxx/wlan/acx100.../scripts wechseln und den Treiber starten: ./start_net (als root!)

_______________________________________________________________________
Nun ist der Treiber installiert und wie beschrieben zu starten.
Wer den Treiber jedoch in den Bootprozess integriert haben möchte,
befolge bitte noch Schritt 2
_______________________________________________________________________

Schritt 2: Die Bootreihenfolge + Treiberimplementierung

User für die Tätigkeit ist ausschließlich "root" und mit Konsole!!

Was ist zu tun?

1. Der Bootprozess muss abgeändert werden, hier speziell sollte PCMCIA (Im Falle der D-Link DWL650+) vor dem Aufbau des Network-Interface gestartet werden.

-> cd /etc/rc.d/rc5.d
Hier das PCMCIA Startparameter (war glaub ich original S09PCMCIA - kann aber anders sein, spielt jedoch keine Rolle, welche Zahl es ist; ich nehme als Beispiel S09pcmcia. Ihr müsst natürlich die in Euerem System angegebene Parameterdatei verwenden! Wichtig ist nur, das das "S" genommen wird, nicht das K14pcmcia !!!
-> mv S09pcmcia S04pcmcia
So, jetzt ist schonmal der Bootprozess geändert und PCMCIA wird vor dem Network interface gestartet, da dieses unter S05network definiert ist.

###############

2. Jetzt muss noch der Treiber in den Bootprozess (in S05network, da es ja das wlan0 Interface aufbaut) integriert werden.
-> vi S05network
Bei ca.60% vom Script (steht rechtsunten in der Konsole)
Ich setzt hier den entsprechenden Auszug des Start und Stop hier von meinem Script rein:
(die rot-markierten Stellen sind hier relevant; im Prinzip können sie einfach kopiert werden und bei Dir in Dein Script an die selbe Stelle eingebaut werden; Du musst jedoch den Pfad abändern auf den Pfad, wo Dein start_net und stop_net installiert ist !!!!! )
###############Start Auszug
rc_reset

case "$ACTION" in
start)
echo Setting up network interfaces:
# START VON WIRELESS LAN ACX100-Treiber
cd /home/XXX/download/wlan/acx100-0.2.0pre6/scripts
./start_net

set -- $CONFFILES ifcfg-$CONFIG
for CONF in ${@#ifcfg-}; do
printf " %-9s " $CONF
$FAKE ifup $CONF $INTERFACE -o $MODE ${BE_QUIET:+quiet} rc
RET=$?
debug && echo -n " (returned $RET)"
rc_failed $RET
case "$RET" in
$R_NOTCONFIGURED|$R_INACTIVE)
startmode=`get_startmode $CONF`
rc_startmode="${stat}${attn}$startmode${norm}"
echo -en "$rc_startmode" 1>&2
echo ;;
#EXTRA_MSG=yes ;;
*)
rc_status -v ;;
esac
rc_reset
done
[ ! -z "$WAIT_FOR_INTERFACES" ] && sleep $WAIT_FOR_INTERFACES
test -z "$CONFIG" && $FAKE ifup-route noiface -o $MODE ${BE_QUIET:+quiet} rc
;;

stop)
echo Shutting down network interfaces:
# STOP VON WIRELESS LAN ACX100-Treiber
cd /home/XXX/download/wlan/acx100-0.2.0pre6/scripts
./stop_net

test -z "$CONFIG" && $FAKE ifdown-route noiface \

########################## Ende Auszug

so, jetzt das Script mit :wq beenden und fertig.

Am Besten gleich testen; "Rechner neu starten" und siehe da -> ES GEHT!

:shock: 8) :lol: :) :D 8) :lol: :D :twisted:
Benutzeravatar
MrLinux
Newbie
Newbie
Beiträge: 3
Registriert: 12. Okt 2004, 17:46
Wohnort: Where the wind blows....

Re: Suse 9.0 W-LAN mit ACX-Chip + Integration in Bootprozess

Beitrag von MrLinux »

Beitrag gelöscht, da keine Antwort :(
Greetz, MrLinux
***LIVE LONG AND PROSPER***
Antworten