Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

loops back to myself

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Archilles
Newbie
Newbie
Beiträge: 27
Registriert: 21. Jun 2004, 14:34

loops back to myself

Beitrag von Archilles »

Hallo,

ich habe mit Postfix das Problem, dass ich moment empfangene Mails nicht weitergeleitet bekomme und ausgehende Mails ebensfalls beim Sender lande, aber nicht beim Empfänger.

Im Logfile habe ich folgende Meldungen:

Code: Alles auswählen

Apr 12 22:57:20 swallow postfix/smtpd[23751]: connect from imap.gmx.net[213.165.64.20]
Apr 12 22:57:20 swallow postfix/smtpd[23751]: BC73F89C009: client=imap.gmx.net[213.165.64.20]
Apr 12 22:57:20 swallow postfix/cleanup[23761]: BC73F89C009: message-id=<29604.1113339493@www11.gmx.net>
Apr 12 22:57:20 swallow postfix/qmgr[23715]: BC73F89C009: from=<tester@gmx.net>, size=881, nrcpt=1 (queue active)
Apr 12 22:57:20 swallow postfix/smtpd[23751]: disconnect from imap.gmx.net[213.165.64.20]
Apr 12 22:57:28 swallow postfix/smtpd[23765]: connect from localhost[127.0.0.1]
Apr 12 22:57:28 swallow postfix/smtpd[23765]: A48F289C00A: client=localhost[127.0.0.1]
Apr 12 22:57:28 swallow postfix/cleanup[23761]: A48F289C00A: message-id=<29604.1113339493@www11.gmx.net>
Apr 12 22:57:28 swallow postfix/qmgr[23715]: A48F289C00A: from=<tester@gmx.net>, size=1369, nrcpt=1 (queue active)
Apr 12 22:57:28 swallow postfix/smtp[23762]: BC73F89C009: to=<info@tester.de>, relay=127.0.0.1[127.0.0.1], delay=8, status=sent (250 2.6.0 Ok, id=23399-04, from MTA: 250 Ok: queued as A48F289C00A)
Apr 12 22:57:28 swallow postfix/qmgr[23715]: BC73F89C009: removed
Apr 12 22:57:28 swallow postfix/smtpd[23765]: disconnect from localhost[127.0.0.1]
Apr 12 22:57:28 swallow postfix/smtp[23766]: A48F289C00A: to=<info@tester.de>, relay=none, delay=0, status=bounced (mail for tester.de loops back to myself)
Apr 12 22:57:28 swallow postfix/cleanup[23761]: E871089C009: message-id=<20050412205728.E871089C009@swallow.service.net>
Apr 12 22:57:29 swallow postfix/qmgr[23715]: E871089C009: from=<>, size=3194, nrcpt=1 (queue active)
Apr 12 22:57:29 swallow postfix/qmgr[23715]: A48F289C00A: removed
Apr 12 22:57:49 swallow postfix/smtp[23766]: E871089C009: to=<tester@gmx.net>, relay=mx0.gmx.net[213.165.64.100], delay=21, status=sent (250 2.6.0 {mx029} Message accepted)
Apr 12 22:57:49 swallow postfix/qmgr[23715]: E871089C009: removed
Meine main.cf sieht so aus:

Code: Alles auswählen

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/lib/postfix
mailbox_command =
mailbox_size_limit = 0
mydestination = swallow.service.net, localhost.service.net, , localhost
mydomain = service.net
myhostname = swallow.service.net
mynetworks = 127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost =
setgid_group = postdrop
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = check_sender_access hash:/etc/postfix/access,   check_recipient_access hash:/etc/postfix/access,   permit_mynetworks,   permit_sasl_authenticated,   reject_unauth_destination,    permit
die virtual so:

Code: Alles auswählen

service.net                          anything


info@service.net                     andreas
webmaster@service.net                andreas





privatpraxis-dr-pfeiffer.de                     anything

info@privatpraxis-dr-pfeiffer.de                rpfeiffer

jogareisen-dr-pfeiffer.de                       anything

info@jogareisen-dr-pfeiffer.de                  rpfeiffer
postmap virtual und postfix reload habe ich stets gemacht. Kann mir jemand sagen, warum ich diese Fehler bekomme?

Gruß
Andreas
Archilles
Newbie
Newbie
Beiträge: 27
Registriert: 21. Jun 2004, 14:34

Beitrag von Archilles »

Also Leutchen,

ich frage mich wozu es das Forum hier gibt. Ich dachte, hier bekommst' e gute Hilfe und Lösungsansätze.
Nichts da! Wieder mal mußt du selber suchen und in wirklich guten Mailinglisten hast du wirkliche Profis bei der Hand.

Also Problemlösung sieht wie folgt aus:

Das neue Postfix bietet inzwischen virtual_alias_maps an und in die gehören meine virtuellen Domains hinein. Das war das ganze Problem.

Schade, dass das hier keiner gewußt hat.

Andreas
Benutzeravatar
wolfsohn
Member
Member
Beiträge: 100
Registriert: 30. Mai 2004, 14:21
Wohnort: Terra

Beitrag von wolfsohn »

oooh Fein.... hat auch mal jemand Eigeninitiative gezeigt... :D ... Respekt.... :wink:... Wunder geschehen... :idea:
OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid »

Archilles hat geschrieben:.....Wieder mal mußt du selber suchen und in wirklich guten Mailinglisten hast du wirkliche Profis bei der Hand.....
na dann brauchst du das forum hier ja nicht mehr ..... :D :D :D :D :D :D :D
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz
Gesperrt