Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

USB mp3 Player / Cardreader einbinden

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

USB mp3 Player / Cardreader einbinden

Beitrag von Timemaster »

So, nachdem ich mich ca. 2,5 Stunden durch alte Beiträge gewühlt habe, aber keinen meinem Problem eindeutig zuordnen konnte, mache ich dann doch noch mal einen eigenen auf. Sorry - die Lösung steht vermutlich schon irgendwo, da bitte ich dann im Zweifelsfall um Verweis, danke!

Ich möchte unter SuSE 9.1 einen USB 1.1 MP3 Spieler mit MMC / SD Cardreader einbinden. Da zunächst gar nichts ging, habe ich es zwischenzeitlich mit Knoppix probiert, was funktionierte (d.h. ich konnte zugreifen und Dateien übertragen, den Player benutzen).

Nach dem Neustart von SuSE kriege ich auch, was vorher nicht ging, eine Ausgabe von usbview - der sieht wie folgt aus:
PLAYER
Manufacturer: MP3
Serial Number: ABCD12346469
Speed: 12Mb/s (full)
USB Version: 1.10
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 8
Number of Configurations: 1
Vendor Id: 0dda
Product Id: 0001
Revision Number: 0.12

Config Number: 1
Number of Interfaces: 1
Attributes: 80
MaxPower Needed: 100mA

Interface Number: 0
Name: usb-storage
Alternate Number: 0
Class: 08(stor.)
Sub Class: 6
Protocol: 50
Number of Endpoints: 3

Endpoint Address: 81
Direction: in
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 02
Direction: out
Attribute: 2
Type: Bulk
Max Packet Size: 64
Interval: 0ms

Endpoint Address: 83
Direction: in
Attribute: 3
Type: Int.
Max Packet Size: 8
Interval: 10ms
Wie kann ich dieses Gerät einbinden bzw. darauf zugreifen?

TIA
T.
PS: hier noch meine fstab:
dev/hda1 / reiserfs acl,user_xattr 1 1
/dev/hda3 /home reiserfs acl,user_xattr 1 2
/dev/hda2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder auto noauto,ro,users,exec,iocharset=utf8 0 0
/dev/dvd /media/dvd auto noauto,ro,users,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
heinzi@ch
Newbie
Newbie
Beiträge: 6
Registriert: 29. Mär 2005, 21:05
Wohnort: Winterthur

USB mp3 Player

Beitrag von heinzi@ch »

Hallo Timemaster

Ja mit SuSE 9.1 hatte ich auch probleme mit dem mp3player anbinden, mit 9.2 wirds dann noch schlimmer.

Schau mal im /var/log/messages, da stehen warscheinlich jede menge Errormeldungen welche in etwa wie folgt beginnen:
sda:<3>Buffer I/O error on device sda, logical block 0

Bei SuSe 9.1kannst Du das Problem noch umgehen indem Du den hotplugger stoppst und dann das ganze manuell mountest. Ich gehe davon aus, dass Dein MP3 Player auch ein vfat Filesystem hat.

Probier mal:
rchotplug stop
mount -t vfat /dev/sda1 /media/mp3player

Der Device kann natürlich varieren, je nachdem was Du schon alles angehängt hast. Der mountpoint muss natürlich auch existieren.

Gruss
Heinzi@ch
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

Probier mal:
rchotplug stop
mount -t vfat /dev/sda1 /media/mp3player
(als root natürlich)

Ah, danke, das klappt schon mal (Device ist bei mir das gleiche, Mountpoint ist /media/sda1). Wie gebe ich mir (als user) Schreibzugriff auf das Device?

T.
heinzi@ch
Newbie
Newbie
Beiträge: 6
Registriert: 29. Mär 2005, 21:05
Wohnort: Winterthur

USB mp3 Player

Beitrag von heinzi@ch »

Hallo Timemaster

vfat kennt keine Filesystemberechtigungen. Wenn was verkehrt ist so müsste es wohl an Deinem Mountpoint liegen. Wenn Du diesen mir root erstellt hast wird der wohl auch root gehören.

Prüf mal mit ls -l wem das Ding gehört und wie die Filesystemberechtigungen sind. Den owner änderst Du mit chown, die Filesystemberechtigung mit chmod. Dazu musst Du natürlich root sein.


Gruss
Heinzi@ch
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Re: USB mp3 Player

Beitrag von Timemaster »

heinzi@ch hat geschrieben: vfat kennt keine Filesystemberechtigungen. Wenn was verkehrt ist so müsste es wohl an Deinem Mountpoint liegen. Wenn Du diesen mir root erstellt hast wird der wohl auch root gehören.
Klar, muß ja, da nur root den mount Befehl ausführen darf.

Allerdings konnte ich gestern selbst als root nicht schreibend auf das Gerät zugreifen. Jetzt scheint es doch zu funktionieren, also habe ich wohl etwas anderes falsch gemacht. "Leider" kann ich den Fehler jetzt nicht reproduzieren, weiß also nicht, was (ja, es war spät... *g*).

Danke für die Hilfe schon mal!

Muß ich die genannten Schritte jedesmal manuell durchführen, oder läßt sich das auch dauehaft einrichten?

T.
PS. wie genau wende ich den chown Befehl an?
Benutzeravatar
TeXpert
Guru
Guru
Beiträge: 2166
Registriert: 17. Jan 2005, 11:22

Beitrag von TeXpert »

man mount hilft Dir weiter,

da vfat keine Rechte kennt, musst Du die als Option beim Mounten mit angeben, also mach mal als Root ein:

Code: Alles auswählen

mount -t vfat -o gid=users,umask=0002  /dev/sda1 /media/mp3player 
[/code]

Code: Alles auswählen

# to resolve all your problems, try this:
HOWTO='pack c5,41*2,sqrt 7056,unpack(c,H)-2,oct 115' && perl -le "print $HOWTO"
Ich beantworte keine Supportfragen per PM!
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

TeXpert hat geschrieben:man mount hilft Dir weiter,
Um ehrlich zu sein, eher nicht. Das ist ungefähr zwei Nummern zu hoch für mich.
also mach mal als Root ein:

Code: Alles auswählen

mount -t vfat -o gid=users,umask=0002  /dev/sda1 /media/mp3player 
[/code]
Das gibt dann:
/dev/sda1 ist kein gültiges blockorientiertes Gerät
T.
heinzi@ch
Newbie
Newbie
Beiträge: 6
Registriert: 29. Mär 2005, 21:05
Wohnort: Winterthur

Beitrag von heinzi@ch »

Hi Timemaster

Code: Alles auswählen

/dev/sda1 ist kein gültiges blockorientiertes Gerät:
Das klingt wieder nach dem ursprünglichen Problem. Wenn Du die Kiste gebootet hast, musst Du rchotplug wieder stoppen.
Damit wird der hotplugger nur temporär gestoppt. Würde ich Dir auch so empfehlen, da Du den hotplugger brauchst, wenn Du ander USB geräte einsteckst.
Ansonsten muss Du hotplug aus dem Bootprozess entfernen.z.B mit Yast -> System -> Runlevel-Editor

Was die "man pages" betrifft, damit kannst Du eine manpage (Manual Seite) über die meisten Befehle anzeigen lassen. Mit dem Befehl

Code: Alles auswählen

man man
kannst Du Dir also die Hilfe Seiten über den Befehl man anzeigen lassen.
Viele davon sind nur in Englisch vorhanden. Aber es gibt jede Menge deutsche Handbücher auf dem Web:
http://www.linuxfibel.de/
http://www.fhworld.de/linux/
http://www.linuxwiki.de/OriginaleStartSeite

Hoffe das hilft weiter.

Gruss
Heinzi@ch
Benutzeravatar
Timemaster
Member
Member
Beiträge: 74
Registriert: 13. Apr 2004, 21:33

Beitrag von Timemaster »

heinzi@ch hat geschrieben:Hi Timemaster
Das klingt wieder nach dem ursprünglichen Problem.
Jepp.
Wenn Du die Kiste gebootet hast, musst Du rchotplug wieder stoppen.
Damit wird der hotplugger nur temporär gestoppt.
Schon klar. Hatte ich auch gemacht. Ging trotzdem nicht.
Was die "man pages" betrifft, damit kannst Du eine manpage (Manual Seite) über die meisten Befehle anzeigen lassen.
Ich weiß. Nur kann ich in besagtem Fall mit dem Inhalt dieser Seiten nicht viel anfangen, da ich einfach zu wenig weiß, um das auf mein Problem beziehen zu können.
Hoffe das hilft weiter.
In diesem speziellen Fall leider nicht, trotzdem danke.

Ich werde mich wohl vorerst damit zufrieden geben müssen, daß ich das Gerät nur unter Knoppix benutzen kann - ist umständlich, aber funzt. Für michals Laien nicht nachvollziehbar, daß das unter SuSE so gar nicht geht, aber so isses nun mal...

T.
Antworten