Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Licq installieren - X11 libs und headers fehlen

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Licq installieren - X11 libs und headers fehlen

Beitrag von n0named »

Moin, hab heut versucht licq zu installen. Hab dann ./configure ausgeführt und dann kam der Fehler beim installieren der qt-gui :
checking for X... no
configure: error: You need to have the X11 libraries and headers installed
Tjo, scheiße oder? Laut yast is das alles installiert, ausser das devel paket. Und x11 jetzt manuell zu installieren, da trau ich mich jetzt nicht ran und das kann ich auch noch ned.
Also kann mir einer sagen, was ich tun soll?
PS: Bin noob im Linux Bereich ;)
Greetz
}-Tux-{
Hacker
Hacker
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ »

xorg-x11-devel installieren...
dann fehlen die bestimmt auch noch die kdelibs3-devel usw...
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Beitrag von n0named »

Die werden mir ja in yast nicht gelisted :(
Wo krieg ich die denn sonst her?
Greetz und danke für die Antwort
EDIT :
Irgendwie werden mir gar keine devel pakete gelisted :/
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

n0named hat geschrieben:Irgendwie werden mir gar keine devel pakete gelisted :/
Was für ne SuSE hast Du denn ? Personal ? Da sind keine devel Pakete dabei. Die mußt Du dann vom ftp Server etc installieren.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Beitrag von n0named »

Öhm, ich hab das FTP-Retail (dvd). Suse 9.2
Na dann schau ich ma schnell auf dem ftp, thx ;)
Greetz
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Beitrag von n0named »

So, jetzt hab ich das Devel Paket für x11, nur um das zu installieren wird jetzt fontconfig-devel benötigt, das ich nirgendwo finde im netz, nur die normalen srcs find ich. Irgendwie bin ich am verzweifeln, und das nur wegen dem licq ^^
Greetz
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Für SuSE 9.2 gibts licq fertig kompiliert in den apt Repositorien:

http://ftp.gwdg.de/pub/linux/suse/apt/s ... 9.i586.rpm

Ich benutze inzwischen apt zum Installieren von rpms. Schau mal in die apt-Sektion rein.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Beitrag von n0named »

vielen vielen dank
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Beitrag von n0named »

Moin ;)
Hab jetzt apt installiert, dann gleich licq installed.
Hat alles perfekt geklappt, nur wenn ich jetzt licq ausführen will, kommt kurz die grüne Blume, die rumhüpft und dann passiert gar nix :(
Es kommt auch keine Fehlermeldung. Woran kann das liegen?
Greetz
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

licq aus der Shell heraus ausführen, Fehlermeldung hier posten...
n0named
Newbie
Newbie
Beiträge: 8
Registriert: 30. Dez 2004, 03:05
Kontaktdaten:

Beitrag von n0named »

19:15:57: [WRN] Licq: Ignoring stale lockfile (pid 11961)
19:15:57: [ERR] Unable to load plugin (qt-gui): /usr/local/lib/licq/licq_qt-gui.so: cannot open shared object file: No such file or directory.

Das kommt, ich habs ja auch schon versucht manuell zu installieren. Hat auch geklappt, aber ich musste halt die qt-gui noch installen, na gut, dann configure -> Checking for X...
Dann steht da, dass mir die x11 libs und headers fehlen.
Dann wollt ich x11-devel installieren, kommt von Yast die Fehlermeldung, dass ich fontconfig-devel benötige. Gut, dann fontconfig installliert. Die angebliche devel. Und dann wieder versucht x11-devel zu installiieren, kommt wieder die Meldung dass ich fontconfig benötige.
Greetz
}-Tux-{
Hacker
Hacker
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ »

wie jetzt??
jetzt hast du ein "mix" aus rpm und selbst kompilierten zeugs???
erklär mal was du genau gemacht hast...
btw.: hast du das auch noch nach /usr/local installiert? :roll:


mfg }-Tux-{
Antworten