Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

iproute2 + iptables Probleme

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Gast

iproute2 + iptables Probleme

Beitrag von Gast »

also, ich habe hier eine Adamantix-Box mit iptables und iproute, die iptables sind soweit eingerichtet dass man problemlos über eth1 internetzugriff hat, jedoch soll nun ein client an eth0 gehängt werden, der dann ganz bequem über die linux-box als gateway auf das internet zugreifen kann, wie muss ich hierfür iproute konfigurieren? ich habe schon extrem viel versucht, kein einziges der ganzen howtos hat bisher funktioniert, die fehler gingen von fehlerhaftem syntax (obwohl ich exakt übernahm und alle nötigen Dinge angepasst hatte) bis hin zu völlig unlogischen iptable-rules....also, falls jemand helfen kann bitte EXAKTE UND KORREKTE befehle posten, die auch wirklich funktionieren, ich kann es mir aus diversen gründen nicht nochmal leisten etwas nicht-funktionierendes zu basteln.....

eth1 hängt an einem Router per DHCP (192.168.0.x)
eth0 hängt am LAN per static ip (176.13.180.1), soll gateway werden
der betroffene client hat 176.13.180.2
iptables blockt alles bis auf einige sachen wie port 80 INPUT, SSH2 INPUT u.ä....
Gast

Beitrag von Gast »

na kommt schon, niemand da der mir helfen kann??
IRGENDWEN gibt es immer :D
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Re: iproute2 + iptables Probleme

Beitrag von Martin Breidenbach »

tha_specializt hat geschrieben:....also, falls jemand helfen kann bitte EXAKTE UND KORREKTE befehle posten, die auch wirklich funktionieren, ich kann es mir aus diversen gründen nicht nochmal leisten etwas nicht-funktionierendes zu basteln.....
Wir auch nicht.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Gast

Beitrag von Gast »

ja, ganz toller post das....mein problem habe ich mittlerweile selbst gelöst: einfach IPCop draufgemacht und gut is..... ich sehe zwar absolut keinen unterschied zwischen meinen iptables-regeln und denen von ipcop, aber seltsamerweise geht es..... vielleicht war ja auch einfach nur iptables geschrottet (warum auch immer)
--> anstatt sowas sinnfreies zu posten hättest mir auch einfach nen tip geben können....smoothwall, ipcop und ähnliche programm sind mit nur einer (!!) zeile zu erwähnen und schon hätte ich fertich gehabt, aber NEIN ich muss natürlich erstma das komplette inet durchsuchen um hilfe zu kriegen, ne....
Antworten