Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SSH Zugriff Funzt nicht

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
virus2000
Newbie
Newbie
Beiträge: 17
Registriert: 22. Feb 2005, 10:52

SSH Zugriff Funzt nicht

Beitrag von virus2000 »

Hi @ll,

Bevor einer Kommt mit Google und versuch die suche das hab ich schon.
Das Problem ich kann micht via SSH nicht auf meiner Suse 9.2 Maschien Anmelden weder mit SSH noch mit Putty. Ich bekomme einen Auth. Failer.

Ich habe auch scon in der Datei sshd_conf die Einträge
PasswordAuthentication no
und
UsePAM yes

Editiert aber es geht nicht. Firewall hab ich auch Komplett abgeschalten und SSH ist auch Installiert auf der Maschiene!

MFG

Clemens
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

Bei sowas hilft erstmal ein 'ssh -v user@host' und die Ausgabe hierher.

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin

Beitrag von taki »

- installiert schon, aber auch gestartet?
SuSE 12.3 kernel 3.7.10-1.16-desktop, K Desktop Environment Version 4.10.5 r1 - Medion Titanium Aldi v. 03/2009
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

taki hat geschrieben:- installiert schon, aber auch gestartet?
Naja, dann würde er ja wohl eher einen 'Connection Refused' Fehler bekommen und kein 'Auth. Failure' (es sei denn, er lügt uns an...)
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
virus2000
Newbie
Newbie
Beiträge: 17
Registriert: 22. Feb 2005, 10:52

Beitrag von virus2000 »

Ja es ist Gestartet warum sollte ich euch anlügen was gäbe das für einen sin.

Also nach einem Test sieht es folgendermassen aus. Wenn ich von Suse zu Suse eine SSH verbindung mache geht es. Aber mache ich von einem Winclient via SSH oder Putty geht es nicht. Hier das File über einen Suse Rechner da ich es über einen Win ja nicht bekomme:

admin@pc427-3:~> ssh -v root@openexchange
OpenSSH_3.9p1, OpenSSL 0.9.7d 17 Mar 2004
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 195.95.xxx.xxx [195.95.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file /home/admin/.ssh/identity type -1
debug1: identity file /home/admin/.ssh/id_rsa type -1
debug1: identity file /home/admin/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.9p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
The authenticity of host '195.95.xxx.xxx (195.95.xxx.xxx)' can't be established.
RSA key fingerprint is a7:78:bf:ee:71:2b:01:57:8b:e7:e8:15:51:6f:07:da.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '195.95.xxx.xxx' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/admin/.ssh/identity
debug1: Trying private key: /home/admin/.ssh/id_rsa
debug1: Trying private key: /home/admin/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
Last login: Tue Apr 5 14:59:47 2005 from openexchange.mmc1
Have a lot of fun...
openexchange:~ #


Clemens
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

virus2000 hat geschrieben:Ja es ist Gestartet warum sollte ich euch anlügen was gäbe das für einen sin.
War natürlich nicht ernst gemeint. Du solltest nur nochmal überprüfen, ob du wirklich das richtige geschrieben hast ;-)
virus2000 hat geschrieben: Also nach einem Test sieht es folgendermassen aus. Wenn ich von Suse zu Suse eine SSH verbindung mache geht es. Aber mache ich von einem Winclient via SSH oder Putty geht es nicht. Hier das File über einen Suse Rechner da ich es über einen Win ja nicht bekomme:
Was ist denn das für ein 'SSH' auf deinem Winclient ? Kann das kein '-v' ? Putty hat auf jeden Fall ein 'plink.exe'. Das kennt '-v'.

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
virus2000
Newbie
Newbie
Beiträge: 17
Registriert: 22. Feb 2005, 10:52

Beitrag von virus2000 »

Hier das File


D:\Programme\PuTTY>plink -v root@195.95.xxx.xxx
Looking up host "195.95.xxx.xxx"
Connecting to 195.95.xxx.xxx port 22
Server version: SSH-1.99-OpenSSH_3.9p1
We claim version: SSH-1.5-PuTTY-Release-0.53b
Using SSH protocol version 1
Received public keys
Host key fingerprint is:
1024 e8:5a:4b:77:ec:ed:3d:e4:7a:bb:b1:e6:62:c5:4a:8a
Encrypted session key
AES not supported in SSH1, skipping
Using Blowfish encryption
Trying to enable encryption...
Successfully started encryption
Sent username "root"
root@195.95.xxx.xxx's password:
Sending password with camouflage packets
Sent password
Access denied
Authentication refused
root@195.95.xxx.xxx's password:


MFG

Clemens
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

Welchen Wert hat denn 'PermitRootLogin' in deiner sshd_config ?
(bzw. setz' das auf 'yes', wenn du wirklich root-Login erlauben willst)

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
virus2000
Newbie
Newbie
Beiträge: 17
Registriert: 22. Feb 2005, 10:52

Beitrag von virus2000 »

HI,

hab ich aber geht nicht. Anderer User geht auch nicht!

Clemens
Thomas4000
Member
Member
Beiträge: 178
Registriert: 8. Aug 2004, 20:20
Wohnort: Bayern

Beitrag von Thomas4000 »

Using SSH protocol version 1
...ist sehr verdächtig! Putty kann auch SSH V2, und IHMO ist bie Suse seit einigen Releases SSH V2 Standard. Also in den Putty-Einstellungen umstellen.
foobar
Newbie
Newbie
Beiträge: 4
Registriert: 8. Apr 2005, 20:39

Beitrag von foobar »

hi,

dieser teil sagt was aus:
Sent username "root"
root@195.95.xxx.xxx's password:
Sending password with camouflage packets
Sent password
Access denied
Authentication refused
root@195.95.xxx.xxx's password:
Sry. zu schnell überflogen obiger Beitrag ist beizupflichten, per ssh2 protokoll verbinden ansonsten in der sshd_conf PasswordAuthentication yes stellen.
gruß foo
Antworten