Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Displayfreigabe mit dem xhost +

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

[Gelöst] Displayfreigabe mit dem xhost +

Beitrag von warpi »

Hallo.
Habe die Einstellungen wie folgt gemacht:
Rechner1 export DISPLAY=Rechnername:0.0 (im /home/benutzer/.profile)
Rechner2 xhost + (in der /home/benutzer/.bashrc)
Anmeldung über ssh:
ssh -X benutzer@Rechner1
nach Passworteingabe der Aufruf eines Programms(nedit) mit & am Ende. Keine Fehlermeldung aber auch keine Ausgabe. nedit ist auf beiden Rechnern.
Habe ich noch was übersehen?
Zuletzt geändert von warpi am 7. Apr 2005, 06:43, insgesamt 1-mal geändert.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

Das Setzen von DISPLAY und der Aufruf von xhost ist bei Verwendung von X11-Forwarding gerade nicht nötig (lies nochmal nach, wie das funktioniert).
Nimm mal beides weg und wenn du dich auf dem Rechner1 angemeldet hast, sag mal 'echo DISPLAY'.

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Danke für den Tipp.
Werde es heute abend mal ausprobieren.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Hi snaewe
habe die Einträge auf Kommentar gesetzt.
Hier der Display:
Password:
Last login: Tue Apr 5 16:47:08 2005 from warpi.chaos
Have a lot of fun...
user@rechner1i:~> echo DISPLAY
DISPLAY
Habe keine Ahnung ob das hilft. Die Firewall ist auf beiden Rechnern deaktiviert.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

:oops: :oops:
Sorry! Mein Fehler. Ich meinte

Code: Alles auswählen

echo $DISPLAY
Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
Neotron
Hacker
Hacker
Beiträge: 256
Registriert: 30. Jan 2005, 18:51

Beitrag von Neotron »

Die ganze export-Display-Geschichte war mir zu kompliziert und irgendwie scheint das unter SuSE9.2 nicht mehr zu klappen (Sicherheitseinstellung??).

Ich nutze jetzt jedenfalls kssh. Solltet ihr Euch mal ansehen. Wirklich praktisch.
Gruß
Neotron
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Neotron hat geschrieben:...und irgendwie scheint das unter SuSE9.2 nicht mehr zu klappen (Sicherheitseinstellung??).
Da gibts glaube ich eine Einstellung die man bei SuSE 9.2 setzen muß damit X Verbindungen von außen annimmt. Details weiß ich nicht mehr; es gibt einen Eintrag in der SuSE Supportdatenbank. Einen Link darauf habe ich neulich beim Rumsuchen nach 'xhost' oder so ähnlich hier im Forum gefunden.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Morgen.
Also habe jetzt die ssh-Verbindung getestet. Hier die Ausgaben:
user@warpi:~> ssh -v -X user@soli
OpenSSH_3.9p1, OpenSSL 0.9.7d 17 Mar 2004
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to soli [10.2.106.29] port 22.
debug1: Connection established.
debug1: identity file /home/user/.ssh/identity type -1
debug1: identity file /home/user/.ssh/id_rsa type -1
debug1: identity file /home/user/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.9p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'soli' is known and matches the RSA host key.
debug1: Found key in /home/user/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/user/.ssh/identity
debug1: Trying private key: /home/user/.ssh/id_rsa
debug1: Trying private key: /home/user/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
Password:
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
Last login: Wed Apr 6 06:26:24 2005 from warpi.chaos
Have a lot of fun...

Hier wird nedit aufgerufen & danach mit strg + c abgebrochen weil nichts mehr passiert.
user@soli:~> nedit

user@soli:~> echo $DISPLAY
warpi:0.0
user@soli:~>

Sieht doch nicht schlecht aus oder??
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

1. Starte mal 'nedit' ohne '&'. Ausgabe ?
2. DISPLAY sollte ungefähr 'localhost:10:0' heissen (abhängig vom Setting 'X11DisplayOffset') !

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Morgen snaewe.
Hab ich ja(die letzten Zeilen)nedit
Bei dem Aufruf echo $DISPLAY kommt localhost:10:0
Wenn ich dann die DISPLAY-variable im .profile setze, dann kommt warpi:0.0
Ich werde mal versuchen über die Freigaben im KDE was zu machen. Bei mir in der Arbeit funktioniert ssh ja auch(selbst zu einer AIX) :wink:
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

warpi hat geschrieben:Hab ich ja(die letzten Zeilen)nedit
Da sollte aber sowas wie 'NEdit: Can't open display' erscheinen
warpi hat geschrieben:Bei dem Aufruf echo $DISPLAY kommt localhost:10:0
So soll's sein!
warpi hat geschrieben:Wenn ich dann die DISPLAY-variable im .profile setze, dann kommt warpi:0.0
Das sollst du gerade nicht machen !!! DISPLAY muss auf 'localhost:10.0' stehen, damit das X11-Forwarding funktioniert (Stichwort 'SSH Tunnel')
warpi hat geschrieben:Ich werde mal versuchen über die Freigaben im KDE was zu machen.
Das verstehe ich nicht. Was willst du damit erreichen ?

Wenn DISPLAY=localhost:10.0 dann starte mal 'nedit'.

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Hi snaewe.
Danke für die ausführliche Antwort.
Mit KDE meine ich irgend ein Menu(was ich mal gesehen habe)wo man freigaben machen kann.
Zu dem nedit aufruf, das ist ja gerade das was mich verwundert. Es kommt kein 'Can't open display'. Es passiert gar nichts.
Heute am Abend oder morgen früh werde ich nochmal im .profile den Displayeintrag deaktivieren.
Melde dann das Ergebnis.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Benutzeravatar
snaewe
Hacker
Hacker
Beiträge: 415
Registriert: 13. Dez 2004, 16:32
Wohnort: Zu Hause

Beitrag von snaewe »

warpi hat geschrieben: Zu dem nedit aufruf, das ist ja gerade das was mich verwundert. Es kommt kein 'Can't open display'. Es passiert gar nichts.
Warte einfach mal länger als 10sek.

Stefan
Der Name Windows stammt ursprünglich aus dem Indianischen und
bedeutet: "Weißer Mann, der auf eine Sanduhr starrt."
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Morgen snaewe.
Habe jetzt die Einträge auskommentiert.

Der Aufruf ssh user@soli
Last login: Thu Apr 7 05:24:30 2005 from console
Have a lot of fun...
user@soli:~> echo $DISPLAY

soli@soli:~>


Der Aufruf ssh -X user@soli
Password:
Last login: Thu Apr 7 05:35:42 2005 from warpi.chaos
Have a lot of fun...
user@soli:~> echo $DISPLAY
localhost:10.0

So geht's jetzt. ':lol:
Danke für die Hilfe ':D'
Zuletzt geändert von warpi am 7. Apr 2005, 09:51, insgesamt 1-mal geändert.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Nachtrag:
Martin Breidenbach meinst du vielleicht den Eintrag in der /etc/ssh/sshd_config <X11Forwarding yes> ?
Kann mir jemand sagen, wie der Befehl für den KDE heißt? Damit die Ausgabe so rüberkommt, als ob ich direkt auf den Monitor gehen würde.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Ich habe da ja nur zufällig was gelesen... ich glaube das war eine Einstellung bei den Systemvariablen im Yast.

Mal SuSE SDB anwerfen...

Der Artikel paßt gut zum Thema (habe ich eben gefunden als ich den anderen da unten suchte):

http://portal.suse.com/sdb/de/1997/06/maddin_xhost.html

Das was ich meinte ist das hier:

http://portal.suse.com/sdb/de/2004/05/x ... _6000.html
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Abend Martin Breidenbach.
Bei mir läufts jetzt über das X-Forwarding Feature von SSH. Damit kann man sich sogar, trotz aktiven Firewall, mit dem anderen Rechner verbinden. :wink:
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Antworten