Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Samba und WindowsME

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Terminator
Newbie
Newbie
Beiträge: 12
Registriert: 27. Mär 2005, 22:28
Wohnort: in den Binary-Sourcen
Kontaktdaten:

Samba und WindowsME

Beitrag von Terminator »

Hallo,

Habe seit neustem ein neues System auf meinem (privaten) Server, er soll Webserver und Fileserver (Samba) sein. Ich habe es so eingerichtet, dass wenn ich auf ein Share zureiffen will, ein passwd abfrage kommt.
Dort muss ich Username und Passwort eingeben.

Bei den Linux Clients funktioniert das auch genauso wie bei allen XP Clients nur der eine Windows ME Rechner macht Probleme.


In der Netzwerkumgebung den Server "sehen" und wenn ich darauf klicke kann ich die Shares "sehen" nun wenn ich aber in die Shares will kommt: http://img76.exs.cx/my.php?loc=img76&im ... ler5xy.gif wenn ich dann dass Passwort des Users eingebe kommt eine Fehlermeldung.

Aso bei ME kommt bevor es den Desktop läd, ein Netzwerkfenster (als wäre er bei einer Domäne angemeldet) und dort gibt man dann den User und das passwd ein.

Hier meine smb.conf

Code: Alles auswählen

[global]
	workgroup = NOERR
	netbios name = SERVER
	server string = Server
	interfaces = rl0
	encrypt passwords = Yes
	log level = 1
	log file = /var/log/samba/log.%m
	read raw = No
	name resolve order = lmhosts host bcast
	socket options = IPTOS_LOWDELAY TCP_NODELAY
	os level = 65
	preferred master = No
	local master = No
	domain master = No
	dns proxy = No
	wins support = Yes
	write cache size = 262144

[Andreas]
	comment = Andreas Home
	path = /home/Andreas
	guest account = Andreas
	valid users = Andreas
	read list = Andreas
	write list = Andreas
	read only = No
	guest ok = Yes

[Matthias]
	comment = Matthias Home
	path = /home/Matthias
	valid users = Matthias
	read only = No

[Bilder]
	comment = Bilder
	path = /Bilder
	valid users = Andreas Matthias
	read only = No

[Tausch]
	comment = Tausch
	path = /Tausch
	valid users = Matthias Andreas
	admin users = Andreas Matthias
	read list = Matthias Andreas
	write list = Matthias Andreas
	read only = No
	create mask = 0777
	force create mode = 0777
	force security mode = 0777
	directory mask = 0777
	force directory mode = 0777
	force directory security mode = 0777
	force unknown acl user = 0777

[homes]
	valid users = %S
	read only = No
	browseable = No
Version von Samba: 2.2.12

Also ich kann SICHER sagen, es liegt NICHT am Windows ME und es liegt an der Passwd Verschlüsselung. Wenn ich z.b. Encrypt Passwd: auf "No" stelle kann ich nicht mal mehr die Shares "sehen"
Ich hoffe, mir kann jemand helfen habe das Problem SCHON SEHR SEHR lange.

Aso der Samba Serverfungiert NICHT als PDC!

Danke!
towo
Moderator
Moderator
Beiträge: 3726
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo »

Also ich kann SICHER sagen, es liegt NICHT am Windows ME
Doch es liegt daran, da ME und alle anderen Win9x keine verschlüsselten PW benutzt!
Signatur nach Diktat spazieren gegangen

Bild
Benutzeravatar
Terminator
Newbie
Newbie
Beiträge: 12
Registriert: 27. Mär 2005, 22:28
Wohnort: in den Binary-Sourcen
Kontaktdaten:

Beitrag von Terminator »

towo2099 hat geschrieben:
Also ich kann SICHER sagen, es liegt NICHT am Windows ME
Doch es liegt daran, da ME und alle anderen Win9x keine verschlüsselten PW benutzt![/quote

Hallo towo2099 danke, für deine schnelle Antwort.

Mit SuSE habe ich es auch mal hinbekommen (mit Yast) aber ihr wisst ja (kein Krieg an fangen will) das manche Menschen SuSE nicht so leiden können. Also ES IST MÖGLICH. Und ich habe auf window-netzwerke.de was gefunden, man solle ein Key in der registry anlegen mit dem Wert 1 und dem namen.... da sei die passwd verschlüsselung abgeschaltet. Nein nichts passierte
towo
Moderator
Moderator
Beiträge: 3726
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo »

Und ich habe auf window-netzwerke.de was gefunden, man solle ein Key in der registry anlegen mit dem Wert 1 und dem namen.... da sei die passwd verschlüsselung abgeschaltet. Nein nichts passierte
Ähm, wie ich schon sagte, Win9x hat keine Passwortverschlüsselung, die Registryänderung bezieht sich AFAIK auf NT-Systeme, um dort die Verschlüsselung abzuschalten.
Signatur nach Diktat spazieren gegangen

Bild
Benutzeravatar
Terminator
Newbie
Newbie
Beiträge: 12
Registriert: 27. Mär 2005, 22:28
Wohnort: in den Binary-Sourcen
Kontaktdaten:

Beitrag von Terminator »

Windows 9x/ME <--- ist doch ME oder bin ich da auf dem Holzweg?

Naja ALSO KEINE! dann sollte ich ENcrypt Passwd auf NO stellen? Da bin ich aber wie oben geschrieben ja noch weiter vom Ziel entfernt!
Benutzeravatar
Terminator
Newbie
Newbie
Beiträge: 12
Registriert: 27. Mär 2005, 22:28
Wohnort: in den Binary-Sourcen
Kontaktdaten:

Beitrag von Terminator »

Also ich weiß, dass Windows ME irgendwas mit LM-xxx als Passwdverschlüsselung hat! Da MUSS sich Towo irren.
Windows XP nutzt MD5 (so wie es der Server auch nutzt)

Nun kommt nur die Frage was mache ich am besten?
Antworten