Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

PHP Update 4.3.4. > 4.3.10

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
DoubleM
Newbie
Newbie
Beiträge: 3
Registriert: 28. Mär 2005, 14:59

PHP Update 4.3.4. > 4.3.10

Beitrag von DoubleM »

hallo forum,

möchte ein php-update unter suse9.1/apache2/php4.3.4 machen.

dazu habe ich die

apache2-mod_php4-4.3.10-10.1.i586.rpm
php4-4.3.10-10.1.i586.rpm

von ftp://ftp.suse.com/pub/projects/apache/php4/9.1-i386/ geladen.

ich bekomme folgende fehler:

php4 = 4.3.4 is needed by (installed) php4-bcmath-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-bz2-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-calendar-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-ctype-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-curl-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-dba-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-dbase-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-domxml-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-exif-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-filepro-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-ftp-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-gd-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-gettext-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-gmp-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-iconv-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-mbstring-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-mcal-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-mcrypt-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-mhash-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-mime_magic-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-pear-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-qtdom-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-readline-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-shmop-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-sockets-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-swf-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-sysvsem-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-sysvshm-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-unixODBC-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-xslt-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-yp-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-zlib-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-pgsql-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-ldap-4.3.4-26
php4 = 4.3.4 is needed by (installed) php4-snmp-4.3.4-26
php4 = 4.3.4 is needed by (installed) mod_php4-core-4.3.4-43.17
php4 = 4.3.4 is needed by (installed) php4-imap-4.3.4-43.17
php4 = 4.3.4 is needed by (installed) php4-mysql-4.3.4-43.17
php4 = 4.3.4 is needed by (installed) php4-session-4.3.4-43.17
php4 = 4.3.4 is needed by (installed) php4-wddx-4.3.4-43.17


auf einem anderen server hatte alles super gefunkt, da lief
die gleiche konfig, nur mit suse 9.0.

hat jemand eine idee, wo hier das problem liegen könnte?

vielen dank!
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

Eines vorneweg: Dir ist klar, dass Du, sobald Du Pakete aus dem "projects"-Verzeichnis von SuSE einspielst, jegliche Ansprüche auf offizielle Updates von SuSE verlierst? Diese Pakete sind inoffiziell!

Zur Frage an sich: Ist doch eigentlich selbsterklärend: Alle PHP-Komponenten müssen zueinander passen. Du willst zwei davon aktualisieren, hast aber noch jede Menge andere installiert. Du kannst entweder

- komplett auf die Aktualisierung verzichten
- diejenigen Komponenten deinstallieren, die Du nicht brauchst
- alle Komponenten auf einmal aktualisieren

Falls Du Dich für die letztgenannte Option entscheiden solltest, findest Du alle notwendigen Pakete in demselben Verzeichnis, aus dem die beiden stammen, die Du schon hast. Ist doch eigentlich kaum zu übersehen.
DoubleM
Newbie
Newbie
Beiträge: 3
Registriert: 28. Mär 2005, 14:59

Beitrag von DoubleM »

Auf ein Update nach 4.3.10 verzichten, wäre wohl ziemlich leichtsinnig.

Um von 4.3.3. auf 4.3.10 unter SUSE 9.0 zu kommen,
brauchst Du genau drei RPMs:

apache2-mod...
die core- & devel RPM

Funkt ausgezeichnet, nur eben nicht unter 9.1.

Leider stehen im 9.1. Ordner diese RPMs auch
nicht zur Verfügung.
DoubleM
Newbie
Newbie
Beiträge: 3
Registriert: 28. Mär 2005, 14:59

Beitrag von DoubleM »

Hallo,

habe jetzt alle Abhängigkeiten aufgelöst (kleines HOWTO
gibt's später), bis auf die folgende:

apache_mmn_19990320_15 is needed by apache-mod_php4-4.3.10-10.1

Kann mir jemand sagen, was dahinter steckt?

Vielen Dank!
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

Auf dieses Update zu verzichten, ist nicht leichtsinnig, sondern sogar sehr vernünftig. Es ist sogar genau umgekehrt, es wäre leichtsinnig, das Update durchzuführen. Wer etwas anderes behauptet, der hat nicht begriffen, wie das mit den Updates bei SuSE läuft.

Da ich keine Lust habe, das alles wieder und wieder zu erklären, gibt es an dieser Stelle nur einen Link:

http://www.linuxforen.de/forums/showthread.php?t=177390

Kurz zusammengefasst: Sicherheitsupdates gibt es bei SuSE über YaST Online Update und nur über dieses! In diesen YOU-Patches sind alle sicherheitsrelevanten Korrekturen in zurückportierter Form enthalten, und zwar so, dass sie sich in das übrige System einfügen.

Wer selbst Hand anlegt und Pakete aus dem höchst inoffiziellen und in keiner Weise unterstützten "projects"-Verzeichnis installiert, der kommt sich im ersten Moment vielleicht besonders schlau vor, weil er die neueste Version hat, aber spätestens wenn es in dieser Version auch wieder ein Sicherheitsloch gibt, hat derjenige ein gewaltiges Problem: Für die inoffiziellen Pakete gibt es nämlich nicht einmal inoffizielle Updates, sondern überhaupt keine!

Im selben Moment darf sich derjenige, der auf die inoffiziellen Updates verzichtet hat, dezent ins Fäustchen lachen, weil der nämlich immer noch seine offiziellen zurückportierten Sicherheitsfixes bekommt, und zwar über YaST Online Update, zwei Jahre lang.

README-Dateien beißen übrigens nicht, auch nicht die aus dem Apache-Verzeichnis:

ftp://ftp.suse.com/pub/projects/apache/README
Dear User,

all packages below this directory are not supported in any way by SuSE. You have to use them on your own risk.
Es steht übrigens bei diesen inoffiziellen Paketen aus dem "projects"-Verzeichnis auf der Tagesordnung, dass sich die Abhängigkeiten gar nicht auflösen lassen. Auch nicht nach langer Sucherei. Denn diese Updates wurden erstens nicht auf unmodifizierten Original-Systemen gebaut, sondern auf Systemen, die einen Entwicklungsstand zwischen zwei SuSE-Releases entsprechen, denn genau dazu, zur Vorbereitung des jeweils nächsten SuSE-Releases, sind sie da und zu sonst gar nichts!

Zweitens kann es passieren, dass Abhängigkeiten zu anderen Paketen auftreten können, die ebenfalls inoffiziell sind. Aber weil die inoffiziellen Pakete nun mal eben inoffiziell sind, werden sie, sobald sie nicht mehr aktuell sind, gnadenlos vom Server genommen und dann wird es eklig, weil sich die Abhängigkeiten auch mit langer Sucherei nicht auflösen lassen.

Genau das ist hier passiert. Es existiert kein Paket für SuSE 9.1, das diese Abhängigkeit enthält, nirgendwo. Es existiert nur eines für SuSE 9.0, aber wenn Du jetzt anfängst, distributionsfremde Pakete einzuspielen, dann kannst Du es auch gleich sein lassen, denn das wird früher oder später zum Zerschießen des Systems führen.

Mein Tipp: Lass es einfach sein und führe stattdessen ein stinknormales YaST Online Update durch.
Antworten