Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

WLAn disconnect und connect?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

WLAn disconnect und connect?

Beitrag von marcor »

Hallo zusammen,

anhand der super Anleitung von der_schreiner habe ich meine Realtek 8180 mit den Linuxant-Treibern super ans laufen bekommen;-)

An dieser Stelle nochmal Danke

Jetzt tritt bei mir folgendes Problem(chen) auf:

Die beider Win-XP Clients meiner Söhne werden 1a über WLAN und eth0 auf das DSL-Modem weitergeleitet. Wenn die beiden Rechner meiner Kinder aber abgeschaltet werden und später wieder ne Verbindung aufbauen wollen nimmt meine WLAN Karte diese nicht an.

Ich bin dann gezwungen über den kwifimanger den Modus meiner Karte von Managed auf Ad-Hoc und zurück zu stellen und schon ist der Kontakt der Karten untereinander wieder da.

Das ganze muss doch irgendwie automatisch gehen, das die Karte von selber anspringt???

Hat da jemand ne Idee??

Grüskes
dirk viher
Hacker
Hacker
Beiträge: 568
Registriert: 19. Feb 2004, 18:08
Wohnort: Herzogenrath

Beitrag von dirk viher »

Wie ist dein Netzwerk aufgebaut. Wer wird worüber mit wem verbunden.
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

Beitrag von marcor »

dirk viher hat geschrieben:Wie ist dein Netzwerk aufgebaut. Wer wird worüber mit wem verbunden.
Die Clients (Win-XP) haben je eine WLAN-Karte eingebaut.
IP 192.168.0.3 und 4

Der Linux Router hat eine WLAN-Karte wlan0 als 192.168.0.1 und eine eth0 192.169.100.1 eingebaut. An der eth0 häng das DSL-Modem.

Auf den Clients ist die IP von eth0 als Gataway eingetragen (Auf dem Linux-System natürlich auch). Dial on demand unter Linux klappt gut.

Interessant ist, das nach dem runterfahren der Clients meine WLAN-Karte "Abschaltet" und sich von den Clients auch nicht wecken lässt.

Grüskes
dirk viher
Hacker
Hacker
Beiträge: 568
Registriert: 19. Feb 2004, 18:08
Wohnort: Herzogenrath

Beitrag von dirk viher »

Setz die wlan karte bei linux von managed auf auto,oder richte sie als AP ein.
Hast du die windows clients beim Einrichten des Routers korrekt angegeben.
Versuch mal gateaway wlan0 und nameserver eth0 auf den windows clients. Auf dem router eth0 als gateaway und die IP des dns deines Providers (t-online: 194.25.2.129) als nameserver und richte eine route von wlan0 zu eth0 ein.
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

Beitrag von marcor »

dirk viher hat geschrieben:Setz die wlan karte bei linux von managed auf auto,oder richte sie als AP ein.
Hast du die windows clients beim Einrichten des Routers korrekt angegeben.
Versuch mal gateaway wlan0 und nameserver eth0 auf den windows clients. Auf dem router eth0 als gateaway und die IP des dns deines Providers (t-online: 194.25.2.129) als nameserver und richte eine route von wlan0 zu eth0 ein.
Versuch ich morgen mal, wenns nicht klappt melde ich mich.

Danke
Antworten