Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SUSE 9.2 / IFDOWN/IFUP DSL0 Problem - Internet geht nimmer!!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
axel1973
Newbie
Newbie
Beiträge: 3
Registriert: 3. Mai 2004, 02:42
Wohnort: Freiburg

SUSE 9.2 / IFDOWN/IFUP DSL0 Problem - Internet geht nimmer!!

Beitrag von axel1973 »

Hallo Allerseits!

Ich hab neulich SuSE 9.2 Pro installiert und möchte es u.a. als DSL Router fürs lokale LAN nutzen. Früher war bei mir 9.0 im Einsatz und hat prima geklappt. Die neue 9.2 macht hier nun Prrobleme und ich weis nich warum und wieso.

Folgendes habe ich festgestellt: (IF == Interface)

1. MAschine frisch rebootet: alles OK!

2. inet verb. Besteht, pings funktionieren

3. IFDOWN DSL0 - IF DSL0 geht weg

4. IFUP DSL0 - DSL0 kommt NICHT wieder!!! Siehe hier

##############################################
linux:~ # ifdown dsl0
dsl0
interface dsl0 is down
linux:~ # ifup dsl0
dsl0
interface dsl0 is up
linux:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:118:3A:2A:3F
inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:fe3a:2a3f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:588 errors:0 dropped:0 overruns:0 frame:0
TX packets:682 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:151902 (148.3 Kb) TX bytes:156838 (153.1 Kb)
Base address:0xbc00 Memory:fc8e0000-fc900000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

linux:~ #
################################################## ###

5. nochmal IFUP DSL0 eingeben >> DSL0 wieder da mit pseudo IP wie gewollt.

################################################## #########
linux:~ # ifup dsl0
dsl0
interface dsl0 is up
linux:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:118:3A:2A:3F
inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:fe3a:2a3f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:588 errors:0 dropped:0 overruns:0 frame:0
TX packets:682 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:151902 (148.3 Kb) TX bytes:156838 (153.1 Kb)
Base address:0xbc00 Memory:fc8e0000-fc900000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

linux:~ # ifup dsl0
dsl0
interface dsl0 is up
linux:~ # ifconfig
dsl0 Link encapoint-to-Point Protocol
inet addr:192.168.99.1 P-t-P:192.168.99.99 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:118:3A:2A:3F
inet addr:192.168.1.69 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:fe3a:2a3f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:656 errors:0 dropped:0 overruns:0 frame:0
TX packets:767 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:158861 (155.1 Kb) TX bytes:167449 (163.5 Kb)
Base address:0xbc00 Memory:fc8e0000-fc900000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

linux:~ #
################################################## ########################


6. Verbindung starten mit "ping -c3 www.hallo.de" >> IF DSL0 erhält neue IP Adresse. Er erscheinen aber auch dubiose Meldungen. siehe hier:

######################################

linux:~ # ping -c3 www.hallo.de
PING wielin3.hallo.de (80.121.157.11) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted

--- wielin3.hallo.de ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

linux:~ # ifconfig
dsl0 Link encapoint-to-Point Protocol
inet addr:80.131.224.47 P-t-P:217.5.98.41 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:591 (591.0 b) TX bytes:789 (789.0 b)

######################################


7. nochmaliger Ping versuch einige Sekunden später ergibt:


######################################


linux:~ # ping -c3 www.hallo.de
PING wielin3.hallo.de (80.121.157.11) 56(84) bytes of data.
64 bytes from 80.121.157.11: icmp_seq=1 ttl=249 time=62.7 ms
64 bytes from 80.121.157.11: icmp_seq=2 ttl=249 time=62.5 ms
64 bytes from 80.121.157.11: icmp_seq=3 ttl=249 time=62.2 ms

--- wielin3.hallo.de ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms rtt min/avg/max/mdev = 62.241/62.515/62.780/0.363 ms linux:~ #

######################################

Was läuft hier falsch?!?


Aber es geht noch weiter!

8. ein ping auf eine andere Adresse z.b. ping www.heute.de klappt dann immernoch nicht. Fehlermeldung wie bereits oben. Hostnot found oder ähnliches. Es scheint als könne er bei bekannten IP Adressen noch sauber pingen. Bei neuen Hostnamen jedoch schlägt es wohl fehl.


Ich kanns mir echt nicht mehr erklären!!! Hat einer von euch nen Tipp oder kennt gar da Problem???


btw:
NEtzkonfig sieht bei mir so aus:
1. Linux box mit IP x.x.x.69 ist ROUTER/Gateway
2. Windows Server mit IP x.x.x..95 ist DNS/Nameserver u.a. wg ADS
3. der DNS auf der Windows box enthält forwarder welche auf gültige NS der Telekom zeigen (TDSL)

Zu guter letzt: Wenn ich die Linux Box per "reboot" neu starte funktioniert alles perfekt bis zum nächsten "ifdown/ifup" ( Das nachträgliche aufrufen von SuSEFirewall2 und/oder "rcnetwork restart" brachte ebenfalls nichts.


HILFÄÄÄÄÄÄ!!!!!

MFG
Axel
Antworten