Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

smpppd und kinternet machen probleme,

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
georgloesel
Newbie
Newbie
Beiträge: 4
Registriert: 23. Mär 2005, 00:12
Wohnort: Hannover

smpppd und kinternet machen probleme,

Beitrag von georgloesel »

Hallo,
ich habe folgendes Problem. Nach dem Start meines Rechners (Suse 9.1) funktioniert kinternet nicht mehr. Die Fehlermeldung besagt, daß der Server smpppd nicht funktioniert. Jegliche bereits genannten Vorschläge (z.B. http://www.linux-club.de/suse-support-forum/5907.html) auch hier im Forum fruchten nicht. Das seltsame ist, daß es vorgestern noch tadellos lief und ich seitdem nur den Rechner ausgeschaltet habe und ihn jetzt halt wieder eingeschaltet habe. Sonst gab es keine Änderungen.

Was ist mir aufgefallen: Beim booten wird in /var/log/boot.msg gesagt, dass die Einrichtung des Netzwerks fehlgeschlagen ist und die einrichtung des smpppd deswegen übersprungen wurde.

Zitat:

georg@linux:~> grep network /var/log/boot.msg

Setting up network interfaces:
skipped Setting up service network . . . . . . . . . . . . . . . .failed
<notice>exit status of (network) is (7)
Failed services in runlevel 5: network

georg@linux:~> grep smpppd /var/log/boot.msg

<notice>start services (smpppd SuSEfirewall2_final)
<notice>exit status of (smpppd SuSEfirewall2_final) is (5 0)
Skipped services in runlevel 5: smbfs smpppd

Wenn ich im Runleveleditor unter YAST den Dienst smpppd anhalten möchte (er wird zunächst mit „Ja“ gekennzeichenet) kommt die Fehlermeldung, das Programnm sei nicht installiert (Fehler 5) . per locate lassen sich aber einige Fundorte diverser smpppd Sachen finden.

Zitat:

georg@linux:~> locate smpppd

/etc/init.d/rc2.d/K01smpppd
[.....]
/etc/init.d/smpppd
/etc/smpppd-c.conf
/etc/smpppd.conf
/lib/scpm/resource_groups/smpppd
/usr/sbin/rcsmpppd
/usr/sbin/smpppd
/usr/sbin/smpppd-ifcfg
/usr/share/doc/packages/smpppd
[.....]
/usr/share/man/man5/smpppd-c.conf.5.gz
/usr/share/man/man5/smpppd.conf.5.gz
/usr/share/man/man8/smpppd-ifcfg.8.gz
/usr/share/man/man8/smpppd.8.gz
/usr/share/susehelp/meta/Manuals/Productivity/smpppd.desktop
/var/adm/fillup-templates/rc.config.smpppd.del
/var/lib/smpppd
/var/log/smpppd
/var/run/smpppd

Hat jemand eine Idee woran es liegen kann und wie ich dem Fehler auf die Spur komme?

Danke im Voraus sagt Georg
Benutzeravatar
Goras
Newbie
Newbie
Beiträge: 9
Registriert: 11. Okt 2004, 17:59
Wohnort: am Rande des Potts
Kontaktdaten:

Beitrag von Goras »

testweise mal versuchen die netzwerkkarten neu zu konfigurieren!
hat bei mir jedenfalls geklappt, hab sie alle aus der konfiguration geschmissen und manuell geadded, danach gings :/
georgloesel
Newbie
Newbie
Beiträge: 4
Registriert: 23. Mär 2005, 00:12
Wohnort: Hannover

Beitrag von georgloesel »

Hallo,

ich habe inzwischen ein wenig weiter probiert. Der Hinweis mit der Netzwerkkarte hat leider nichts gebracht. auch das deinstallieren von smpppd und kinternet bringt nichts. die neu einstallation von smpppd unter YAST bringt immer "Diese Pakete haben Fehler zurückgeliefert: smpppd . irgendwie scheint es an diesem programm zu liegen eine alternative installation mit kpackage bringt folgende Fehlermeldung:

<home/georg/RPM_Lager/smpppd-1.16-3.i586.rpm';echo RESULT=$?
warning: /etc/init.d/smpppd saved as /etc/init.d/smpppd.rpmorig
warning: /etc/smpppd-c.conf created as /etc/smpppd-c.conf.rpmnew
warning: /etc/smpppd.conf created as /etc/smpppd.conf.rpmnew
error: unpacking of archive failed on file /usr/sbin/rcsmpppd: cpio: rename failed - Permission denied
RESULT=1

so wie es scheiunt habe ich trotz rootlogin keine schreibrechte ? ??

irgendwelche Ideen?

langsam etwas verzweifelnd :-(

Georg
The_Eye
Member
Member
Beiträge: 145
Registriert: 22. Mai 2004, 21:18

Beitrag von The_Eye »

Das smpppd Paket von SuSE 9.2 hatte Fehler. Auf dem Server liegt ein update, welches "eigentlich" ein anderes Problem beheben sollte. Aber vielleicht einen Versuch wert.
Ubuntu& SuSE -- HP nx7000 & nx9420
georgloesel
Newbie
Newbie
Beiträge: 4
Registriert: 23. Mär 2005, 00:12
Wohnort: Hannover

Beitrag von georgloesel »

Hallo The_Eye,


wo liegt der Patch? bei Suse? Auf einem ftp-Server?

hast du eine genauen Link ?

bedankt Georg
georgloesel
Newbie
Newbie
Beiträge: 4
Registriert: 23. Mär 2005, 00:12
Wohnort: Hannover

Beitrag von georgloesel »

Hallo,

Problem gelöst.

es hatte nichts mit dem smpppd zu tun sondern lag an einem fehlerhaften FileSystem. Genau die Stelle auf der Platte die mit dem smpppd zu tun hatte war fehlerhaft. Ein reiserfsck --fix-fixable /device und danach reiserfsck --rebuild-tree /device haben das Problem gelöst.

Insgesamt riecht das nach einer neuen Festplatte

Danke für die Hilfestellungen.

Gruß Georg
The_Eye
Member
Member
Beiträge: 145
Registriert: 22. Mai 2004, 21:18

Beitrag von The_Eye »

Hi,

Falls dennoch von Interesse. Update wie immer unter:
http://ftp.suse.com/pub/suse/i386/update/9.2/rpm/i586/

Oder über Yast natürlich.
Ubuntu& SuSE -- HP nx7000 & nx9420
Antworten