Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

problem mit putty und ssh login

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
captain nemo
Member
Member
Beiträge: 94
Registriert: 30. Jan 2004, 04:46
Wohnort: Berlin
Kontaktdaten:

problem mit putty und ssh login

Beitrag von captain nemo »

hey leute,
ich hab nen problem mit ssh.
also erst mal zu meinen hardware/software kram:
suse 9.0 prof mit neuesten updates
dsl flat mit fm114p router (ssh ist freigegeben)
no-ip.com dynamische dns
und halt nen putty client

so nu zum problem.
wenn ich mich mit putty auf meiner linux maschiene einloggen will konnektet der zwar zu meinem rechner und nimmt anscheinend auch den usernamen an aber wenn ich dann mein passwort eingebe kommt so ne nette message "access denied". ok nu liegt ja nahe mal das passwort nochmal einzugeben, hab ich auch gemacht, aber nach den 20. mal hab ich dann doch aufgegeben.

wenn ich ueber die konsole auf dem rechner selber die adresse eingebe kann ich mich komischerweise super einloggen und alles funktioniert.

hab auf dem rechner auch nen webserver laufen und da komme ich auch super auf die website ueber den no-ip account.

waere ganz cool wenn mir wer helfen kann.
rechtschreibfehler sind gewollt

"imagination is more important than knowledge"
A. Einstein

mein blog
Benutzeravatar
nny
Member
Member
Beiträge: 226
Registriert: 4. Jan 2004, 17:06

Beitrag von nny »

hi,

ich schätz mal das Du eventuell was mit den Usern verhauen hast, da der ssh connect ja funktioniert.
Nur als Bsp. war ich in der Schule immer mit meiner Schulkennung eingeloggt, wenn ich dann einen Standart Connect mit putty nach hause gemacht hab, hat er sich mit fi03@nny.wieauchimmer.de connectet...
Da ich zuhause kein user fi03 angelegt hatte, hat auch der Connect nach der passwort eingabe angebrochen -> access denied
also ssh user@host

hoff das war das prob
nny
it takes a nation of millions to hold us back
Chuck D / Public Enemy No1
/join #nny @ euIRC
Benutzeravatar
captain nemo
Member
Member
Beiträge: 94
Registriert: 30. Jan 2004, 04:46
Wohnort: Berlin
Kontaktdaten:

Beitrag von captain nemo »

hey nny
also wie du schon richtig vermutet hast logge ich mich von meiner schule aus ein, allerdings denke ich nicht das das was mit usern zu tun hat den putty oder vielmehr der ssh server fragt dich als welcher user du dich anmelden willst also das erscheint mit unwarscheinlich. was ich mir denke ist das irgendwie der user auf dem localen system keine berechtigung hat sich anzumelden, oder es hat was mit irgend nem neuen protokoll oder so zu tun, welches linux benutzt.

denkst du es wuerde helfen wenn ich nen neuen user nur fuer ssh anlege? wenn ja wie kann ich das machen?
rechtschreibfehler sind gewollt

"imagination is more important than knowledge"
A. Einstein

mein blog
Benutzeravatar
nny
Member
Member
Beiträge: 226
Registriert: 4. Jan 2004, 17:06

Beitrag von nny »

hi nemo

user kannst Du bequem über yast anlegen -> Sicherheit & Benutzer -> Benutzer bearbeiten & anlegen...
und schau mal das bei putty 'ssh2 only' eingestellt ist, obwohl ich mir nicht über die Fehlermeldung sicher bin, die es bei einer falschen ssh Version bringt, muss ich nachher mal testen...
User können natürlich auch über konsole angelegt werden.
useradd oder adduser <name>, musst Du bei Bedarf noch mal nachlesen, ich werf immer gerne SuSE und Debian durcheinander ;)

nny
it takes a nation of millions to hold us back
Chuck D / Public Enemy No1
/join #nny @ euIRC
poiin2000
Member
Member
Beiträge: 55
Registriert: 29. Jan 2004, 17:04
Wohnort: Pforzheim
Kontaktdaten:

Beitrag von poiin2000 »

http://www.linux-club.de/viewtopic.php?t=798&highlight=
poiin2000 hat geschrieben:SuSE hat sich bei 9.0 eine Kleinigkeit abseits des Standards in der /etc/ssh/sshd_config erlaubt.

Code: Alles auswählen

# To disable tunneled clear text passwords, change to no here!
#PasswordAuthentication no
ist in

Code: Alles auswählen

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
zu ändern.

Alternativ könnten auch ssh-schlüssel mittels dem Programm ssh-keygen erstellt werden.


poiin2000
p2k
Benutzeravatar
captain nemo
Member
Member
Beiträge: 94
Registriert: 30. Jan 2004, 04:46
Wohnort: Berlin
Kontaktdaten:

Beitrag von captain nemo »

hey danke das wars.
nu kann ich entlich wieder von der schule aus auf meinen rechner zugreifen.
rechtschreibfehler sind gewollt

"imagination is more important than knowledge"
A. Einstein

mein blog
Antworten