Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

VSFTP Server !!!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Andre
Member
Member
Beiträge: 237
Registriert: 11. Mai 2004, 19:46
Wohnort: Wien
Kontaktdaten:

VSFTP Server !!!

Beitrag von Andre »

Hallo Leute,

hat wer eine Anleitung bez. VSFTP Server ???
habe schon ein bisschen gegoogelt und auch einiges gefunden aber itgendwie läuft er nicht so ganz.

Danke im voraus

mfg andre
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Moin Andre,
habe selber vsftp. Was läuft nicht??
Schau mal in die /etc/vsftpd.conf
Diesen Eintrag sollte man aktivieren, wenn man sich als user verbinden will.
# Local FTP user Settings
#
# Uncomment this to allow local users to log in.
#
local_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#
Viel Spaß
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Andre
Member
Member
Beiträge: 237
Registriert: 11. Mai 2004, 19:46
Wohnort: Wien
Kontaktdaten:

vsftp

Beitrag von Andre »

Hallo warpi ,



hier meine vsftpd.conf

write_enable=YES
dirmessage_enable=YES
userlist_enable=YES

#nopriv_user=ftpsecure

ftpd_banner="Welcome to CTS FTP Server."

#ls_recurse_enable=YES
#deny_email_enable=YES
#banned_email_file=/etc/vsftpd.banned_emails

hide_ids=YES
local_enable=YES
local_umask=022
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list

local_max_rate=0

anonymous_enable=NO
anon_world_readable_only=YES
anon_upload_enable=NO
#anon_umask=022

anon_mkdir_write_enable=NO
anon_other_write_enable=NO

#chown_uploads=YES
#chown_username=whoever
#anon_max_rate=7200

syslog_enable=YES
log_ftp_protocol=YES
xferlog_enable=YES
vsftpd_log_file=/var/log/vsftpd.log
xferlog_std_format=YES
xferlog_file=/var/log/xferlog

#dual_log_enable=YES
#setproctitle_enable=YES

connect_from_port_20=YES
idle_session_timeout=600

#data_connection_timeout=120
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES

#pasv_enable=NO

#pam_service_name=vsftpd
listen=NO



mfg andre
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Morgen Andre,
sieht ja ganz gut aus. Was für Probs haste denn genau??
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Andre
Member
Member
Beiträge: 237
Registriert: 11. Mai 2004, 19:46
Wohnort: Wien
Kontaktdaten:

vsftp

Beitrag von Andre »

hallo warpi,

ich kann intern nicht zugreifen (firewall ist deaktiviert)
habe einen user angelegt mit home verzeichnis
in die chroot_list eingetragen

aber es funkt nicht

wenn ich den server restarten möchte schreibt er mir auch kein zugriff

mfg andre
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Mahlzeit Andre,
mir ist da eine Einstellung aufgefallen:
#pam_service_name=vsftpd
diese Zeile ist auskommentiert. Darüber steht <PAM setting. Do NOT change this unless you know what you do.>
Ich geh mal davon aus, dass du den ftpd aktiviert hast(mit YAST oder manuell als root).
Aktiviere mal den PAM-Eintrag. Ich weiß nicht wozu der gut ist.
Wenn du chroot_list_enable=yes setzt, dann stehen in der Liste die user die NICHT chroot benutzen.
Falls das alles nicht hilft, dann gib doch die Meldungen beim anmelden bitte aus.
Bis bald
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Nachtrag:
Bei mir ist der PAM-Eintrag aktiv und das war auch die Einstellung von der Installation.':roll:'
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Andre
Member
Member
Beiträge: 237
Registriert: 11. Mai 2004, 19:46
Wohnort: Wien
Kontaktdaten:

vsftp

Beitrag von Andre »

hallo warpi

also ich habe das pam_service_name=vsftd
auskommentiert funkt aber trozdem nicht

ich habe ja einige anleitungen gelesen aber irgendwie werde ich nicht schlau daraus

vielleicht stelle ich ein paar dumme fragen (tut mir leid)

ich habe die vsftpd.conf und die vsftpd.croot_list

die vsftpd.conf habe ich eh konfig.
die benutzer die zugreifen dürfen werden normal am system angelegt (mit homeverzeichnis aber keine anmeldung auf der shell)
und in der vsftpd.croot_list werden die benutzer eigetragen die zugreifen dürfen oder

was habe ich falsch gemacht bzw fehlt noch.

ich habe den ftp per yast in der xinetd gestartet. (im yast steht das der server läuft)
wie kann ich das in der konsole prüfen. ??

mfg andre
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Morgen Andre,
in deiner vsftp.conf war der Eintrag <pam_service_name=vsftd> schon auskommentiert.
Du solltest mal versuchen, diesen Eintrag zu aktivieren. Wie gesagt bei mir sieht das so aus:
# PAM setting. Do NOT change this unless you know what you do!
#
pam_service_name=vsftpd :roll:

Wenn du versuchst einen ftp-connect aufzubauen, dann langt der Befehl in der shell:
ftp benutzername
bei mir sieht das so aus
ftp user
Connected to user.
220 (vsFTPd 2.0.1)
Name (user)
danach in der anderen shell
ps -aef | grep ftpd
root 6771 5130 0 07:06 ? 00:00:00 vsftpd
nobody 6772 6771 0 07:06 ? 00:00:00 vsftpd
user 6794 5801 0 07:07 pts/2 00:00:00 grep ftpd

Wenn kein connect versucht wird sieht das so aus:
ps -aef | grep ftpd
user 6829 5801 0 07:10 pts/2 00:00:00 grep ftpd
Viel Spaß ':P'
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Nachtrag:
der Versuch von einem connect reicht.
Also nur
ftp benutzer
& dann auf einer 2ten shell
ps -aef | grep ftpd.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Andre
Member
Member
Beiträge: 237
Registriert: 11. Mai 2004, 19:46
Wohnort: Wien
Kontaktdaten:

vsftp

Beitrag von Andre »

Hallo warpi

ich glaube der ftp läuft gar nicht

wie kann ich den starten

im yast zeigt er mir zwar an das er läuft aber ich glaube er läuft nicht.

wenn ich ftp username eintippe dann schreibt er
Name or Service not know

???

mfg andre
warpi
Hacker
Hacker
Beiträge: 451
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Beitrag von warpi »

Abend Andre,
hast du einen ftpclient installiert??
Ich habe folgende Programme:
vsftpd 2.0.1-2.2
gftp 2.0.17-2.2
lukemftp 1.5-580
Ich hoffe es liegt am fehlen eines ftpclients.
Wenn ich versuche vsftpd manuell zu starten sieht das so aus:
warpi:/usr/sbin # vsftpd
500 OOPS: vsftpd: not configured for standalone, must be started from inetd
warpi:/usr/sbin #
Wenn ich nur ftp eingebe dann so:
user@warpi:~> ftp
ftp>
falls das nicht weiter hilft dann gibt's von mir zu deinen ??? noch ':?:' ':?:'
Viel Glück
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.
Antworten