Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Paketabhängigkeiten

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
achim_g
Newbie
Newbie
Beiträge: 30
Registriert: 21. Aug 2004, 17:27
Wohnort: Berlin

Paketabhängigkeiten

Beitrag von achim_g »

Hallo,

wenn ich mit YAST versuche xsane zu installieren kommen viele Meldungen zu Konflikten, z.B. mit gimp "Konflikt mit gimp 2.0.0-12", insgesamt 12 solcher Meldungen "xsane benötigt libgimp-2.0.so.0". Es wird mir angeboten, den Konflikt zu ignorieren und ein inkonsistentes System zu riskieren.

Wie gehe ich am besten mit solchen Konflikten um?

Achim
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Du musst die Konflikte auflösen. Dazu musst die Pakete herausfinden die diese Dateien enthalten und installieren. Meist dürften die schon auf deiner CD/DVD drauf sein, ansonsten musst du dich im Internet umschauen, wo du die Pakete bekommst. www.rpmseek.com oder http://packman.links2linux.de sind Anlaufstellen für solche Angelegenheiten. Aber achte bitte darauf, dass die Pakete genau zu deiner Distribution passen.

Interessant für sowas ist auch apt (siehe eigenes Forum hier), allerdings sollte man dazu schon etwas Fortgeschrittener sein.

Welche Distribution nutzt du?
achim_g
Newbie
Newbie
Beiträge: 30
Registriert: 21. Aug 2004, 17:27
Wohnort: Berlin

Beitrag von achim_g »

schonmal danke, ist aber äußerst schwer bei solch vielen Konflikten den Überblick zu behalten. Ich habe Suse 8.2. Werden alle Konflikte automatisch aufgehoben, wenn ich Suse 9.2 installiere?
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Zumindest könnte es etwas einfacher werden, da hier dann bereits aktuellere Programmversionen mitgeliefert werden. Optimal für solche Dinge eignet sich halt apt. Da werden die Abhängigkeiten weitgehend automatisch aufgelöst.

Was ist denn mit dem Paket von Packman für deine 8.2? Läuft das nicht?

http://packman.links2linux.de/index.php ... n=236&vn=5
achim_g
Newbie
Newbie
Beiträge: 30
Registriert: 21. Aug 2004, 17:27
Wohnort: Berlin

Beitrag von achim_g »

will xsane installieren oder irgendwas zum scannen
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk »

Hm. Ja und? Was ist denn mit xsane von Packman? Läuft das denn nicht? Und hast du gimp mal irgendwann upgedated?
Antworten