Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix und Courier

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
Benutzer 14843 gelöscht

Postfix und Courier

Beitrag von Benutzer 14843 gelöscht »

Nachdem ich lange mit Cyrus gearbeitet habe möchte ich auch mal Courier ausprobieren. Das von mit aufgesetzte System mit Postfix und Courier funktioniert leider nicht 100%ig.
Da ich höchstwahrscheinlich etwas falsch in den Konfigurationsdateien eingestellt habe würde ich gerne wissen, wie die richtigen Einstellungen lauten.
Könnte vielleicht einer von euch mal die Konfigurationsdateien (vor allem Postfix) von einem funktionierenden System posten?

Mfg. Mercedesdriver :)
Benutzeravatar
mccologne
Newbie
Newbie
Beiträge: 10
Registriert: 22. Dez 2004, 21:50

Beitrag von mccologne »

Hey,

ich nutze hier SuSE 9.1 für meinen Mailserver, daher zähle ich Dir auf, was ich hier installiert habe:

1) Basisinstallation ohne X-Server
2) Postfix, Courier-Imap, Amavisd-New, Openssl für TLS, OpenSSH, Spamassassin, evtl. Webserver für Webmails incl. Squirrelmail, Cyrus-Sasl, Cyrus-Sasl-Plain, Cyrus-Sasl-Digest-MD5, Cyrus-Sasl-Cram-MD5 und Programme mit Abhänigkeiten zu den v.g. Paketen.

/etc/postfix/main.cf
alias_maps = hash:/etc/aliases
body_checks = regexp:/etc/postfix/body_checks.regexp
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports =
disable_dns_lookups = no
header_checks = regexp:/etc/postfix/header_checks.regexp
home_mailbox = Maildir/
html_directory = /usr/share/doc/packages/postfix/html
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains = $mydomain
masquerade_exceptions = root
message_size_limit = 10240000
mime_header_checks = regexp:/etc/postfix/mime_header_checks.regexp
mydestination = $myhostname, localhost.$mydomain, $mydomain
mydomain = xxx.xx
myhostname = server.xxx.xx
mynetworks = 127.0.0.0/8 192.168.12.0/24
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
reject_code = 554
relayhost = [smtp.xxxxxxx]
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtp_tls_CAfile = /etc/postfix/CAcert.pem
smtp_tls_cert_file = /etc/postfix/cert.pem
smtp_tls_key_file = /etc/postfix/key.pem
smtp_use_tls = yes
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unknown_sender_domain, reject_non_fqdn_sender, permit_mynetworks, reject_unauth_destination, check_sender_access hash:/etc/postfix/access, check_recipient_access hash:/etc/postfix/recipient_access, permitmtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/CAcert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_received_header = no
smtpd_use_tls = yes
strict_rfc821_envelopes = no
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 450

/etc/postfix/master.cf
smtp inet n - n - - smtpd -o content_filter=smtp:[localhost]:10024
smtps inet n - n - 2 smtpd -o smtpd_tls_wrappermode=yes -o content_filter=smtp:[localhost]:10024
-o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
submission inet n - n - - smtpd
-o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628 inet n - n - - qmqpd
pickup fifo n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - n 300 1 oqmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
trace unix - - n - 0 bounce
verify unix - - n - 1 verify
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - n - - smtp
relay unix - - n - - smtp
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - n - - showq
error unix - - n - - error
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
localhost:10025 inet n - n - - smtpd -o content_filter=
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus unix - n n - - pipe
user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
vscan unix - n n - 10 pipe
user=vscan argv=/usr/sbin/amavis ${sender} ${recipient}
procmail unix - n n - - pipe
flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
smtp-amavis unix - - n - 4 smtp
-o smtp_data_done_timeout=1800
-o disable_dns_lookups=yesserver:~ #

Courier-Imap ist eigendlich selbsterklärend.
Zu Amavisd-new findest du im Netz viele Hinweise.
Ansonsten beschreibe Deine Probleme mal.

Grüße
mccologne
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Danke schonmal.
Bei Postfix wusste ich nicht genau welchen Eintrag mailbox-transport brauchte. Es werden die E-Mails jetzt aber erfolgreich in den Mailboxen abgelegt.
Ein Problem habe ich jedoch mit Courier. Bei mir schlägt die Authentifizierung immer fehl.
Könntest du vielleicht mal deine authdaemonrc posten?
Ansonsten weiß ich leider nicht woran es liegen könnte.

Mfg. Mercedesdriver :)
Benutzeravatar
mccologne
Newbie
Newbie
Beiträge: 10
Registriert: 22. Dez 2004, 21:50

Beitrag von mccologne »

Hey,

kann ich Dir erst später nachreichen, da ich zur Zeit auf der Arbeit bin.
Ich denke, Du hast ein anderes Problem. Bei meiner authdaemonrc-config ist eigendlich nichts verändert!
Zuerst aber alle anderen Möglichkeiten ausschließen:
a) läuft courier-imap
testen mit:
lsof -i :143
oder
telnet 127.0.0.1 143
oder
ps ax | grep courier

b) Maildir Ordner erstellt!
maildirmake Maildir/ ***als User ausführen oder als root in /etc/skel
ausführen , dann User anlegen.

Meine User werden alle über authdaemon.plain von Courier angemeldet. Wenn Du Mysql nutzen willst, dann mußt Du unter SuSE Courier und Postfix aus den Quellen (SPEC-Files) neu bauen.

Poste mal Dein Log aus /var/log/mail (unter SUSE)

Grüße
mccologne
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Die Möglichkeiten a und b konnte ich ausschließen.
Es liegt glaube ich am authdaemon.
Wenn ich diesen nämlich starten will kommt die folgende Fehlermeldung

Code: Alles auswählen

Shutting down Courier Authentication Daemon                           done
Starting Courier Authentication Daemon (plain) Error: authdaemond no longer handles its own daemonizing.
Use new startup script.
startproc:  exit status of parent of /usr/lib/courier-imap/authlib/authdaemond.plain: 1
                                                                      failed
Leider habe ich bis jetzt nicht so viel zu diesem Problem gefunden.
In /var/log/mail befindet sich nichts ausergewöhnliches, außer halt

Code: Alles auswählen

imapd: Connection, ip=[::ffff:192.168.0.2]
imapd: LOGIN FAILED, ip=[::ffff:192.168.0.2]
imapd: Disconnected, ip=[::ffff:192.168.0.2]
und

Code: Alles auswählen

authdaemond: Unknown option '-'


Mfg. Mercedesdriver :)
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Ah, habe das Problem gefunden.
Nachdem ich diesen Artikel gefunden habe -> http://lists.suse.com/archive/suse-linu ... /2534.html habe ich mit mal das Patch-RPM von SuSE heruntergeladen.
Und tatsächlich behebt es das Problem.
Jetzt funktioniert auch alles schön :D.

Danke für deine Hilfe!

Mfg. Mercedesdriver :)
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Ein Problem habe ich jedoch noch ;).
Anscheinend können irgendwie keine Ordner erstellt werden (Grund: Invalid mailbox name).
Auch das manuelle Anlegen eines solchen Ordners im Maildir-Ordner brachte nichts.
Gibt es vielleicht da eine Lösung?

Mfg. Mercedesdriver :)
Benutzeravatar
mccologne
Newbie
Newbie
Beiträge: 10
Registriert: 22. Dez 2004, 21:50

Beitrag von mccologne »

Hallo,

als erstmal mußt Du als User den Befehl
maildirmake Maildir/
ausführen.
Siehe auch "man maildirmake", da findest Du auch Hinweise wie man "Shared Ordner" systemweit anlegen kann.
Damit ist Deine Inbox im Maildir-Format vorhanden. Dann kannst Du mit jedem IMAP-Mail-Client (z.B. Kmail) weitere Unterordner anlegen.
Wichtig ist halt dein User die INBOX erstellt, ansonsten hat er keine Rechte darauf!

Postfix kann Mails dann in INBOX im Maildir-Format reinschreiben.
Siehe meine Postfix-Config:
/etc/postfix/main.cf
...
home_mailbox = Maildir/
....

Und wenn es geht, beobachte mit
tail -f /var/log/mail
dein Logfile, denn dort werden eigendlich alle Fehler aufgezeigt.

Grüße
mccologne
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Ich meinte eher das Problem das man nur Ordner unterhalb von "INBOX" anlegen kann. Das Problem wird unter http://www.courier-mta.org/FAQ.html#namespace auch beschrieben. Jedoch habe ich nicht genau kapiert, wie ich das Problem umgehen kann.

Mfg. Mercedesdriver :)
Benutzeravatar
mccologne
Newbie
Newbie
Beiträge: 10
Registriert: 22. Dez 2004, 21:50

Beitrag von mccologne »

Achso....

Da habe ich zuletzt auf der Mailingliste von Postfix von gelesen.
Habe mal danach gesucht, finde es aber nicht mehr!
Ich kann mich daran erinnern, das in der /etc/courier/imap.cf was verändert werden muß, aber was kriege ich nicht mehr zusammen.
Hier die Url der Liste:
http://listi.jpberlin.de/pipermail/postfixbuch-users/

Grüße
mccologne
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Wahrscheinlich meintest du diesen Artikel -> http://listi.jpberlin.de/pipermail/post ... 15019.html .
Leider hat er mir nicht viel weitergeholfen ...
Hast du noch etwas anderes gefunden?

Mfg. Mercedesdriver :)
Benutzeravatar
mccologne
Newbie
Newbie
Beiträge: 10
Registriert: 22. Dez 2004, 21:50

Beitrag von mccologne »

Jein...

unter /etc/courier/imapd kannst Du den Inbox-Namen ändern!
Statt Maildir kann man da Z.B INBOX angeben.
Dann mußt Du mit "maildirmake INBOX" deine Mailbox anlegen.
Aber sonst habe ich keine Idee mehr...
Poste mal auf der Postfixliste. Dort werden allgem. Themen rund um Postfix-Mailserver abgehandelt.

Grüße
mccologne
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

bei cyrus hatte ich das problem auch.

loesen kann man es im MUA - dort das imap-prefix auf "INBOX." setzen.

(z.b. beim thunderbird: extras - konten - server - erweitert - imasp-server-verz.)

evtl. geht das bei courier auch - einfach mal den imap-prefix setzen.

muesste bei courier "Maildir" oder so sein...


evtl. hilfts.....
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Liegt anscheinend wirklich an den Einstellungen vom Mailclient.
Da ich mit Horde das Webinterface mache habe ich dazu noch eine Frage.
Wie lauten die Einstellungen für das Auslesen der Quotas von Courier in Horde (ich glaub in der server.php)?
Muss für Quotas noch was anderes außer "maildirmake -q
>>1000000S ./maildir" gemacht werden? (Unter Cyrus funktioniert alles super)

Mfg. Mercedesdriver :)
Gesperrt