Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix loggt nichtmehr !

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

smtpd -o folgt eine OPTION.

smtpd -v ist fuer verbose logging. siehe: http://www.postfix.org/DEBUG_README.html

Making Postfix daemon programs more verbose

Append one or more "-v" options to selected daemon definitions in /etc/postfix/master.cf and type "postfix reload". This will cause a lot of activity to be logged to the syslog daemon. Example:

/etc/postfix/master.cf:
smtp inet n - n - - smtpd -v
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

aber noch einfacher: laeuft dein syslog???
Froschpopo
Newbie
Newbie
Beiträge: 15
Registriert: 18. Mär 2005, 17:07

Beitrag von Froschpopo »

der läuft, weil ich hab die ganze zeit tail -f /var/log/httpd/access_log am laufen und das funzt prima.

aber noch ne frage zu deinen beiden vorrednern, was soll ich denn jetzt in master.cf ändern??
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

ups war ich da falsch mit -o

stimmt -v war es

sorry
Zuletzt geändert von crazyrolf am 18. Mär 2005, 18:21, insgesamt 1-mal geändert.
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

syslog

rolf:/home/rolf # rcsyslog status
Checking for service syslog: running
Gruß crazyrolf
-EX-Moderator-Mail-
Froschpopo
Newbie
Newbie
Beiträge: 15
Registriert: 18. Mär 2005, 17:07

Beitrag von Froschpopo »

wenn ich -v hinter smtpd setze, dann loggt er auch nicht. Aber ich kann Mails senden und empfangen
Froschpopo
Newbie
Newbie
Beiträge: 15
Registriert: 18. Mär 2005, 17:07

Beitrag von Froschpopo »

jup der syslog rennt
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

zur zeit fällt mir da nicht viel ein!?!?!?

ich denke....................


:lol:
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

wie sieht es denn mit einträgen in der var/log/mail.info aus.
oder mail.warn

ist da auch nix neues drin?
Gruß crazyrolf
-EX-Moderator-Mail-
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

syslog neu starten hilft manchmal - rcsyslog restart....

an der master.cf _kannst_ du mit der option -v das logging
auf verbose stellen - aber das muss nicht sein. es reicht ja schon
wenn der gute alte postfix ueberhaupt was loggt...

zum thema alte distri: die distri ist sch... egal! postfix aus den
quellen bauen mach ich mit jeder neuen release - z.z. mit
der 2.3er version. schwer ist das nicht....
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

also vielleicht mal ein upgrade???
Gruß crazyrolf
-EX-Moderator-Mail-
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

ich tippe jetzt erst mal auf den syslog - einfach mal neu starten.

wenns vorher ging muss es jetzt auch noch gehen :-)
Froschpopo
Newbie
Newbie
Beiträge: 15
Registriert: 18. Mär 2005, 17:07

Beitrag von Froschpopo »

Das bezweifel ich da er nach neustart des servers sowieso neugestartet wird. Der letzte Eintrag in /var/log/mail stammt vom November 2004 ! Ich starte den Server jedoch alle 1-2 Woche/n neu ! Kann also daran auch nicht gelegen haben.
Froschpopo
Newbie
Newbie
Beiträge: 15
Registriert: 18. Mär 2005, 17:07

Beitrag von Froschpopo »

PS: kann es vielleicht daran liegen, dass man vielleicht in der virtual auch angaben zu ner log machen muss? hab dort nur @domain.de user stehen
dermichel
Advanced Hacker
Advanced Hacker
Beiträge: 1169
Registriert: 20. Apr 2004, 22:36
Wohnort: Neuweiler / Saarland
Kontaktdaten:

Beitrag von dermichel »

in der virtual kann/muss man in sachen log nix angeben.

ist in der main.cf auch alles richtig eingetragen?

syslog_facility = mail
syslog_name = postfix


und im syslog:

/etc/syslogd.conf

#
# all email-messages in one file
#
mail.* -/var/log/mail
mail.info -/var/log/mail.info
mail.warn -/var/log/mail.warn
mail.err /var/log/mail.err
Gesperrt