Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

USB Kamera wird nicht mehr eingebunden

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
buschmann
Member
Member
Beiträge: 127
Registriert: 15. Nov 2004, 16:37
Wohnort: Ostwestfalen und Dresden
Kontaktdaten:

USB Kamera wird nicht mehr eingebunden

Beitrag von buschmann »

Hallo,

ich habe ein kleines Problem mit meiner Kamera. Sie wurde bisher immer einwandfrei vom System erkannt und automatisch eingebunden. Seit neuestem funktioniert das nicht mehr. Sie wird zwar noch erkannt, aber es wird kein Eintrag mehr unter drives:// bzw. Arbeitsplatz vorgenommen. Ich kann sie allerdings ohne Probleme manuell einbinden, nur fand ich die Automatik schon praktischer, vor allem weil meine Eltern sonst wieder überfordert sind ;-)

Mein System:
SuSE Linux 9.2
Kernel 2.6.11.4 (dachte nen Update bringt was, hat aber nix verändert)
KDE 3.4
Kamera Casio Exilim EX-Z55

Wenn ich in der Kamera den Verbindugstyp von Mass Storage auf PTP umstelle, dann wird sie automisch erkannt und er bietet an, dass camer:// Modul zu starten. Da funktioniert alles, nur ist es furchtbar langsam. Und als Mass Storage USB Festplatte war es angenehmer eingebunden. Hier mal der Abschnitt meiner /var/log/messages wenn ich sie reinstöpsle:

Code: Alles auswählen

Mar 18 14:23:45 linux kernel: usb 1-1: new full speed USB device using uhci_hcd and address 7
Mar 18 14:23:45 linux kernel: usb 1-1: configuration #1 chosen from 2 choices
Mar 18 14:23:46 linux kernel: scsi4 : SCSI emulation for USB Mass Storage devices
Mar 18 14:23:46 linux kernel: usb-storage: device found at 7
Mar 18 14:23:46 linux kernel: usb-storage: waiting for device to settle before scanning
Mar 18 14:23:52 linux kernel:   Vendor: Casio     Model: QV DigitalCamera  Rev: 1000
Mar 18 14:23:52 linux kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
Mar 18 14:23:52 linux kernel: SCSI device sda: 494080 512-byte hdwr sectors (253 MB)
Mar 18 14:23:52 linux kernel: sda: Write Protect is off
Mar 18 14:23:52 linux kernel: sda: Mode Sense: 00 46 02 00
Mar 18 14:23:52 linux kernel: sda: assuming drive cache: write through
Mar 18 14:23:52 linux kernel: SCSI device sda: 494080 512-byte hdwr sectors (253 MB)
Mar 18 14:23:52 linux kernel: sda: Write Protect is off
Mar 18 14:23:52 linux kernel: sda: Mode Sense: 00 46 02 00
Mar 18 14:23:52 linux kernel: sda: assuming drive cache: write through
Mar 18 14:23:52 linux kernel:  sda: sda1
Mar 18 14:23:52 linux kernel: Attached scsi removable disk sda at scsi4, channel 0, id 0, lun 0
Mar 18 14:23:52 linux kernel: Attached scsi generic sg0 at scsi4, channel 0, id 0, lun 0,  type 0
Mar 18 14:23:52 linux kernel: usb-storage: device scan complete
Mar 18 14:24:02 linux /etc/dev.d/block/50-hwscan.dev[13305]: new block device /block/sda/sda1
Mar 18 14:24:03 linux /etc/dev.d/block/51-subfs.dev[13315]: mount block device /block/sda/sda1
Mar 18 14:24:03 linux /etc/dev.d/block/50-hwscan.dev[13372]: new block device /block/sda
Mar 18 14:24:03 linux /etc/dev.d/block/51-subfs.dev[13382]: mount block device /block/sda
Und das hier passiert beim ausstöpseln:

Code: Alles auswählen

Mar 18 14:37:07 linux kernel: usb 1-1: USB disconnect, address 7
Mar 18 14:37:07 linux /sbin/hotplug[13566]: unknown command
Mar 18 14:37:08 linux /sbin/hotplug[13565]: unknown command
Mar 18 14:37:18 linux /etc/dev.d/block/51-subfs.dev[13671]: umount block device /block/sda/sda1
Mar 18 14:37:18 linux /etc/dev.d/block/51-subfs.dev[13671]: umount: /dev/sda1: not mounted
Mar 18 14:37:18 linux /etc/dev.d/block/51-subfs.dev[13686]: umount block device /block/sda
Mar 18 14:37:18 linux /etc/dev.d/block/51-subfs.dev[13686]: umount: /dev/sda: not mounted
Ich hab schon alles mögliche ausprobiert....aber es wil einfach nicht.... :(

Schöne Grüße

Buschmann
"Du bist anderer Meinung als ich und ich werde dein Recht dazu bis in den Tod verteidigen." François Marie Arouet - genannt Voltaire (1694-1778)
buschmann
Member
Member
Beiträge: 127
Registriert: 15. Nov 2004, 16:37
Wohnort: Ostwestfalen und Dresden
Kontaktdaten:

Beitrag von buschmann »

Hm, nach einer Reinstallation des letzten offiziellen Kernels von SuSE ging wieder alles einwandfrei. Gibt es irgendeine Kerneloption, die unbedingt aktiviert sein muss, damit der SuSE Plugger ienwandfrei funktioniert, oder arbeitet der generell nur mit offiziellen SuSE Kerneln zusammen??? Gibt es vielleicht ein vergleichbares Progrämmchen???
"Du bist anderer Meinung als ich und ich werde dein Recht dazu bis in den Tod verteidigen." François Marie Arouet - genannt Voltaire (1694-1778)
Antworten