Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

gelöst: rpm

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
milos
Newbie
Newbie
Beiträge: 9
Registriert: 30. Dez 2004, 18:03

gelöst: rpm

Beitrag von milos »

guten abend zusammen!

es mag vielleicht sein das ich das falsche thread ins falsche forum schreibe, aber ich wüßte nicht wohin sonst.

ich habe ein problem mit der installation von firefox 1.0.1, ich habe mir ihn gerade als rpm runtergezogen und wollte ihn jetzt installieren, aber da bekomme ich ständig diesen fehler:

inux:~/Desktop # rpm -i MozillaFirefox-1.0.1-4.1.i586.rpm
warning: MozillaFirefox-1.0.1-4.1.i586.rpm: V3 DSA signature: NOKEY, key ID 71423d59
error: Failed dependencies:
libpopt.so.0 is needed by MozillaFirefox-1.0.1-4.1
linux:~/Desktop #

vielen dank für eure hilfe!
OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid »

libpopt.so.0 is needed by MozillaFirefox-1.0.1-4.1
mit hilfe dieses Links solltest du die fehlende lib leicht finden

FAQ: Welches rpm-paket enthält die datei xyz
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

Welche SuSE-Version verwendest Du und welches Firefox-RPM hast Du heruntergeladen? Ich behaupte einfach mal, dass Du das falsche RPM heruntergeladen hast.

ftp://ftp.suse.com/pub/projects/mozilla/firefox

Da gibt es für jede SuSE-Version ein genau passendes Firefox-RPM.
OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid »

Ich behaupte einfach mal, dass Du das falsche RPM heruntergeladen hast.
nein es ist nicht das falsche RPM

sein RPM stammt nur aus der Apt Source

die beiden RPM sind aber identisch

ftp://ftp.gwdg.de/pub/linux/suse/apt/Su ... 1.i586.rpm

ftp://ftp.suse.com/pub/projects/mozilla ... 1.i586.rpm

beide satmmen vom suse - projects !!!!!!!!!

welches Firefox-RPM hast Du heruntergeladen?


lesen ---->
inux:~/Desktop # rpm -i MozillaFirefox-1.0.1-4.1.i586.rpm
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz
Benutzeravatar
pawe
Member
Member
Beiträge: 148
Registriert: 14. Dez 2004, 21:38
Wohnort: Bayern
Kontaktdaten:

Beitrag von pawe »

kann mich erinnern, dass es unter SuSE 9.1 Probleme mit der libpopt.so.0 gibt (@milos: es lohnt sich bei Problemen die SuSE-Version anzugeben).

... da haben wir´s ja auch schon:
Nachtrag 1
wenn unter 9.1 eine Fehlermeldung bezgl libpopt.so.0 kommt:
dieses RPM mit rpm -Uhv popt-1.7-176.3.i586.rpm installieren
http://ftp.gwdg.de/pub/linux/suse/apt/S ... 3.i586.rpm
Also patchen, dann sollte es gehen :wink:

gruß Pawe
P III, 700 MHz, 384 MB Ram, SuSE 9.3 - fluxbox/idesk // NB: AMD 2800+, 704 MB Ram, SuSE 9.3 - KDE 3.4.

Fundiertes Wissen über Linux: www.de.linwiki.org
HowTo´s, Tutorials, Softwarelisten, Begriffserklärungen und vieles mehr!
milos
Newbie
Newbie
Beiträge: 9
Registriert: 30. Dez 2004, 18:03

..:::DANKE:::...

Beitrag von milos »

Danke Euch für Eure Bemühungen, hat geklappt...war vielleicht ein Flüchtigkeitsfehler von mir irgendwo gewesen!

Danke..................... :)
Antworten