Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Namensauflösung mit Suse 9.2 funktioniert nicht

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Pörty
Newbie
Newbie
Beiträge: 2
Registriert: 15. Mär 2005, 19:01

Namensauflösung mit Suse 9.2 funktioniert nicht

Beitrag von Pörty »

Hallo allerseits,

ich habe SuSE 9.2 neu installiert und habe Probleme mit der Namensauflösung. Als DNS-Server sind zwei Windows Server 2003 (einmal Standard, einmal SBS) angegeben.

- externe Namen werden (mit ping) immer aufgelöst
- Rechnernamen, die in /etc/hosts eingetragen sind werden aufgelöst
- andere interne Namen werden (mit ping) nie aufgelöst

Test mit dig:
"dig rechnername" liefert status: SERVFAIL
"dig rechnername.domain.local" liefert status: NOERROR und die korrekte IP-Adresse

Test mit nslookup liefert immer korrekte IP-Adressen.

Ich tippe nun auf eine fehlerhafte /etc/nsswitch:
passwd: files winbind
group: files winbind
shadow: files winbind
hosts: files dns winbind
networks: files dns
services: files
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files
publickey: files
bootparams: files
automount: files nis
aliases: files

Auffallend ist, dass bei einer geänderten hosts-Zeile zu
hosts: dns files winbind
die Namensauflösung für in /etc/hosts eingetragene Rechner sehr lange dauert.

Wie deutlich ersichtlich habe ich Samba installiert und in das Active Directory der Windows-Domäne aufgenommen. Das funktioniert.

PAM ist konfiguriert für SSH und XDM. Auch das funktioniert, allerdings sind Zugriffe darüber beim Anmelden sehr langsam (mit putty wird ein Timeout angezeigt; "wiederholen" angeklickt und die Anmeldung erfolgte), anschließend geht alles reibungslos und schnell.

SuSE-Firewall ist deaktiviert.

Bin kein Newbie und hatte mit früheren SuSE-Versionen nie Probleme in dieser Richtung.

Wer hat eine Idee, woran es liegen könnte?
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Na klar, das Problem hat mich schließlich selber hierher geführt:

http://www.linux-club.de/viewtopic.php?t=6067

Kurzfassung: das liegt an .local - in diesem Fall macht er DNS-Auflösung via Multicast.

Lies Dir den Thread mal durch und melde ob die am Ende vorgestellte Lösung funktioniert. Ich habe damals meine Domäne von .local in .home umbenannt aber das wird etwas schwierig wenn man da bereits ein Active Directory laufen hat...
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

Seite 2 des Beitrags, mitte, ist ein Beitrag von mir mit den erlaubten TLD. .home ist da auch nicht dabei...

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Schon. Aber ich bennene das jetzt nicht deswegen alles nochmal um - solange es funktioniert :)

Da gibts ja offenbar beim SLES9 die Möglichkeit MDNS auszuschalten. Würde mich mal interessieren ob das bei SuSE92 auch geht. Aber um das zu testen werde ich die Domäne auch nicht umbenennen...
carsten hat geschrieben:Bevors verloren geht:

Code: Alles auswählen

Issue:

Many companies that had a Microsoft network have setup their Windows network to use the .local domain policy. If someone then introduced a SuSE box (with the 2.6 kernel) they would end up having resolution issues with that network.

Solution:

** IMPORTANT ** You must be running the glibc package from NLD 9 SP1 or SLES 9 SP1. The full package version is glibc 2.3.3-98.38. If you are running anything earlier than this then you do not have on SP1, or it was not installed properly.

Once you have verified that the proper glibc has been installed, you will need to edit the /etc/host.conf file. There you will need to add the parameter mdns off to the bottom of the file.
Auf deutsch:
Bei Problemen mit .local in die /etc/host.conf unten reinschreiben:

Code: Alles auswählen

mdns off
Wers probiert hat bitte mal melden.

Grüße
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Pörty
Newbie
Newbie
Beiträge: 2
Registriert: 15. Mär 2005, 19:01

Es funktioniert!

Beitrag von Pörty »

Die Lösung mit "mdns off" in /etc/host.conf funktioniert; alle rechnername und rechnername.domain.local werden sofort aufgelöst.

Ein "man host.conf" erklärt das auch sehr verständlich. Mir war nur überhaupt nicht klar, dass es an .local liegen könnte. Das Problem müsste doch dann wesentlich bekannter sein. Oder verwendet niemand SuSE in Verbindung mit Windows-Netzwerken?

Der Link auf den SuSE 9.1-Thread war auch hilfreich. Mich überrascht aber, dass das Phänomen schon seit April 2004 existiert, Novell aber erst im Februar 2005 eine Lösung publiziert.

Dabei will ich nicht sagen, dass Mulitcast-DNS schlecht wäre (ich habe mich nicht genauer nach dessen Sinn erkundigt), die Voreinstellung "mdns on" finde ich aber schlecht gewählt, da ich glaube, jeder der mDNS nutzen will, ist sich dessen bewußt und kann dann expilizt "mdns on" setzen. Ich habe davon vorher noch nie etwas gehört, und mir war nicht klar, dass sich die Namensauflösung geändert hat. Folglich war mir auch nicht klar, dass ich mDNS für .local-Domänen ausschalten muss. "mdns off" als Default wäre wohl die bessere Wahl gewesen. (So, dass musste noch gesagt werde!)

Nochmals vielen Dank für die Tipps.
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

Danke für's feedback !

Vor allem freut es mich zu hören daß das mit dem Abschalten funktoniert.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Antworten