Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Webbrowser Galeon will nicht installiert werden.

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Yehudi
Guru
Guru
Beiträge: 2152
Registriert: 21. Jan 2004, 13:51
Wohnort: Hamburg
Kontaktdaten:

Webbrowser Galeon will nicht installiert werden.

Beitrag von Yehudi »

Wenn ich über Apt Galeon installiere sagt mir Synaptic:
galeon:
Benötigt: mozilla (=1.7.2) aber 1.7.5-2.1 wird installiert.

Läßt sich der Browser auf 9.2 nicht mehr installieren?
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

galeon benötigt *genau* die Version von mozilla, mit der er kompiliert wurde. Bei SuSE 9.2 war mozilla 1.7.2 dabei und nur *genau* dieses wird unterstützt. mozilla 1.7.5, welches dieses "apt" Dir gerne installieren möchte, funktioniert nicht.

Mögliche Lösungen:

- Dieses Nicht-SuSE-Tool namens "apt" beiseite legen und mozilla 1.7.2 mit dem SuSE-Tool namens YaST von den SuSE-CDs/DVDs installieren. Anschließend galeon installieren, aber bitte ebenfalls ohne dieses "apt".
- Das von SuSE in keiner Weise unterstützte mozilla 1.7.5 installieren und anschließend eine Version von galeon suchen, die mit mozilla 1.7.5 kompiliert wurde, was Dir wahrscheinlich nicht gelingen wird.
- Das von SuSE in keiner Weise unterstützte mozilla 1.7.5 installieren und galeon anschließend selbst kompilieren.

Ich kann mich an dieser Stelle wirklich nur wiederholen:

"apt" ist kein Tool für SuSE, das Tool für SuSE heißt YaST und "apt" ist nur etwas für Leute, die ganz genau wissen, was sie tun. Von SuSE bekommst Du zwei Jahre lang Sicherheitsupdates für alle RPMs, die ursprünglich dabei waren, aber auch nur für diese und keine neuen Versionen und auch nur, wenn Du Dich auf diese beschränkst und YaST Online Update verwendest.

galeon ist bei allen Distributionen von SuSE schon dabei, der offizielle und wohl auch einzig funktionierende Weg besteht darin, es mit YaST von den SuSE-CDs/DVDs zu installieren, wobei die Abhängigkeiten selbstverständlich vollautomatisch aufgelöst und durch originale SuSE-RPMs erfüllt werden. Wieso benutzt Du überhaupt dieses "apt", um eine Software zu installieren, die bei der Distribution schon dabei ist?
Yehudi
Guru
Guru
Beiträge: 2152
Registriert: 21. Jan 2004, 13:51
Wohnort: Hamburg
Kontaktdaten:

Beitrag von Yehudi »

Nun, Deine Einstellung zu dem Apt kann ich nachvollziehen. Habe mich damit auch schwer getan, weil ich es einfach nicht einsehen wollte, dass man noch ein Programm haben muss, um Programme zu instalieren. Vor allen Dingen fängt Yast mit eine Y an.
Probiere ich das ganze mit Yast aus, dann komme ich erst mal zum gleichen Ergebnis. Das besagte rpm fehlt einfach. Was natürlich sch... ist. Suchen wir das nette rpm, und installieren das mit Yast, komme ich wieder an den Punkt, wo wieder weitere Pakete fehlen. Yast kann keine Abhängigkeiten auflösen, ohne die weiteren Pakete zu haben. Das kann apt auch nicht, weil diese Packete nicht bereit stehen.
Mit anderen Worten, ich muss die Pakete selber zusammen suchen, und sie dann über die Konsole mit "force" installieren.
Dann werde ich mal die Postbote spielen:

http://prdownloads.sourceforge.net/germ ... m?download
krb5-libs-1.2.7-14.1.i386 von
http://www.megaloman.com/~hany/RPM/libcom_err.so.3.html
krb5-libs-1.2.7-14.i386
http://itp.tugraz.at/Comp/RPM/libgssapi_krb5.so.2.html
krb5-libs-1.2.7-2.i386
http://itp.tugraz.at/Comp/RPM/libk5crypto.so.3.html

http://itp.tugraz.at/Comp/RPM/libkrb5.so.3.html

sind die fehlenden Pakete.

error: Failed dependencies:
libcom_err.so.3 is needed by Mozilla-1.7.2-1
libgssapi_krb5.so.2 is needed by Mozilla-1.7.2-1
libk5crypto.so.3 is needed by Mozilla-1.7.2-1
libkrb5.so.3 is needed by Mozilla-1.7.2-1

Ich offe die Pakete stimmen jetzt alle.
Zuletzt geändert von Yehudi am 13. Mär 2005, 01:30, insgesamt 3-mal geändert.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Webbrowser Galeon will nicht installiert werden.

Beitrag von oc2pus »

Yehudi hat geschrieben:Wenn ich über Apt Galeon installiere sagt mir Synaptic:
galeon:
Benötigt: mozilla (=1.7.2) aber 1.7.5-2.1 wird installiert.

Läßt sich der Browser auf 9.2 nicht mehr installieren?
wenn man es mit apt richtig macht funktioniert das ganze auch ....

Code: Alles auswählen

apt policy mozilla
mozilla:
  Installiert: 1.7.5-2.1
  Kandidat: 1.7.5-2.1
  Versionstabelle:
 *** 1.7.5-2.1 0
       1001 ftp://ftp.gwdg.de SuSE/9.2-i386/suse-projects pkglist
       1001 ftp://ftp.gwdg.de SuSE/9.2-i386/mozilla pkglist
        100 RPM Database
     1.7.2-17.4 0
       1001 ftp://ftp.gwdg.de SuSE/9.2-i386/base pkglist
     1.7.2-17.2 0
       1001 ftp://ftp.gwdg.de SuSE/9.2-i386/update pkglist
wie man sieht ist mozilla-1.7.2-* sehr wohl via apt verfügbar.

=> apt install galeon mozilla=1.7.2-17.4

und schon stimmt das ganze. Ist aber im apt Forum auch schon mehrfach erklärt worden ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Yehudi
Guru
Guru
Beiträge: 2152
Registriert: 21. Jan 2004, 13:51
Wohnort: Hamburg
Kontaktdaten:

Beitrag von Yehudi »

Warum werden dann die Abhängigkeiten nicht gelöst? Weder von Yast noch von Synaptic?
Das habe ich bisher bei keinem Programm gehabt. Nun ich kann auch ohne Galeon leben.
traffic
Guru
Guru
Beiträge: 2750
Registriert: 13. Feb 2005, 05:50

Beitrag von traffic »

Lassen wir "apt" oder "nicht-apt" mal beiseite.

Du kannst mir nicht erzählen, dass mozilla nicht auffindbar ist, weil das auf Deinen CDs drauf ist. Sowohl "apt" als auch YaST können Abhängigkeiten auflösen, sehr gut sogar, das ist aber nur solange garantiert, wie Du Dich auf die Pakete beschränkst, die Dir Dein Distributor namens SuSE anbietet.

Der galeon-Browser benötigt ganz genau das Binary von mozilla, mit dem er kompiliert wurde und wenn Du mir sagst, dass YaST das konkrete Binary von Mozilla, das auf Deinen CDs drauf ist, nicht installieren kann, dann glaube ich Dir das schlicht und einfach nicht.

Genug gestritten, wenn Du jetzt anfängst,

- mozilla aus dem in keiner Weise unterstützten "projects"-Verzeichnis vom SuSE-FTP-Server zu installieren
- mozilla von irgendeiner höchst inoffiziellen Sourceforge-Webseite zu installieren

dann wirst Du nur Ärger bekommen, das einzige mozilla-Binary, mit dem galeon funktioniert, ist nämlich dasjenige, welches auf Deinen CDs ist.

Wenn YaST Dir dieses nicht installieren möchte, dann kann das nur daran liegen, dass Du auf eigene Faust ein neueres oder gar aus dritter Quelle stammendes Binary von mozilla installiert hast. An der Stelle macht YaST alles richtig, weil galeon am Ende sowieso nicht funktionieren wird.

Deine Schlussfolgerungen sind genau falsch, durch das Einsammeln von RPMs aus fremden Quellen wird es nur noch schlimmer. Wenn Du galeon wirklich haben willst, dann musst Du alle fremden mozilla-Binaries komplett entfernen und anschließend mit YaST einfach galeon auswählen. Das wird die passende mozilla-Version automatisch von den CDs holen.

Wenn YaST das nicht gelingen sollte, dann bedeutet das zwangsläufig, dass Du RPMs aus fremden Quellen auf Deinem System hast. Das hat mit "apt" prinzipiell nichts zu tun, aber der unsachgemäße Einsatz von "apt" begünstigt diesen Umstand.
Antworten