Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Wlan Centrino - komme nicht zum Router?!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Key
Newbie
Newbie
Beiträge: 17
Registriert: 5. Jan 2005, 21:40

Wlan Centrino - komme nicht zum Router?!

Beitrag von Key »

Hallo zusammen,

ich bin im Prinzip Linux noob und hatte auch schon mal Probleme mit Suse+XP. Aber ich habe vor ein paar Tagen 9.2 auf meinem Notebook installiert und bin eigentlich sehr zufrieden. Wäre da nicht Wlan ...

Status: Internet läuft mit der Lan-Karte. Habe sie momentan aber deaktiviert (war ein Tipp in anderen Threads).
Es scheint mir als ob Suse die Wlan Karte erkennt und ich kann sie auch konfigurieren, aber bekomme einfach keine Verbindung zum Router (Siemens Gigaset 505 Cable/DSL) .
Bei XP wird ja zumindest ein Wlan Netz erkannt, egal ob man die Verschlüsselung und Einstellungen schon gemacht hat oder nicht...

Ich bin ratlos :(

Vielleicht könnt ihr mir weiterhelfen, wär toll!

Code: Alles auswählen

Starting Firewall Initialization (phase 1 of 3) done
<notice>exit status of (random pcmcia isdn SuSEfirewall2_init) is (0 0 0 0)
<notice>start services (network)
Setting up network interfaces:
    lo        
    lo        IP address: 127.0.0.1/8   
done    eth0      device: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 20)
    eth0      configuration: eth-id-00:02:3f:25:d5:da
    eth0      Startmode is 'off'
skipped    eth1      device: Intel Corp. PRO/Wireless 2200BG (rev 05)
    eth1      configuration: wlan-bus-pci-0000:02:02.0
    eth1      warning: using NO encryption
    eth1      is controlled by ifplugd
doneSetting up service network  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .done

<4>ipw2200: unsupported module, tainting kernel.
<6>ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.12
<6>ipw2200: Copyright(c) 2003-2004 Intel Corporation
<6>ACPI: PCI interrupt 0000:02:02.0[A] -> GSI 5 (level, low) -> IRQ 5
<6>ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection

Code: Alles auswählen


linux:/usr # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      unassociated  ESSID:off/any  Nickname:"linux"
          Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
          Bit Rate=0 kb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

sit0      no wireless extensions.
Benutzeravatar
HendrikT
Newbie
Newbie
Beiträge: 15
Registriert: 22. Sep 2004, 11:06
Wohnort: Kassel
Kontaktdaten:

Beitrag von HendrikT »

Hast Du mal probiert mit iwconfig ssid und channel vom Router zu setzen?
-Hendrik

Ubuntu 6.06 LTS

Bild
Key
Newbie
Newbie
Beiträge: 17
Registriert: 5. Jan 2005, 21:40

Beitrag von Key »

Problem gelöst. Bin nun mit der Suse Eval DVD 9.2 per Wlan/Centrino und T-Sinus DSL Router im Internet :)

Ich versuche noch mal meine Schritte aus der Linux-Noob Perspektive zu beschreiben (keine Ahnung ob alle Schritte notwendig sind) :

1. Nach Installation der Eval-DVD habe ich das ipw-Firmware rpm Paket (hab grad nicht den Link da) nachinstalliert, indem ich das Ding einfach auf die Linux Partition gepackt habe und mit Rechtsklick die Option "per Yast installieren" gewählt hab.

2. Konfiguration der Wlan Karte:

a) Unter "Routing" als Standard Gateway die IP des Routers eingetragen
b) Bei Routing-Tabellen 2x IP des Routers und 255.255.255.0 und das Wlan Gerät (wlan-id ...) ausgewählt.
c) Auf Weiter und
- Betriebsmodus "Verwaltet"
- ESSID "siehe Routereinstellung (z.B. WLAN)"
- Authetifikationsmodus "Offen"
- Schlüssel Eingabeart "Hexadezimal" (hier lag einer meiner großen Knackpunkte)
-Verschlüsselungs-Key "siehe Routereinstellung".
-Bei mehrere Schlüssel habe ich noch entsprechend der Routereinstellung auf 64 bit umgestellt.
- Unter Einstellungen für Experten Kanal/Bitrate "Automatisch" und bei Zugriffspunkt vorsichtshalber mal meine MAC Adresse eingetragen (steht z.B. in diesem Eintrag wlan-id-00-...oder mit ifconfig)
d) Dann habe ich versucht die Suse Firewall zu deaktivieren, weiß aber nicht, ob das geklappt hat und ob das was weitergeführt hat.

So, endlich hats geklappt. Jetzt installiere ich die fehlenden Pakete nach und hab dann hoffentlich mein lang ersehntes Suse auf dem Rechner ;)
Antworten