Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

mit winbind auf w2k PDC Server Userdaten holen

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
superbike
Member
Member
Beiträge: 71
Registriert: 25. Feb 2005, 16:08
Kontaktdaten:

mit winbind auf w2k PDC Server Userdaten holen

Beitrag von superbike »

HalLo Leute,
ich versuche von meinem Suse 9.2 Webserver die User / Passworte von meinem PDC (Active Directories) zu holen; habe nach der Anleitung http://gertranssmb3.berlios.de/output/winbind.html gearbeitet (nscd abgestellt usw.).
Kann mich am PDC mit net rpc join -S PDC Administrator einklinken. mit wbinfo -u erhalte ich alle User des PDC, aber ohne den Domainname vorangestellt, dasselbe bei den Gruppen. Mit getent passwd aber erhalte ich nichts vom PDC (nur lokale Linuxuserdaten). Meine smb.conf:

Code: Alles auswählen

[global]
	idmap gid = 10000-20000
	include = /etc/samba/dhcp.conf
	logon drive = P:
	username map = /etc/samba/smbusers
	map to guest = Bad User
	winbind trusted domains only = yes
	encrypt passwords = yes
	printer admin = @ntadmin, root, administrator
	passdb backend = smbpasswd
	logon home = \\%L\%U\.9xprofile
	template shell = /bin/bash
	printcap cache time = 750
	netbios name = Lexus
	cups options = raw

	printing = cups
	ldap machine suffix = ou=Computers
	idmap uid = 10000-20000
	password server = *
	ldap suffix = dc=example,dc=com
	template homedir = /home/%D/%U
	workgroup = ARATHUNERSEE
	logon path = \\%L\profiles\.msprofile
	os level = 20
	printcap name = cups
	security = domain
	ldap idmap suffix = ou=Idmap
	winbind separator = +
	winbind cache time = 10
So nah am Ziel und doch so ratlos... Wer kann mir weiterhelfen ?
Benutzeravatar
superbike
Member
Member
Beiträge: 71
Registriert: 25. Feb 2005, 16:08
Kontaktdaten:

Beitrag von superbike »

mein Problem :
warum erhalte ich die w2kUser und Gruppen nicht mit getent passwd / group :?:
Warum übernimmt samba die w2kUser-Daten nicht :?:
Warum muss ich mich beim Zugriff auf ein w2k-Netzwerklaufwerk noch anmelden :?:
Benutzeravatar
superbike
Member
Member
Beiträge: 71
Registriert: 25. Feb 2005, 16:08
Kontaktdaten:

Beitrag von superbike »

ja habs so gemacht wie (sehr gut :D )beschrieben: Hier meine /etc/nsswitch.conf:

Code: Alles auswählen

passwd:	files winbind
shadow:	files
group:	files winbind
hosts:	files dns winbind
networks:	files dns winbind
services:	files
protocols:	files
rpc:	files
ethers:	files
netmasks:	files
netgroup:	files
publickey:	files
bootparams:	files
automount:	files nis
aliases:	files
Symlink angelegt; Cache geladen mit diesem Resultat:

Code: Alles auswählen

lexus:~ # ldconfig -v | grep winbind
ldconfig: Can't stat /usr/X11R6/lib/Xaw95: No such file or directory
ldconfig: Can't stat /usr/X11R6/lib/Xaw3d: No such file or directory
ldconfig: Can't stat /usr/i486-linux/lib: No such file or directory
ldconfig: Can't stat /usr/i486-linux-libc5/lib: No such file or directory
ldconfig: Can't stat /usr/i486-linux-libc6/lib: No such file or directory
ldconfig: Can't stat /usr/i486-linuxaout/lib: No such file or directory
ldconfig: Can't stat /usr/i386-suse-linux/lib: No such file or directory
ldconfig: Can't stat /usr/openwin/lib: No such file or directory
ldconfig: Can't stat /opt/kde/lib: No such file or directory
ldconfig: Can't stat /opt/kde2/lib: No such file or directory
ldconfig: Can't stat /opt/gnome2/lib: No such file or directory
        libnss_winbind.so.2 -> libnss_winbind.so
ldconfig: Cannot stat /usr/lib/libpt.so: No such file or directory
lexus:~ #
Nach erfolreichem net rpc join -S PDC -U Administrator erhalte ich mit getent passwd alle Linuxuser, aber keiner vom w2k:

Code: Alles auswählen

lexus:~ # getent passwd
root:x:0:0:root:/root:/bin/bash
bin:x:1:1:bin:/bin:/bin/bash
daemon:x:2:2:Daemon:/sbin:/bin/bash
lp:x:4:7:Printing daemon:/var/spool/lpd:/bin/bash
mail:x:8:12:Mailer daemon:/var/spool/clientmqueue:/bin/false
games:x:12:100:Games account:/var/games:/bin/bash
at:x:25:25:Batch jobs daemon:/var/spool/atjobs:/bin/bash
wwwrun:x:30:8:WWW daemon apache:/var/lib/wwwrun:/bin/false
squid:x:31:65534:WWW-proxy squid:/var/cache/squid:/bin/false
irc:x:39:65534:IRC daemon:/usr/lib/ircd:/bin/bash
ftp:x:40:49:FTP account:/srv/ftp:/bin/bash
named:x:44:44:Name server daemon:/var/lib/named:/bin/false
postfix:x:51:51:Postfix Daemon:/var/spool/postfix:/bin/false
pop:x:67:100:POP admin:/var/lib/pop:/bin/false
sshd:x:71:65:SSH daemon:/var/lib/sshd:/bin/false
mailman:x:72:67:GNU mailing list manager:/var/lib/mailman:/bin/bash
ntp:x:74:65534:NTP daemon:/var/lib/ntp:/bin/false
ldap:x:76:70:User for OpenLDAP:/var/lib/ldap:/bin/bash
dhcpd:x:100:65534:DHCP server daemon:/var/lib/dhcp:/bin/false
radiusd:x:101:101:Radius daemon:/var/lib/radiusd:/bin/false
privoxy:x:102:102:Daemon user for privoxy:/var/lib/privoxy:/bin/false
vdr:x:103:33:Video Disk Recorder:/var/spool/video:/bin/false
quagga:x:104:103:Quagga routing daemon:/var/run/quagga:/bin/false
nobody:x:65534:65533:nobody:/var/lib/nobody:/bin/bash
sommer:x:1000:100::/home/sommer:/bin/bash
man:x:13:62:Manual pages viewer:/var/cache/man:/bin/bash
news:x:9:13:News system:/etc/news:/bin/bash
uucp:x:10:14:Unix-to-Unix CoPy system:/etc/uucp:/bin/bash
bitdefender:x:1001:1000::/opt/BitDefender:/bin/false
lexus:~ #                       
Ich kann das Problem nicht lokalisieren; gibts welche Logfiles?
Benutzeravatar
superbike
Member
Member
Beiträge: 71
Registriert: 25. Feb 2005, 16:08
Kontaktdaten:

Beitrag von superbike »

winbind voranzustellen bringt keine Veränderung :oops:. Wenn ich die Original nsswitch.conf nehme mit:

Code: Alles auswählen

passwd:	compat
group:	compat
hosts:	files lwres dns
networks:	files dns
und neu boote, dann ergeben wbinfo -u / -g immer noch dieselben Resultate wie bisher (sehe die User / Gruppen, aber mit getent dann wieder nicht mehr). Also scheints nicht an dieser Konfigurationsdatei zu liegen, aber wo denn :?:
Benutzeravatar
superbike
Member
Member
Beiträge: 71
Registriert: 25. Feb 2005, 16:08
Kontaktdaten:

Anmeldung fehlgeschlagen: w2kuser an Samba3

Beitrag von superbike »

Hallo Leute,
die Lösung liegt bei winbind trusted domains only; diese Zeile in smb.conf auskommentieren, smb und winbind neu starten, getent und wbinfo funktionieren. DANKE an mcdaniels :!:
Nun hab ich aber noch das Problem, dass ich nach einem Linux-Rechner Neustart auf dem Anmeldebildschirm zwar die Symbole aller w2kuser habe,
aber keiner kann sich mit korrektem Passwort anmelden !??
net ads testjoin meldet: Join is OK; getent passwd bringt alle w2k user (ARATHUNERSEE+username) und die lokalen dazu. Meine PAM-Konfigs:

Code: Alles auswählen

/etc/pam.d/samba
#%PAM-1.0
auth            sufficient      pam_winbind.so
auth            required        pam_unix.so nullok
account         sufficient      pam_winbind.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_unix.so 

Code: Alles auswählen

/etc/pam.d/login
#%PAM-1.0
auth        required     pam_securetty.so
auth        sufficient   pam_winbind.so
auth        sufficient   pam_unix.so use_first_pass
auth        required     pam_stack.so service=system-auth
auth        required     pam_nologin.so
account     sufficient   pam_winbind.so
account     required     pam_stack.so service=system-auth
password    required     pam_stack.so service=system-auth
session     required     pam_stack.so service=system-auth
session     optional     pam_console.so 
Wer kann mir weiterhelfen ?
Antworten