Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Tastaturprobleme

Moderator: Moderatoren

Antworten
mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

[gelöst] Tastaturprobleme

Beitrag von mechanicus »

Hallo,

nachdem ich uebers Netz Sarge auf dem LH6000/Server installiert habe, gibt es Tastaturprobleme.
In der Konsole ohne X ist alles i.O., unter X habe ich jedoch das amerikanische Layout.
Auch

Code: Alles auswählen

dpkg-reconfigure xserver/xfree86
aenderte daran nichts.
Meine XF86Config/4 sieht folgendermassen aus
  • Section "Files"
    FontPath "unix/:7100" # local font server
    # if the local font server has problems, we can fall back on these
    FontPath "/usr/lib/X11/fonts/misc"
    FontPath "/usr/lib/X11/fonts/cyrillic"
    FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/lib/X11/fonts/Type1"
    FontPath "/usr/lib/X11/fonts/CID"
    FontPath "/usr/lib/X11/fonts/Speedo"
    FontPath "/usr/lib/X11/fonts/100dpi"
    FontPath "/usr/lib/X11/fonts/75dpi"
    EndSection

    Section "Module"
    Load "GLcore"
    Load "bitmap"
    Load "dbe"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "record"
    Load "speedo"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "keyboard"
    Option "CoreKeyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de"
    Option "XkbVariant" "nodeadkeys"
    Option "XkbOptions" "nodeadkeys"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/psaux"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    EndSection
    Section "InputDevice"
    Identifier "Generic Mouse"
    Driver "mouse"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Device"
    Identifier "Standardgrafikkarte"
    Driver "ati"
    EndSection

    Section "Monitor"
    Identifier "Standardbildschirm"
    HorizSync 32-60
    VertRefresh 56-75
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Standardgrafikkarte"
    Monitor "Standardbildschirm"
    DefaultDepth 16
    SubSection "Display"
    Depth 1
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "Generic Mouse"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection
Was nun?

Anton
Zuletzt geändert von mechanicus am 10. Mär 2005, 09:09, insgesamt 1-mal geändert.
OldKid
Hacker
Hacker
Beiträge: 448
Registriert: 2. Aug 2004, 19:37
Wohnort: Sauerland
Kontaktdaten:

Beitrag von OldKid »

schau mal hier :
Debian auf deutsch
“Regression testing? What's that? If it compiles, it is good, if it boots up it is perfect.”Linus Torvalds
AMD64 X2 4200+ - 4GB RAM - 1,2 TB Disk - GeForce 8400 GS - 2.6.38-ck
Creative Commons Lizenz
mechanicus
Hacker
Hacker
Beiträge: 299
Registriert: 14. Jan 2005, 22:26

Beitrag von mechanicus »

oldkid30 hat geschrieben:schau mal hier :
Debian auf deutsch
Danke für den Tip, aber ganz so einfach ist das leider nicht.
Natürlich ist locales installiert, in der /etc/locales.gen findet sich auch der korrekte Eintrag

Code: Alles auswählen

de_DE@euro ISO-8859-15
Ich möchte noch hinzufügen, daß dieses defekte Tastaturlayout in allen X-Anwendungen vorhanden ist (Mozilla, Office, Editoren, ...), seltsamerweise aber nicht im grafischen Login.
Ich habe zwischenzeitlich herausgefunden, daß unter KDE alles i.O. ist, scheint also Gnome zu sein.
Eine abgesicherte Sitzung ließ sich leider nicht starten, da xterm nicht gefunden wurde.
Hmm, irgendwie scheint die Installationsroutine Murks zu sein. Beim NetInst-Image stimmte aber die md5-Summe.

Anton


Spätere Ergänzung:

In Gnome war das Tastaturlayout auf us gesetzt!
Die Installation von Debian finde ich stark verbesserungswürdig. Nicht nur, daß per default der 2.4'er Kernel eingerichtet wird und die i2o Unterstützung schlecht ist, es sind diese ganzen Nachlässigkeiten, wie der oben geschilderte Fall und andere (z.B. kein Fontserver installiert, obwohl in der XF86Config angegeben), die schlicht ärgerlich sind bei diesem ansonsten großartigen System.

Anton
Antworten