Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SimCity3000unlimited Fehler bei Start

Alles rund um Büroanwendungen, Bildungsprogramme und Spiele unter Linux

Moderator: Moderatoren

Antworten
setpatch
Newbie
Newbie
Beiträge: 22
Registriert: 29. Jan 2004, 20:32
Kontaktdaten:

SimCity3000unlimited Fehler bei Start

Beitrag von setpatch »

:?: Habe hier auf Suse 9 SimCity3000unlimited installiert, ging auch problemlos.

Wenn ich jetzt mit sc3u starte in Konsole, dann kommt folgende Fehlermeldung:

sc3u: relocation error: sc3u: symbol _dl_global_scope, version GLIBC_2.0 not defined in file ld-linux.so.2 with link time reference

Was will mir der Dichter damit sagen? Jemand 'ne Idee, wie ich das regeln kann?
Thx im Voraus.
setpatch
Benutzeravatar
der_schreiner
Member
Member
Beiträge: 218
Registriert: 5. Dez 2003, 16:05
Wohnort: Abtwil (CH)
Kontaktdaten:

Re: SimCity3000unlimited Fehler bei Start

Beitrag von der_schreiner »

setpatch hat geschrieben:sc3u: relocation error: sc3u: symbol _dl_global_scope, version GLIBC_2.0 not defined in file ld-linux.so.2 with link time reference
Schau dir mal folgeden Link an, dann weisst du was dir fehlt!

http://www.gnu.org/software/libc/libc.html

Sollte aber warscheindlich auf deiner SuSE CD/DVD als rpm enthalten sein, installieren und dann sollte es eigentlich gehen.
Michael

habe auch probleme mit glib2

Beitrag von Michael »

Hi,

ich habe nachgeschaut und festgestellt, dass meine GLIB version viel neuer ist: 2.2.3-21, als die verlangte 2.0.
Das ist die Fehlermeldung:
"sc3u: relocation error: sc3u: symbol _dl_global_scope, version GLIBC_2.0 not defined in file ld-linux.so.2 with link time reference"


Wer weiß Rat??

lg
michael
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

Re: habe auch probleme mit glib2

Beitrag von marcor »

Michael hat geschrieben:Hi,

ich habe nachgeschaut und festgestellt, dass meine GLIB version viel neuer ist: 2.2.3-21, als die verlangte 2.0.
Das ist die Fehlermeldung:
"sc3u: relocation error: sc3u: symbol _dl_global_scope, version GLIBC_2.0 not defined in file ld-linux.so.2 with link time reference"


Wer weiß Rat??

lg
michael
Schau mal unter

http://www.lokigames.com

da gibt es einen Patch für SimCity. Damit müsste das laufen.
setpatch
Newbie
Newbie
Beiträge: 22
Registriert: 29. Jan 2004, 20:32
Kontaktdaten:

Beitrag von setpatch »

:D
Thx, nach dem Update geht es sauber ab. Scheint so, daß eine ältere lib abgefragt wurde oder ähnlich, egal ich kann den Patch nur empfehlen.
setpatch
Gast

Wie geht das mit dem update??

Beitrag von Gast »

Hallo,

kann mir mal bitte jemand sagen, wie das mit dem update geht??? Habe es in der shell mit sh ... gestartet hat mich nach dem installationsort gefragt und dann war irgendwie ende....???
Wie geht es richtig, bzw. weiter??

lg
michael
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

Re: Wie geht das mit dem update??

Beitrag von marcor »

Gast hat geschrieben:Hallo,

kann mir mal bitte jemand sagen, wie das mit dem update geht??? Habe es in der shell mit sh ... gestartet hat mich nach dem installationsort gefragt und dann war irgendwie ende....???
Wie geht es richtig, bzw. weiter??

lg
michael
Hast du das Script als root ausgeführt?
Gast

Beitrag von Gast »

Hi,

ja ich habe es auch als root ausgeführt...

michael
Benutzeravatar
marcor
Member
Member
Beiträge: 198
Registriert: 21. Feb 2004, 11:05
Wohnort: Duisburg
Kontaktdaten:

Beitrag von marcor »

Dann sollte die Datei sich selbst entpacken und installieren (War bei mir auf jeden Fall so)
Gast

Beitrag von Gast »

Hat sie bei mir aber nicht...
hat immer nur nach dem Instalationspfad gefragt.
Ich dachte ich soll den Pfad für SC3U eingeben: usr/local/games/SC3U hat aber nicht weiter gemacht...
na gut, muß ich halt nochmal probieren.

danke erstmal, melde mich später wieder...
michael
hhandy
Newbie
Newbie
Beiträge: 4
Registriert: 2. Mai 2004, 01:26

Beitrag von hhandy »

an gust
Verfasst am: 2004-März-14, 12:39 pm Titel:
Hat sie bei mir aber nicht...
hat immer nur nach dem Instalationspfad gefragt.
Ich dachte ich soll den Pfad für SC3U eingeben: usr/local/games/SC3U hat aber nicht weiter gemacht...
na gut, muß ich halt nochmal probieren.

danke erstmal, melde mich später wieder...
michael
du must /usr/local/games/SC3U/ eingeben als su dann geht es
Antworten