Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

usb 2.0 kartenlesegerät 6in1

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
christosmp
Member
Member
Beiträge: 54
Registriert: 13. Nov 2004, 14:07
Wohnort: Nürnberg
Kontaktdaten:

usb 2.0 kartenlesegerät 6in1

Beitrag von christosmp »

Hi
Habe hier ein kleines Problemchen mit mein Lesegerät
Wie greife da drauf? Habe ne sd karte rein aber die finde ich net.
unter usbview sehe das er was findet.
HILFE
dankeschön
Zuletzt geändert von christosmp am 4. Mär 2005, 14:03, insgesamt 1-mal geändert.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Einstecken und fürs erste einige Minuten abwarten,
die automatische Anbindungsfunktion durfte den
Inhalt in kurzem auf dem Desktop in einem Fenster
zeigen.

Alternativ mit Konqueror im Verzeichnis /media
nachschauen.

MfG
misiu
Benutzeravatar
christosmp
Member
Member
Beiträge: 54
Registriert: 13. Nov 2004, 14:07
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von christosmp »

Habe ich schon gemacht.
Da kommt nichts raus. Unter /media ist alles mögliche da aber das halt nicht.
Usb sticks macht er immer sofort und öffnet sogar ein Fenster.
Ich habe das Lesegerät schon länger eingesteckt aber nichts ist passiert.
Das Lesegerät ist nicht kaputt
Benutzeravatar
christosmp
Member
Member
Beiträge: 54
Registriert: 13. Nov 2004, 14:07
Wohnort: Nürnberg
Kontaktdaten:

Lesegerät 6in1 geht nicht

Beitrag von christosmp »

ohoh ich glaube ich habe mir vertippt
das Gerät ist ein 6in1 und nicht in 2 :lol:
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Ist das ein externe Lesegerät?
Tust du zuerst die Karte hinein und dann einstöpseln (falls
Extern)?
Was sagen die Kernelmeldungen beim anstöpseln?
Andere Büchsen ausprobiert?
Andere Art von Speicherkarten?
Wenn usbview was findet ist schon mal gut.
Was genau siest du in /media?

MfG
misiu
Benutzeravatar
christosmp
Member
Member
Beiträge: 54
Registriert: 13. Nov 2004, 14:07
Wohnort: Nürnberg
Kontaktdaten:

Beitrag von christosmp »

Es ist ein usb 2.0 Gerät. Klar ist es extern.
unter media ist mein floppy meine 2 dvd laufwerke, windows partition und die platte vom linux sonst nichts. wenn ich mein usb stick oder usb festplatte einstecke kommt sofort was raus unter media und extra noch ein fenster.
die usb büchse funktioniert da es unter winxp läuft
so viele speicherkarten habe ich net zum ausprobieren. nur sd und memory sticks.
kernelmeldungen???
wie sehe ich jetzt das??? bin mit linux noch nicht sehr weit gekommen.
ich kanns mal mit der sony cam versuchen aber glaube net das es funkt.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4001
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Und , wenn du jetzt die Karte reinsteckst, dann das Lesegerät
anschliessen tust, ist unter /media ein neues Verzeichnis zu
sehen? Hast du da draufgeklickt?

Andere USB-Büchsen sollst du auch ausprobieren, weil Linux
anders , als Windows die IRQ's verteilt und es dann möglicherweise geht (Stichwort : ACPI).

MfG
misiu
drathi81
Newbie
Newbie
Beiträge: 25
Registriert: 20. Jul 2004, 07:45
Wohnort: Unterschleißheim
Kontaktdaten:

Beitrag von drathi81 »

Hallo.

Linux spricht die meisten (mir bekannten) USB-Speicherkartenleser als SCSI-Devices an. Ich habe den Fall bei mir (vorerst) wie folgt gelöst:
Unter /media ein neues Verzeichniss anlegen, z.B. cardreader. Als root kann man nun das SCSI-Device nach /media/cardreader mounten, also ab auf die Konsole und

Code: Alles auswählen

mount /dev/sda1 /media/cardreader
eintippen.
Für sda1 muss man den entsprechneden Kartenschacht auswählen. Wenn Du Windows auf Deiner Kiste hast, bekommst Du das relativ schnell raus: Das erste Laufwerk unter Windows Deines Kartenlesers ist sda1, das zweite sdb1, usw. Ansonsten Speicherkarte rein, von sda1 bis sd[n]1 mal alles mounten und gucken, wann man das richtige Device erwischt hat.
Nach dem Mounten des Lesers reicht es bei mir, einfach einige Sekunden zu warten, bis sich automatisch ein Konquerer-Fenster auftut.
Bishergie Nachteile: :(
  • 1) Mounten und unmounten muss als root geschehen
    2) nur root kann die Bilder nach dem Kopieren löschen
Wenn ich mal mehr Zeit habe, würde ich das gerne mit Hilfe des Automounters lösen, aber die fehlt mir momentan einfach. :wink:

Gruß
drath81
LinuxOr
Newbie
Newbie
Beiträge: 35
Registriert: 9. Feb 2004, 15:45
Kontaktdaten:

Beitrag von LinuxOr »

hallo leute,
das problem mit cardreader habe ich auch und wie ich hier im board gelesen habe, ist das problem immer noch nicht gelöst.
benutzt denn keiner von euch ein cardreader oder sowas zu hause?
lasst uns bitte mal das problem aus der welt schaffen, denn ich find nirgends etwas über die benutzung von cardreader.

hilft mal bitte

ich hab eine interne cardreader ausserdem es sind auch usb-stecker und firewire-stecker auf diesem teil.
usb funktioniert ja einwandfrei aber die steckkarten nicht.
das gerät ist mit 2 kabeln(JUSB1 und JUSB2) an mein mainboard angeschlossen.

weiss jemand vielleicht weiter?
Linux is for networking
Mac is for working
Windows is for Solitair
Benutzeravatar
Linux_Beginner
Member
Member
Beiträge: 110
Registriert: 15. Mai 2005, 12:58
Wohnort: Wittlich

Beitrag von Linux_Beginner »

Hallo,

wenn ich ein Gerät an meine Linux-Kiste anstöpsel, das sich nicht direkt meldet, dann habe ich hier im FOrum irgendwann mal einen sehr guten Tipp gelesen.

Bevor Du den Kartenleser einsteckst, loggst Du Dich auf einem Terminal als root ein.

Dann gibst Du

Code: Alles auswählen

tail -f /var/log/messages
ein und drückst Enter.

Nun siehst Du online die Kernelmeldungen.

Stecke jetzt den Kartenleser in den USB-Port ein und beobachte, wie der Kernel den USB-Cardreader behandelt.

Die ersten Meldungen werden sein: New fullspeed USB-Device detected ...

Irgendwo in den Meldungen steht dann, das der Rechner die einzelnen Laufwerke in dem Cardreader als SCSI-Geräte behandelt.

In dem ganzen Meldungswust, wird dann irgendwo stehen: mounted USB-Device xxx --> /dev/sdcx (x - irgendeine Zahl)

Versuchs mal ... Hat mir unheimlich geholfen, nicht nur bei Cardreadern, Webcams, USB-Sticks sondern auch bei anderen Problemen.

Gruß

Michael
Benutzeravatar
Zinnwurm
Hacker
Hacker
Beiträge: 261
Registriert: 1. Sep 2004, 13:32
Wohnort: echo ~ Deutschland/Augsburg
Kontaktdaten:

Beitrag von Zinnwurm »

Jup, /var/log/messages ist dein Helfer. Dann muss man auch nicht probieren. Wem das automatische Mounten nicht gefällt, sollte sich mal mit der FSTab vertraut machen und die Dinger dort eintragen. ^^
Ich empfehle:

Code: Alles auswählen

man fstab
Mein Web-Framework: EatingEngine
LinuxOr
Newbie
Newbie
Beiträge: 35
Registriert: 9. Feb 2004, 15:45
Kontaktdaten:

Beitrag von LinuxOr »

hallo linux_beginner,
ich hab das so gemacht wie du es gesagt hast aber das hier ist bei mir raus gekommen:
linux:/home/linuxor # tail -f /var/log/messages
May 19 14:30:02 linux kernel: saa7134[0]: i2c eeprom 10: ff ff ff ff 15 00 0e 01 0c c0 08 00 00 00 00 00
May 19 14:30:02 linux kernel: saa7134[0]: i2c eeprom 20: 00 00 00 e3 ff ff ff ff ff ff ff ff ff ff ff ff
May 19 14:30:02 linux kernel: saa7134[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
May 19 14:30:02 linux kernel: saa7134[0]: registered device video0 [v4l2]
May 19 14:30:02 linux kernel: saa7134[0]: registered device vbi0
May 19 14:30:02 linux /usr/sbin/cron[7152]: (CRON) STARTUP (V5.0)
May 19 14:30:03 linux SuSEfirewall2: Firewall rules successfully set from /etc/sysconfig/SuSEfirewall2
May 19 14:30:14 linux kdm: :0[6896]: pam_unix2: session started for user linuxor, service xdm
May 19 14:30:42 linux su: (to root) linuxor on /dev/pts/1
May 19 14:30:42 linux su: pam_unix2: session started for user root, service su
May 19 14:31:17 linux gconfd (linuxor-7820): (Version 2.6.1) wird gestartet, Prozesskennung 7820, Benutzer »linuxor«
May 19 14:31:18 linux gconfd (linuxor-7820): Die Adresse »xml:readonly:/etc/opt/gnome/gconf/gconf.xml.mandatory« wurde an der Position 0 zu einer nur lesbaren Konfigurationsquelle aufgelöst
May 19 14:31:18 linux gconfd (linuxor-7820): Die Adresse »xml:readwrite:/home/linuxor/.gconf« wurde an der Position 1 zu einer schreibbaren Konfigurationsquelle aufgelöst
May 19 14:31:18 linux gconfd (linuxor-7820): Die Adresse »xml:readonly:/etc/opt/gnome/gconf/gconf.xml.defaults« wurde an der Position 2 zu einer nur lesbaren Konfigurationsquelle aufgelöst
May 19 14:31:18 linux bonobo-activation-server (linuxor-7825): iid OAFIID:BrokenNoType:20000808 has a NULL type
May 19 14:31:18 linux bonobo-activation-server (linuxor-7825): invalid character '#' in iid 'OAFIID:This#!!%$iid%^$%_|~!OAFIID_ContainsBadChars'
May 19 14:31:48 linux gconfd (linuxor-7820): Der GConf-Server wird nicht verwendet und daher beendet.
May 19 14:31:48 linux gconfd (linuxor-7820): Beenden
May 19 14:33:03 linux kernel: usb 2-1: reset full speed USB device using address 4
May 19 14:34:59 linux kernel: usb 2-1: reset full speed USB device using address 4
May 19 14:35:35 linux kernel: scsi: Device offlined - not ready after error recovery: host 0 channel 0 id 0 lun 2
May 19 14:37:34 linux kernel: usb 2-1: reset full speed USB device using address 4
May 19 14:44:28 linux gconfd (linuxor-7900): (Version 2.6.1) wird gestartet, Prozesskennung 7900, Benutzer »linuxor«
May 19 14:44:28 linux gconfd (linuxor-7900): Die Adresse »xml:readonly:/etc/opt/gnome/gconf/gconf.xml.mandatory« wurde an der Position 0 zu einer nur lesbaren Konfigurationsquelle aufgelöst
May 19 14:44:28 linux gconfd (linuxor-7900): Die Adresse »xml:readwrite:/home/linuxor/.gconf« wurde an der Position 1 zu einer schreibbaren Konfigurationsquelle aufgelöst
May 19 14:44:28 linux gconfd (linuxor-7900): Die Adresse »xml:readonly:/etc/opt/gnome/gconf/gconf.xml.defaults« wurde an der Position 2 zu einer nur lesbaren Konfigurationsquelle aufgelöst
May 19 14:44:28 linux gconfd (linuxor-7900): file orbit-small.c: line 1396 (ORBit_connection_set_max_buffer): assertion `LINK_IS_CONNECTION (lcnx)' failed
May 19 14:44:58 linux gconfd (linuxor-7900): Der GConf-Server wird nicht verwendet und daher beendet.
May 19 14:44:58 linux gconfd (linuxor-7900): Beenden
liegt es vielleicht an gconf - server?
Linux is for networking
Mac is for working
Windows is for Solitair
Antworten