Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Externe Adresse geht nicht.

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
jumanji
Member
Member
Beiträge: 92
Registriert: 10. Dez 2004, 12:44
Kontaktdaten:

Externe Adresse geht nicht.

Beitrag von jumanji »

Hallo Zusammen,

ich habe hier einen internen DNS-Server aufgesetzt. Die Domain lautet intern firma.local und ist auch zu erreichen, sowie alles anderen weltweiten Domains 8) Nur erreiche ich unsere externe Adresse firma.de nicht. In der named.conf habe ich unter forwarders die DNS-Server unseres ISP eingetragen. In- und extern es die gleichen Domainnamen nur mit einer TLD intern local und extern de.

Evtl. sehe ich den Wald vor lauter Bäumen nicht, hat da jemand einen Tipp bzw. Idee, wo mein Fehler liegen könnte?

Danke im Voraus.

jumanji
drathi81
Newbie
Newbie
Beiträge: 25
Registriert: 20. Jul 2004, 07:45
Wohnort: Unterschleißheim
Kontaktdaten:

Beitrag von drathi81 »

Hi jumanji,

was mich etwas stutzig macht: Dein DNS läuft intern wirklich 100%-ig mit er TLD .local?? Siehe dazu auch: http://www.linux-club.de/viewtopic.php?t=6067&start=25

Ich hatte damals mit .local die tollsten Probleme... :wink:

Gruß
drathi81
Benutzeravatar
jumanji
Member
Member
Beiträge: 92
Registriert: 10. Dez 2004, 12:44
Kontaktdaten:

Beitrag von jumanji »

drathi81 hat geschrieben:Hi jumanji,

was mich etwas stutzig macht: Dein DNS läuft intern wirklich 100%-ig mit er TLD .local?? Siehe dazu auch: http://www.linux-club.de/viewtopic.php?t=6067&start=25
Hi,

also bei mir klappt das problemlos und wirklich keine Probs, außer mit der externen Domain will das nicht, bzw. geht nur vom Server aus. Ich weiß, das einige das im Intranet so machen mit TLD local.

Gruß,

jumanji
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

evt. fehlerhafter hosts Eintrag, oder in den zonendatein
geht der ping mit ip-nummer (vom client)
und ping -a firma-de (von client)
was bringt nslookup firma.de


By Huflatisch
Benutzeravatar
jumanji
Member
Member
Beiträge: 92
Registriert: 10. Dez 2004, 12:44
Kontaktdaten:

Beitrag von jumanji »

Huflatisch hat geschrieben:Hey

evt. fehlerhafter hosts Eintrag, oder in den zonendatein
geht der ping mit ip-nummer (vom client)
und ping -a firma-de (von client)
was bringt nslookup firma.de


By Huflatisch
Hi,

ping auf IP geht und ping auf Name geht nicht.

Ich habe statt nslookup dig eingegeben:

; <<>> DiG 9.2.2 <<>> www.firma.de
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52956
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 6, ADDITIONAL: 8

;; QUESTION SECTION:
;www.firma.de. IN A

;; ANSWER SECTION:
www.firma.de. 86083 IN A 192.67.198.51

;; AUTHORITY SECTION:
de. 86334 IN NS z.nic.de.
de. 86334 IN NS a.nic.de.
de. 86334 IN NS c.de.net.
de. 86334 IN NS f.nic.de.
de. 86334 IN NS l.de.net.
de. 86334 IN NS s.de.net.

;; ADDITIONAL SECTION:
a.nic.de. 40012 IN A 193.0.7.3
c.de.net. 34597 IN A 208.48.81.43
f.nic.de. 38296 IN A 81.91.161.4
f.nic.de. 15615 IN AAAA 2001:608:6::5
l.de.net. 37602 IN A 217.51.137.213
s.de.net. 124039 IN A 193.159.170.149
z.nic.de. 1687 IN A 194.246.96.1
z.nic.de. 3135 IN AAAA 2001:628:453:4905::53

;; Query time: 57 msec
;; SERVER: 194.77.111.24#53(194.77.111.24)
;; WHEN: Mon Mar 7 08:59:17 2005
;; MSG SIZE rcvd: 307

Sieht aber so ganz ok aus, soweit läuft der DNS-Server.
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

So wies aussieht haut dein zonefile nicht hin
;; QUESTION SECTION:
;www.firma.de. IN A

;; ANSWER SECTION:
www.firma.de. 86083 IN A 192.67.198.51
poste mal dieses
und poste mal die named.conf wo die zonenfiles definiert sind

By huflatisch
Benutzeravatar
jumanji
Member
Member
Beiträge: 92
Registriert: 10. Dez 2004, 12:44
Kontaktdaten:

Beitrag von jumanji »

Hi,

hier die named.conf:

options {
directory "/var/named";
pid-file "/var/run/named/named.pid";

listen-on { any; };

sortlist {
{ localhost; localnets; };
{ localnets; };
};
auth-nxdomain no;

forward first;
/*
* syntax for "forwarders"
* forwarders { <ip>; [<ip>; ...; <ip>; ] };
* e.g. forwarders { 192.168.1.1; 192.168.1.2; }; or
* forwarders { 192.168.1.1; };
*/
forwarders { 194.77.8.1; 194.77.111.24; };
};

logging {
category lame-servers { null; };
};

zone "." {
type hint;
file "root.hint";
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "127.0.0.zone";
allow-update { none; };
};
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

du hast doch gar keine zone firma.local definiert. Deshalb hast du auch keine Probleme mit firma.local

Wo hast du den firma.de und oder firma.local eingetragen.
Arbeite dich mal hier durch.

http://sman.informatik.htw-dresden.de/d ... z.DNS.allg

oder
http://www.linuxbu.ch/pdf4/kapitel15.pdf

oder
http://www.linux-tin.org/modules.php?op ... page_id=12

By huflatisch
Antworten