Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Rechte verloren nach Festplattentausch!!!??

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
maga
Newbie
Newbie
Beiträge: 10
Registriert: 22. Jun 2004, 19:36
Kontaktdaten:

Rechte verloren nach Festplattentausch!!!??

Beitrag von maga »

Hallo,

ich habe seit einiger Zeit einen Samba Server am laufen. Jetzt wurde mir die alte Festplatte zu klein, und ich habe eine 2. eingebaut. Ich habe die 2 betroffenen Ordner im Linux auf die neue Festplatte verschoben.... Das hat alles wunderbar geklappt.

Dann habe ich die rechte gesetzt.

chmod 0770
chgrp users

(so habe ich es vorher auch scho gehabt!)

naja, und jetzt wenn ich auf die Daten zugreifen, bzw. sie löschen will, kommt die Meldung (in Windows) es sei ein Schreibgeschützt ....

wie kann ich die rechte wieder auf die alten setzen???


Vielen Dank
Nukem36
Hacker
Hacker
Beiträge: 337
Registriert: 28. Okt 2004, 08:58
Wohnort: Im schwarzen Walde

Beitrag von Nukem36 »

High!

wie waren denn die Rechte vorher? Hast Du die
chmod 0770
chgrp users


abgesetzt? Nur auf die Verzeichnisse? Das hätte dann zur Folge, daß nur der Verzeichniseintrag, aber nicht die darin enthaltenen Dateien angepackt werden. Um das ab einem Verzeichnis für alle enthaltenen Objekte durchzuführen, muß für beide Befehle die Option rekursiv (-R : bitte in der Manpage nachlesen) angegeben werden.

Tip: bei solchen Aktionen die man-pages zu den Kommandos lesen. Es gibt Möglichkeiten die Rechte "mitzunehmen". Ansonsten werden neue Rechte angelegt, denn z.B. ein cp erzeugt ja neue Objekte auf der 2. Platte. Tust Du das als root, wird dieser Inhaber!

Bis denn
Nukem36[/quote]
Sie brauchen einen neuen Monitor? Dann bitte hier (X) bohren!
maga
Newbie
Newbie
Beiträge: 10
Registriert: 22. Jun 2004, 19:36
Kontaktdaten:

Beitrag von maga »

soo.... habs jetzt geschafft!!

hab einfach statt

chgrp users /local/...

das hier eingegeben:

chgrp users -R /local/...

so funktionierts eigentlich bis her....

Vielen Dank noch mal!!!!!!!!!!!! :D
Antworten