Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Nach Einbau zweiter Netzwerkkarte kein DHCP auf der Ersten

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
Luc
Newbie
Newbie
Beiträge: 1
Registriert: 22. Feb 2005, 11:51

Nach Einbau zweiter Netzwerkkarte kein DHCP auf der Ersten

Beitrag von Luc »

Hallo,

unter SuSe 9.2 Prof auf einem PIII600 Notebook habe ich folgendes Problem.

Nachdem ich zusätzlich zur fest eingebauten Intel Netzwerkkarte eine 3com PCMCIA Karte benutzt habe, startet die erste Netzwerkkarte nicht mehr automatisch per DHCP.

1. boot.msg


cardmgr[2939]: socket 0: 3Com 589 Ethernet

<notice>exit status of (random pcmcia isdn) is (0 0 0)
<notice>start services (network)
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8
done eth0 device: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
eth0 configuration: eth-id-00:e0:00:17:3a:f8
eth0 (DHCP) . <notice>pidofproc: dhcpcd 3111
IP/Netmask: 149.208.38.132 / 255.255.252.0
done eth1 device: 3Com 589 Ethernet
eth1 No configuration found for eth1
unusedSetting up service network . . . . . . . . . . . . . . . .done
<notice>exit status of (network) is (0)
<notice>start services (syslog)

2. ifconfig

eth0 Link encap:Ethernet HWaddr 00:E0:00:17:3A:F8
inet6 addr: fe80::2e0:ff:fe17:3af8/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:767 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:87023 (84.9 Kb) TX bytes:1239 (1.2 Kb)

lo Link encap:Local Loopback
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

3. rcnetwork restart

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
Shutting down network interfaces:
eth0 device: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
eth0 configuration: eth-id-00:e0:00:17:3a:f8
[1A..done eth1 device: 3Com 589 Ethernet
eth1 No configuration found for eth1
Nevertheless the interface will be shut down.
eth1 configuration:
[1A..doneShutting down service network . . . . . . . . . . . . . . ...done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8
[1A..done eth0 device: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
eth0 configuration: eth-id-00:e0:00:17:3a:f8
eth0 (DHCP) . IP/Netmask: 149.208.38.132 / 255.255.252.0
[1A..done eth1 device: 3Com 589 Ethernet
eth1 No configuration found for eth1
Setting up service network . . . . . . . . . . . . . . . ...done

Erst nach 3. funktioniert das Netzwerk wieder.

4. ifconfig

eth0 Link encap:Ethernet HWaddr 00:E0:00:17:3A:F8
inet addr:149.208.38.132 Bcast:149.208.39.255 Mask:255.255.252.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5401 errors:0 dropped:0 overruns:0 frame:0
TX packets:294 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:756555 (738.8 Kb) TX bytes:69236 (67.6 Kb)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

4. ethereal
Habe mal ein DHCP Discover Transaction Paket abgefangen.
Es sieht so aus, als ob er sich die letzte IP, die er in einem anderem Netz erhalten hat versucht wieder zu erhalten (Requested IP Adress). Das kann auch nicht funktionieren.

Habe schon gelesen, das man im ifcfg-eth-id-* DHCLIENT_PRIMARY_DEVICE='yes'
eintragen soll. Aber das hatte vorher auch nichts bewirkt.

Was kann ich tun, damit die eth0 sich wieder beim Systemstart eine neue DHCP-Adresse holt?

Grüße
Luc :?
Antworten