Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Zonendatei falsch konfiguriert?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
mycros
Newbie
Newbie
Beiträge: 28
Registriert: 31. Jan 2005, 12:14
Wohnort: Düsseldorf
Kontaktdaten:

Zonendatei falsch konfiguriert?

Beitrag von mycros »

Hi leutz,

hab mal wieder ein Problem. Ich habe einen Server auf dem DNS und DHCP gemeinsam läuft. DHCP läuft ohne Probleme *freu*, aber DNS macht mir einige Probleme. irgendwie lassen sich meine Zonendateien nicht ansprechen. Vielleicht wisst ihr ja Rat.

Auszug aus named.conf:

zone "localhost" {
type master;
file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
type master;
file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
type master;
file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
type master;
file "/etc/bind/db.255";
};

zone "mycros.local" {
type master;
file "/etc/bind/mycros.vorwaerts";
allow-update {none};
allow-query {any};
};

zone "213.168.192.in-addr.arpa" {
type master;
file "/etc/bind/mycros.rueckwaerts";
allow-update {none};
allow-query {any};
};

mycros.vorwaerts:

$TTL 86400
@ IN SOA root.mycros.local. (

2005012801
604800
900
604800
86400

)

IN NS root.mycros.local.

root IN A 192.168.213.1
www IN A 192.168.213.2

test IN CNAME root
server IN CNAME root


mycros.rueckwaerts:

$TTL 1D

@ IN SOA root.mycros.local. (

2005012801
604800
900
604800
86400

)

IN NS root.mycros.local.

1 IN PTR root.mycros.local.
Distribution Suse 10
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

Ufff, ganz schön viel verwurstelt.

Schau dir mal hier im Forum andere Beispiele an, da ist ne Menge da.

Gabs bei Debian keine Standard-conf? Zumindest localhost, 127 und die root-Server sollten nicht geändert werden, nur deine Vorwärts- und rückwärts-datei
In den Zonendaten stimmt auch was nciht, z.B. fehlt der Eintrag der root-Mailaddi.
Und wenn da update none steht wird das ganze auch nie bei ner neuen Vergabe einer Adresse geupdatet (war ja so gewünscht)

Also bitte erstmal hier durchschaun und im Detail helfen wir dann.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

Ach ja, .local ist auch keine gute Wahl, da nicht im Standard dafür vorgesehen.
Schau mal hier zu dem Thema: http://www.linux-club.de/viewtopic.php?t=6067&start=25
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Benutzeravatar
mycros
Newbie
Newbie
Beiträge: 28
Registriert: 31. Jan 2005, 12:14
Wohnort: Düsseldorf
Kontaktdaten:

Beitrag von mycros »

also die grundversorgung ist vorhanden, also die conf-dateien 127, local, root. die hab ich auch nicht verändert. was meinst du mit mailaddy? hab local in lokal ausgetauscht. Update ist jetzt auch zulässig. funktioniert aber weiterhin nicht.
Distribution Suse 10
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

Wenn der named die zonendateien nicht findet bzw. was falsch ist edann steht das in der logdatei. Poste die mal. wenn du einen named neustart gemacht hast

By Huflatisch
Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach »

mycros hat geschrieben:was meinst du mit mailaddy?
e-mail Adresse
Nicht Böse sein ! Der Onkel macht doch nur Spaß !
Benutzeravatar
mycros
Newbie
Newbie
Beiträge: 28
Registriert: 31. Jan 2005, 12:14
Wohnort: Düsseldorf
Kontaktdaten:

Beitrag von mycros »

Also die Log-Datei hat folgendes ausgegeben (nach einem Neustart)

localhost named[3085]: starting BIND 9.2.4 -u bind
localhost named[3085]: using 1 CPU
localhost named[3085]: loading configuration from '/etc/bind/named.conf'
localhost lwresd[3095]: starting BIND 9.2.4
localhost lwresd[3095]: using 1 CPU
localhost lwresd[3095]: loading configuration from '/etc/bind/lwresd.conf'
localhost lwresd[3095]: none:0: open: /etc/bind/lwresd.conf: file not found
localhost lwresd[3095]: loading configuration from '/etc/resolv.conf'
localhost kernel: NET: Registered protocol family 10
localhost kernel: Disabled Privacy Extensions on device c02c9840(lo)
localhost kernel: IPv6 over IPv4 tunneling driver
localhost named[3085]: listening on IPv4 interface lo, 127.0.0.1#53
localhost named[3085]: listening on IPv4 interface eth0, 192.168.248.130#53
localhost named[3085]: listening on IPv4 interface eth1, 192.168.213.1#53
localhost lwresd[3095]: none:0: open: /etc/bind/rndc.key: permission denied
localhost lwresd[3095]: couldn't add command channel permission denied
localhost lwresd[3095]: none:0: open: /etc/bind/rndc.key: permission denied
localhost lwresd[3095]: couldn't add command channel ::1#953: permission denied
localhost lwresd[3095]: lwres listening on 127.0.0.1#921
localhost lwresd[3095]: running
localhost named[3085]: command channel listening on 127.0.0.1#953
localhost named[3085]: command channel listening on ::1#953
localhost named[3085]: zone 0.in-addr.arpa/IN: loaded serial 1
localhost named[3085]: zone 127.in-addr.arpa/IN: loaded serial 1
localhost named[3085]: dns_rdata_fromtext: /etc/bind/mycros.rueckwaerts:9: near eol: unexpected end of input
localhost named[3085]: zone 213.168.192.in-addr.arpa/IN: loading master file /etc/bind/mycros.rueckwaerts: unexpected end of input
localhost named[3085]: zone 255.in-addr.arpa/IN: loaded serial 1
localhost named[3085]: zone localhost/IN: loaded serial 1
localhost named[3085]: dns_rdata_fromtext: /etc/bind/mycros.vorwaerts:8: near eol: unexpected end of input
localhost named[3085]: zone mycros.lokal/IN: loading master file /etc/bind/mycros.vorwaerts: unexpected end of input
localhost named[3085]: running
Distribution Suse 10
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

Code: Alles auswählen

localhost named[3085]: dns_rdata_fromtext: /etc/bind/mycros.rueckwaerts:9: near eol: unexpected end of input 
localhost named[3085]: zone 213.168.192.in-addr.arpa/IN: loading master file /etc/bind/mycros.rueckwaerts: unexpected end of input 
localhost named[3085]: zone 255.in-addr.arpa/IN: loaded serial 1 
localhost named[3085]: zone localhost/IN: loaded serial 1 
localhost named[3085]: dns_rdata_fromtext: /etc/bind/mycros.vorwaerts:8: near eol: unexpected end of input 
localhost named[3085]: zone mycros.lokal/IN: loading master file /etc/bind/mycros.vorwaerts: unexpected end of input 
Hier hastes doch. Die Syntax scheint nicht ganz hinzuhauen.

By huflatisch
stka
Moderator
Moderator
Beiträge: 3313
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Beitrag von stka »

Versuch mal wenn du in beiden SOA Einträgen den Host hinzufügst.

@ IN SOA mycros.local. root.mycros.local. (

Wie schon vorher erwähnt, "local" solltest du NICHT verwenden. Ändere das doch einfach in "lokal" das sollte gehen
Benutzeravatar
mycros
Newbie
Newbie
Beiträge: 28
Registriert: 31. Jan 2005, 12:14
Wohnort: Düsseldorf
Kontaktdaten:

Beitrag von mycros »

Hallo

ich hab jetzt mal die Zonendateien so geändert wie ihr es vorgeschlagen habt. Ich poste Sie jetzt noch mal. Wenn ich die Dateien aber überprüfen lasse, dann er folgt bei beiden immer die selbe Fehlermeldung.

mycros.vorwaerts:

$TTL 86400
@ IN SOA mycros.lokal. root.mycros.lokal. (

2005012801
604800
900
604800
86400

)

IN NS root.mycros.lokal.

root IN A 192.168.213.1
www IN A 192.168.213.2

test IN CNAME root
server IN CNAME root

Fehlermeldung >>>
mycros.vorwaerts:1: unknown option '$TTL'
mycros.vorwaerts:19: unexpected token near end of file

----------------------------------------------
mycros.rueckwaerts:

$TTL 1D

@ IN SOA mycros.lokal. root.mycros.lokal. (

2005012801
604800
900
604800
86400

)

IN NS root.mycros.lokal.

1 IN PTR root.mycros.lokal.


Fehlermeldung >>>
mycros.vorwaerts:1: unknown option '$TTL'
mycros.vorwaerts:16: unexpected token near end of file[/b]
Distribution Suse 10
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

Poste mal die Datein als Code

By huflatisch

dein vorwärts sollte so aussehen (zum testen)

Code: Alles auswählen

$TTL 1W
@               IN SOA     @ mycros.lokal (
                                42              ; serial (d. adams)
                                2D              ; refresh
                                4H              ; retry
                                6W              ; expiry
                                1W )            ; minimum

                IN NS           mycros.lokal

root                IN A             192.168.213.1
www               IN A             192.168.213.2
jetzt wird
root.mycros.lokal auf 192.168.213.1 geschickt und
www.mycros.lokal auf 192.168.213.2
die zone in der named.conf muss "mycros.lokal" heisen
bearbeiten tust du aber die Datein nicht in Windows und dann hochladen, oder ???

By Huflatisch

PS: mit "named-checkzone" kannst du die Datei prüfen lassen
Benutzeravatar
mycros
Newbie
Newbie
Beiträge: 28
Registriert: 31. Jan 2005, 12:14
Wohnort: Düsseldorf
Kontaktdaten:

Beitrag von mycros »

hab jetzt die datei geändert. aber die fehlermeldung bleiben immer noch die gleichen.

irgendwas stimmt mit dem dateianfang und mit dem ende der datei nicht. fehlermeldung siehe oben
Distribution Suse 10
Huflatisch
Hacker
Hacker
Beiträge: 543
Registriert: 5. Apr 2004, 22:40

Beitrag von Huflatisch »

Hey

Habe gerade meine gepostete Datei per copy/paste über ssh in den vi eingefügt und named-checkzone drüberlaufen lassen.

Code: Alles auswählen

linux:~ # named-checkzone mycros.lokal ./zone
zone mycros.lokal/IN: loaded serial 42
OK
Die Datei ist in Ordnung. Ich bin immer noch der Meinung du hast einen Syntaxfehler drin. Vielleicht $ und § verwechselt. Kann ich mir die Datei direkt auf deinem Server angucken.

By Huflatisch

mit was editierst du die Datei ???
Kann aber auch sein das dein Bind ne Macke hat.

Was mir gerade noch einfällt. Erhöhst du immer die Seriennummer, damit bind auch die Änderungen check. Vielleicht liegs daran.
oder wenn du ein älteres oder neueres bind hast will der vielleicht hinter $TTL die Zeit in Sekunden also das 1W weg und dafür mal 86400 reinschreiben
Antworten