Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Plötzlicher Schreibschutz

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
uffnik
Newbie
Newbie
Beiträge: 10
Registriert: 25. Dez 2004, 15:01

Plötzlicher Schreibschutz

Beitrag von uffnik »

Hallo forum,

plötzlich bekomme ich beim Zugriff auf meine Dateien die Fehlermeldung daß die Datei schreibgeschützt sei. Will ich unter einem anderen Namen abspeichern kommt die Meldung, daß es sich beim Namen um einen unzulässigen Dateinamen handle.

Server und Zugriff waren bisher problemlos

Verwende Samba 3.0 und Suse 9.2, hier das config.file

Code: Alles auswählen

# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2005/02/22 06:10:07

# Global parameters
[global]
        workgroup = TUX-NET
        server string = SambaServer
        map to guest = Bad User
        username map = /etc/samba/smbusers
        printcap cache time = 750
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        logon path = \\home\%U\.msprofile
        logon drive = P:
        domain logons = Yes
        os level = 65
        preferred master = Yes
        domain master = Yes
        ldap idmap suffix = ou=Idmap
        ldap machine suffix = ou=Computers
        ldap suffix = dc=example,dc=com
        ldap ssl = no
        printer admin = @ntadmin, root, administrator
        cups options = raw
        include = /etc/samba/dhcp.conf

[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        inherit acls = Yes
        browseable = No



[daten]
        comment = GemeinsameDaten
        path = /home/ResearchdatenLinux/
        valid users = root, @xpuser, @xpclient

[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        create mask = 0600
        directory mask = 0700
        store dos attributes = Yes

[users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/

[groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes

[pdf]
        comment = PDF creator
        path = /var/tmp
        create mask = 0600
        printable = Yes

[printers]
        comment = All Printers
        path = /var/tmp
        create mask = 0600
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin, root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Damit läßt sich erst mal gar nichts anfangen. Das ist einfach nur eine gültige Konfiguration.

Stell mal in globals den "log level = 3", Dann kanst du in /var/log/samba/log.smb nachsehen warum er hier einen Schreibschutz vermutet.

Es kann auch am Dateisystem liegen. Daher bitte in der Log nachsehen.
BilboBeutlin
Newbie
Newbie
Beiträge: 22
Registriert: 13. Jul 2004, 08:40

Beitrag von BilboBeutlin »

Hallo,

hatte ähnliches Problem. Nach langem Probieren stellte sich heraus, dass eine Kombination von Read_only = No und write bzw. Read lists kontraproduktiv ist.

D.h. ich verzichte bei Verwenden von write/Readlist ganz auf den read only Parameter.

Seither keine Probleme.

Viel Erfolg

Bernd
Benutzeravatar
nobbiew
Hacker
Hacker
Beiträge: 497
Registriert: 1. Mär 2004, 23:26

Beitrag von nobbiew »

Das kann ich so nicht stehen lassen. Natürlich macht es keinen Sinn read only = no u. eine write list. Da der default read only = yes ist kann man den im dem Fall also weg lassen. Aber mir einer read list kannst du bei read only = no bestimmten benutzern das Schreiben verbieten.
Antworten