Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

NFS => "Zugriff verweigert auf /share"

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

NFS => "Zugriff verweigert auf /share"

Beitrag von christian_k »

hallo,

habe momentan ein kleines problem mit meinen nfs und hoffe, das ihr evtl. die lösung auf mein problem kennt.

Code: Alles auswählen

Problem:

ich folgendes system / netzwerk:
- Server (ip: 192.168.0.254) => Suse Linux 9.2
- client1 (ip: 192.168.0.1)     => Suse Linux 9.2
- client2 (ip: 192.168.0.2)     => Suse Linux 9.1 (64-Bit)
der server soll den clients speicherplatz zur verfügung stellen. die clienten sollen sowohl schreibrechte als auch leserechte besitzen.

ich habe das ganze mit yast eingerichtet:

bei dem server habe ich das verzeichnis angegeben, welches als nfs dienen soll. dann erscheint ein fenster, wo folgendes eingetragen werden soll:
einmal die "wildcard" und einmal die "options"
ich habe folgendes eingetragen:

Code: Alles auswählen

"wildcard" => hier soll jeder rechner drauf zugreifen dürfen, also habe ich "*" eingetragen.

"option" => standard ist "ro,root_squash,sync". dort habe ich folgendes eingetragen "rw,root_squash,sync".
die clients habe ich auch mit yast eingerichtet, habe einfach bei den "hostnamen" die ip des servers eingetragen, und habe dann das entfernte dateisystem gewählt und anschließend den lokalen mountpoint bestimmt.


wenn ich jetzt allerding von einem client einen ordner in dem nfs verzeichnis des servers erstellen möchte, kommt folgende meldung
"Zugriff verweigert auf /share"

kann mir einer sagen, was ich falsch gemacht habe oder wo der fehler liegt?


mfg
Tux^
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

poste doch mal die /etc/exports und den Eintrag in deiner fstab auf den Clients
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k »

okay auf wunsch hier folgende einträge:

/etc/exports:

Code: Alles auswählen

/home/shared/ *(rw,root_squash,sync)
/usr/nfs/          *(rw,root_squash,sync)
fstab client1:

Code: Alles auswählen

 
/dev/hda9	/	reiserfs	acl,user_xattr 1 1
/dev/hda1	/windows/C	ntfs	ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5	/windows/D	ntfs	ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda6	/windows/E	ntfs	ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8	swap	swap	pri=42 0 0
devpts	/dev/pts	devpts	mode=0620,gid=5 0 0
proc	/proc	proc	defaults 0 0
sysfs	/sys	sysfs	noauto 0 0
/dev/cdrecorder	/media/cdrecorder	subfs	fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/cdrecorder11	/media/cdrecorder11	subfs	fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0	/media/floppy	subfs	fs=floppyfss,procuid,nodev,nosuid,sync 0 0
192.168.0.254:/usr/nfs	/nfs	nfs	defaults 0 0
192.168.0.254:/home/shared	/share	nfs	defaults 0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
fstab client2:

Code: Alles auswählen

/dev/hda2	/	reiserfs	acl,user_xattr 1 1
/dev/hda1	swap	swap	pri=42 0 0
devpts	/dev/pts	devpts	mode=0620,gid=5 0 0
proc	/proc	proc	defaults 0 0
usbfs	/proc/bus/usb	usbfs	noauto 0 0
sysfs	/sys	sysfs	noauto 0 0
/dev/cdrecorder	/media/cdrecorder	subfs	fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdrecorder	/media/dvdrecorder	subfs	fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0	/media/floppy	subfs	fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/hda3	/windows/C	ntfs	ro,users,gid=users,umask=0002,nls=utf8 0 0
192.168.0.254:/usr/nfs	/nfs	nfs	rw 0 0
192.168.0.254:/home/shared	/share	nfs	rw 0 0
hoffe, das du damit was anfangen kannst...

mfg
Tux^
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Das sieht soweit gut aus.
Wie sehen die Rechte auf den Mount-Punkten aus ?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k »

was meinst du mit

Rechten auf den Mount-Punkten ?

bei den Clients habe ich das Verzeichnis vom Server eingebunden und als "Options" "Default" genommen.

mfg
Tux^
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Ich meine die Rechte der Verzeichnisse, in die das Share gemountet wird.

Code: Alles auswählen

ls -l /share
als Beispiel.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k »

also wenn ich beim server den befehl "ls -l / eingebe erscheint folgendes:

ls -l /usr/nfs

Code: Alles auswählen

Server:/ # ls-l /usr/nfs
total 0
drwxr-xr-x    2 root root   48 Feb 21 22:28 .
drwxr-xr-x  15 root root 400 Feb 21 22:28 ..
ls -l /home/shared/frei

Code: Alles auswählen

drwxr-xr-x  2 root     root    48  Feb 23 15:41 .
drwxr-xr-x  8 shared users  592 Feb 23 16:41 ..
hoffe, das es das ist, was du wolltest

mfg
Tux^
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Sorry ... das war mein Fehler.
Entscheidend sind die Rechte eine Ebene höher.
Den Mount-Punkten /usr/nfs und /home/shared/frei solltest du mal alle Rechte geben (mit chmod 777 - schau dir dazu "man chmod" an)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
christian_k
Member
Member
Beiträge: 57
Registriert: 29. Sep 2004, 14:41
Wohnort: Obertshausen
Kontaktdaten:

Beitrag von christian_k »

jetzt funktioniert alles! ich danke dir für deine hilfe und geduld!
ich weiß jetzt zwar nicht, warum die rechte falsch waren, aber okay

mfg
Tux^
admine
Administrator
Administrator
Beiträge: 8865
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine »

Schau dir dazu mal die Rechte-Verwaltung von Linux an.
Gute Online-Site dazu ist:
www.linuxfibel.de
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Antworten