Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix: Kein Versandt von anderem Rechner im lokalen Netz

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
fwhamm
Newbie
Newbie
Beiträge: 4
Registriert: 19. Feb 2005, 11:55
Kontaktdaten:

Postfix: Kein Versandt von anderem Rechner im lokalen Netz

Beitrag von fwhamm »

Ich habe hier ein kleines Netz mit WLAN-Router
- SUSE 9.2 Server aufgebaut (192.168.2.111)
- Windows XP (192.168.2.101)

Linux/Unix-mäßig bin ich (Wieder-)Einsteiger, zuletzt hatte ich vor 15 Jahren damit zu tun :-)

Auf dem SUSE habe ich Fetchmail und Postfix installiert (zunächst alles direkt und ohne Cyrus etc.). Von dem SUSE aus kann ich mit KMail eine Mail über den Router in Internet versenden (localhost:25, kein SSL etc.). /var/log/mail.info:

Code: Alles auswählen

Feb 19 11:06:20 tso1 postfix/smtpd[6227]: connect from localhost[127.0.0.1]
Feb 19 11:06:20 tso1 postfix/smtpd[6227]: 84E7715A8C: client=localhost[127.0.0.1]
Feb 19 11:06:20 tso1 postfix/cleanup[6230]: 84E7715A8C: message-id=<200502191106.20235.vorname.name@server.net>
Feb 19 11:06:20 tso1 postfix/qmgr[5645]: 84E7715A8C: from=<vorname.name@server.net>, size=55
5, nrcpt=1 (queue active)
Feb 19 11:06:20 tso1 postfix/smtpd[6227]: disconnect from localhost[127.0.0.1]
Feb 19 11:06:21 tso1 postfix/smtp[6231]: 84E7715A8C: to=<vorname.name@zielserver.net>, relay=smtp.server.net[217.195.36.98], delay=1, status=sent (250 Ok: queued as B1A8F86C06A)
Wenn ich aber vom XP Rechner aus (mit Firefox) versuche eine Mail zu versenden, dann sagt mir mein AVG Virenscanner auf der XP-Box irgendwann

Code: Alles auswählen

-------------------------------------------------------------------
Cannot open smtp connection to '192.168.2.111'
Connect: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte. (10061)
-------------------------------------------------------------------
Bei dem erfolglosen Versuch stehen keine Einträge in der /var/log/mail.info.
In der /var/log/messags stehen folgende Einträge:

Code: Alles auswählen

Feb 19 12:03:04 tso1 kernel: SFW2-INext-ACC-TCP IN=ath0 OUT= MAC=00:11:6b:b0:1f:d0:00:0b:6a:99:f5:2c:08:00 SRC=192.168.2.101 DST=192.168.2.111 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=10415 DF PROTO=TCP SPT=1587 DPT=25 WINDOW=65535 RES=0x00 SYN URGP=0 OPT (020405B401010402)
Feb 19 12:03:04 tso1 kernel: SFW2-INext-ACC-TCP IN=ath0 OUT= MAC=00:11:6b:b0:1f:d0:00:0b:6a:99:f5:2c:08:00 SRC=192.168.2.101 DST=192.168.2.111 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=10439 DF PROTO=TCP SPT=1587 DPT=25 WINDOW=65535 RES=0x00 SYN URGP=0 OPT (020405B401010402)
Feb 19 12:03:05 tso1 kernel: SFW2-INext-ACC-TCP IN=ath0 OUT= MAC=00:11:6b:b0:1f:d0:00:0b:6a:99:f5:2c:08:00 SRC=192.168.2.101 DST=192.168.2.111 LEN=48 TOS=0x00 PREC=0x00 TTL=128 ID=10458 DF PROTO=TCP SPT=1587 DPT=25 WINDOW=65535 RES=0x00 SYN URGP=0 OPT (020405B401010402)
Bisher habe ich alles mit YAST2 konfiguriert, dabei will ich zunächst auch bleiben bis die Kiste mailmäßig generell läuft. Anschließend gehe ich mit Sicherheit auch in die /etc files.
master.cf

Code: Alles auswählen

# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       n       -       -       smtpd
#smtps    inet  n       -       n       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission   inet    n       -       n       -       -       smtpd
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes -o smtpd_etrn_restrictions=reject
#628      inet  n       -       n       -       -       qmqpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
#tlsmgr   fifo  -       -       n       300     1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
relay     unix  -       -       n       -       -       smtp
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
#localhost:10025 inet   n       -       n       -       -       smtpd -o content_filter=
#
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# maildrop. See the Postfix MAILDROP_README file for details.
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus     unix  -       n       n       -       -       pipe
  user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
main.cf

Code: Alles auswählen

biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = tso1.muf-hamm.tso
program_directory = /usr/lib/postfix
inet_interfaces = 127.0.0.1 ::1
masquerade_domains = muf-hamm.net
mydestination = $myhostname,localhost.$mydomain,$mydomain,localhost
defer_transports =
disable_dns_lookups = no
relayhost = smtp.muf-hamm.net
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
smtp_sasl_auth_enable = yes
smtpd_sasl_auth_enable = no
smtpd_use_tls = no
smtp_use_tls = no
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
smtp_sasl_security_options =
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
Jetzt, wo ich darüber schreibe, kommt mir ein Verdacht: Die Meldungen in der /var/log/messages sehen irgendwie nach SFW2 (SuseFireWall2) aus??? Ich habe zwar in Yast die Firewall für SMTP freigeschaltet, aber könnte dort das Problem liegen?
Zuletzt geändert von fwhamm am 19. Feb 2005, 12:34, insgesamt 2-mal geändert.
Live long and prosper!
fwhamm
Newbie
Newbie
Beiträge: 4
Registriert: 19. Feb 2005, 11:55
Kontaktdaten:

Beitrag von fwhamm »

Kurzes Update: Die Firewall ist es nicht, habe sie komplett ausgeschaltet. Ich habe zwar die Einträge in der /var/log/messages nicht mehr, aber die Verbindung wird dennoch verweigert...
Live long and prosper!
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Probier mal die folgende Einstellung:
inet_interfaces = all

Mfg. Mercedesdriver :)
fwhamm
Newbie
Newbie
Beiträge: 4
Registriert: 19. Feb 2005, 11:55
Kontaktdaten:

Beitrag von fwhamm »

mercedesdriver hat geschrieben:Probier mal die folgende Einstellung:
inet_interfaces = all
BINGO!

Vielen Dank, das war's!

Mit Direktzustellung klappt's jetzt schon mal, jetzt werde ich mich bei Gelegenheit an Cyrus ranmachen. Und ab jetzt läuft die Config eben auch direkt über die /etc files - wäre eh bald fällig gewesen...

Grüße

Frank (fwhamm)
Live long and prosper!
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Tja wo man helfen kann ... ;).
Wenn du sonst noch Probleme haben solltest (z.B. mit Cyrus) schreib sie uns einfach.

Mfg. Mercedesdriver :)
fwhamm
Newbie
Newbie
Beiträge: 4
Registriert: 19. Feb 2005, 11:55
Kontaktdaten:

Beitrag von fwhamm »

mercedesdriver hat geschrieben:Tja wo man helfen kann ... ;).
Wenn du sonst noch Probleme haben solltest (z.B. mit Cyrus) schreib sie uns einfach.
Ich fange gerade an und erschaffe mir die Probleme damit Ihr mir damit helfen könnt :)

Bin jetzt soweit und habe einen Basis-"Mailserver" lauffähig mit:
  • Postfix
  • Cyrus
  • Fetchmail
Jetzt geht es nach und nach ans Ausbauen. Vielen Dank nochmals, ich werde auf dein Angebot sicher noch zurückkommen (müssen)...

Kurze Frage OT: Brauche ich in der Kombination eigentlich procmail? Mir ist noch nicht so ganz klar wofür das da ist.

Grüße, Frank
Live long and prosper!
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Procmail wird für die lokale E-Mailzustellung verwendet.
Procmail wird z.B. von Sendmail gebraucht. Postfix mit Cyrus braucht Procmail nicht aber man kann damit z.B. Spam rausfiltern oder automatische Antworten verfassen lassen. (Obwohl ich dafür andere Programme verwenden würde ...)

Mfg. Mercedesdriver :)
Gesperrt