Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Synaptics-Touchpad unter SuSE 9.2 funzt nicht

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
LudwigVan
Member
Member
Beiträge: 110
Registriert: 28. Feb 2004, 08:42

Synaptics-Touchpad unter SuSE 9.2 funzt nicht

Beitrag von LudwigVan »

Schön, wenn das Installieren doch noch geklappt hat, aber das
eigendlich Aufwendige ist ja das Einrichten. Da ich mir hier bei
einigen Dingen schwertu folgende Frage:

Ich habe ein Synaptics-Touchpad, das sog. 'life-scrolling'
unterstützt, also das scrollen mit einer bestimmten Fläche im pad -
sollte inzwischen Standard sein. Nun, egal was ich in Sax2 einstelle,
ich kriegs nicht hin. Synapics Touchpad ist asugewählt.

Die Einstellung aus SuSE 9.1 weiß ich leider
nicht mehr ... aktives tippen funktioniert. Vielleicht muß ich auch
nur in Yast ein anderes Mausmodell wählen?

Folgendes zur Info aus X*conf:
Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "Name" "SynPS/2 Synaptics TouchPad"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection
NB: hp xe4500
SuSE 9.2 (CD-Installation)

Für jede Hilfe dankbar ...

L.
Oli-nux
Hacker
Hacker
Beiträge: 500
Registriert: 28. Mai 2004, 17:05

Beitrag von Oli-nux »

Evtl. hilft es dir.... Zitat:
Dann ist auch der Synaptics Treiber fürs Touchpad nicht eingerichtet (obwohl bei SuSE 9.1 dabei). Ja, es geht auch so, aber einige nette Features sind dann eben nicht verfügbar. SuSE hat in der SDB hierzu einen Artikel, klappt dann auch wunderbar, aber dieses Touchklick (festerer Druck aufs Pad wird als Klick interpretiert) ist etwas was mich in den Wahnsinn treibt. Im Zug ruckelt es mal, schon hat man was angeklickt oder markiert, oder ... entsprechend der FAQ, Punkt How can I configure tap-to-click behavior? hab ich es via MaxTapMove deaktiviert, der Eintrag für den Klick ist auf Kommentar für alle die, die es aktivieren wollen.

Ist zwar jetzt Suse 9.1 sollte aber bei 9.2 genauso gehen!;)

Das Ganze habe ich mit etwas Zeitaufwand über Googel gefunden.
Das zeigt mir mal wieder, dass ihr keine Suchmaschine verwendet! :?
http://mainschleifen-angler.de.vu Textilen- & Geschenke-Shop
Benutzeravatar
LudwigVan
Member
Member
Beiträge: 110
Registriert: 28. Feb 2004, 08:42

google?

Beitrag von LudwigVan »

Das Ganze habe ich mit etwas Zeitaufwand über Googel gefunden.
Das zeigt mir mal wieder, dass ihr keine Suchmaschine verwendet!

... das finde ich leicht unfair. Wer sagt das denn?

Wie auch immer. Wie ich schon sagte, habe ich in Sax2 alle Einstellungen probiert und den Treiber, wie in der Anleitung (ich vergas wohl zu schreiben, dass diese mir wohl bekannt war), ausgewählt - nur der Effekt will sich nicht einstellen.

Somit hilft mir das nicht viel weiter ...

L.
NavyNeidi
Newbie
Newbie
Beiträge: 1
Registriert: 18. Feb 2005, 13:59
Kontaktdaten:

Beitrag von NavyNeidi »

... das finde ich leicht unfair. Wer sagt das denn?

Wie auch immer. Wie ich schon sagte, habe ich in Sax2 alle Einstellungen probiert und den Treiber, wie in der Anleitung (ich vergas wohl zu schreiben, dass diese mir wohl bekannt war), ausgewählt - nur der Effekt will sich nicht einstellen.
Ich hab auf meinem NB auch so ein Touchpad. Und nach der Anleitung (die du ja gelesen hast) habe ich meine XF86Config folgendermassen angepaßt:

Code: Alles auswählen

Section "InputDevice"
  Driver       "synaptics"
  Identifier   "Mouse[1]"
  Option       "AccelFactor" "0.0010"
  Option       "BottomEdge" "4000"
  Option       "Device" "/dev/psaux"
  Option       "Edges" "1900 5400 1800 3900"
  Option       "Emulate3Buttons" "on"
  Option       "Finger" "25 30"
  Option       "FingerHigh" "30"
  Option       "FingerLow" "25"
  Option       "InputFashion" "Mouse"
  Option       "LeftEdge" "1900"
  Option       "MaxSpeed" "0.18"
  Option       "MaxTapMove" "220"
  Option       "MaxTapTime" "180"
  Option       "MinSpeed" "0.02"
  Option       "Name" "Synaptics;Touchpad"
  Option       "RightEdge" "5400"
  Option       "SHMConfig" "on"
  Option       "TopEdge" "1900"
  Option       "VertScrollDelta" "100"
  Option       "ZAxisMapping" "4 5"
  Option       "CorePointer"
EndSection
Siehe da, es funktioniert (was es vorher halt nicht gemacht hat). Übrigens: Dieser Abschnitt ist exact der aus der Anleitung. Dein Abschnitt sieht irgendwie kürzer aus?

Jetzt werd ich mir nur noch dieses bescheuerte Klicken auf dem Touchpad abschalten....

Schönen Gruß
NavyNeidi

P.S. Verzeih mir die Ironie in meinem Beitrag. Ich war gerade gut in Laune. Nimm halt diesen Abschnitt, dann gehts. Und wenn du das Tappen auf dem Touchpad nicht haben willst, setz die "MaxTapTime" auf 0. Das Scrollen funktioniert weiterhin.
Antworten