Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

configure von gtk+ 2.6.2 meldet pango backend required

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

configure von gtk+ 2.6.2 meldet pango backend required

Beitrag von menuisier »

.. obwohl ich es eben installiert habe. Ich habe version 1.8.0, gerade configured, gemaked und gemake installed, dann neu gebootet. pango liegt unter /usr/share/pango-1.8.0 doch wenn ich das gtk+ 2.6.2 configure-script starte, gibt'S die meldung

configure: error: Xft Pango backend is required for x11 target

Dann bricht das script ab, denn pango ist für gtk+ wohl erforderlich, und make und make install führen selbstverständlich inst nichts.

was tun? ist der Pfad für pango nicht in ordnung (sollte doch das install script selbst erledigen, oder?) Muss ich noch eine Pfadvariable setzen?
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

ergänzende Infos zur Umgebung

Beitrag von menuisier »

sorry, vergessen habe ich:
System ist Suse 9.0, Arbeitsplatzinstallation.
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2595
Registriert: 12. Feb 2005, 22:45

Beitrag von panamajo »

Das Paket pango-devel ist installiert?
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

NEin

Beitrag von menuisier »

soll ich? Auf der gtk+-Seite steht dazu nämlich nichts.
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2595
Registriert: 12. Feb 2005, 22:45

Re: NEin

Beitrag von panamajo »

menuisier hat geschrieben:soll ich? Auf der gtk+-Seite steht dazu nämlich nichts.
(Komisch, der 2. Satz wird bei mir gar nicht angezeigt? EDIT: jetzt doch ... WTF)
Ja, wenn du irgendwas mit pango Unterstützung compilieren willst mußt du das devel Paket installiert haben.
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

Pango-devel installiert

Beitrag von menuisier »

Hi,

So, jetzt habe ich nach langer Suche das Paket installiert, leider habe ich offenbar einen Versionskonflikt verursacht- beim Start vom gtk-configure-script erscheint jetzt:

checking for pkg-config... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Requested 'pango >= 1.8.0' but version of Pango is 1.2.5

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

argh. Frickele jetzt seit heute mittag daran rum, und habe glaub ich für heute die schnauze voll ... Wäre trotzdem für eine Antwort dankbar ...
Gruesse nach D.
Benutzeravatar
panamajo
Guru
Guru
Beiträge: 2595
Registriert: 12. Feb 2005, 22:45

Re: Pango-devel installiert

Beitrag von panamajo »

menuisier hat geschrieben:checking for pkg-config... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Requested 'pango >= 1.8.0' but version of Pango is 1.2.5
Sry, ich hatte wohl übersehen daß du pango 1.8 selber compiliert hast. Dann bringt die pango-devel natürlich nichts außer Versionkonflikt, also wieder weg damit :(
Vmtl. mußt du danach nochmal ein "make install" im pango-srcdir aufrufen, damit wieder die korrekten Header installiert werden.
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

ok, und jetzt bin ich wieder da, wo ich vorher war ...

Beitrag von menuisier »

Hi,

so, pango-devel deinstalliert, make install in pango.1.8.0 gemacht, SuSEconfig aufgerufen (ist das nötig, es gibt ein SuSEconfig.pango-script, was soll das ? ), gtk configure aufgerufen. Meldung:

checking For sufficiently new FreeType (at least 2.0.1)... yes
configure: error: Xft Pango backend is required for x11 target

hm. den hatten wir schon, glaub' ich.
}-Tux-{
Hacker
Hacker
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Beitrag von }-Tux-{ »

Hi

nimm am besten die RPMs von dem ganzen gtk und pango zeugs. Dann hast du nachher weniger probs weil alles am richtigen "ort" liegt.

mfg }-Tux-{
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

Vielleicht sollte ich dazu etwas weiter ausholen:

Beitrag von menuisier »

Ziel ist, eine laufende Version vom aktuellen Xsane zu kreieren, mit der ich hoffentlich meinen Canon canoscan Lide 35 zum laufen bringe. Da xsane in der version rpm-Version für Suse 9.0 meinen Scanner nicht unterstuetzt, scheint dies in der aktuellen Version von xsane der Fall zu sein. Für 9.0 finde ich aber ein rpm des aktuellen xsane pakets nicht, sondern nur für 9.2 - argh.
Warum gtk+? weil ich das benötige, um das aktuelle xsane Paket zu installieren. gefunden habe ich bislang von gtk+ nur rpm's version 1.20. für Suse. Da ich nicht viel davon halte, alte Versionen einer Lib zu installieren, wo es neuere gibt, hatte ich gehofft, dass ich statt gtk+ 1.20... zu installieren, gtk+ 2.6.xxx kompilieren kann, bislang (was die Vorbereitungsarbeiten angeht) mit gutem Erfolg.

So der Stand der Dinge.Vielleicht kannst Du mir ja mitteilen, wo ich ein aktuelles rpm für SuSe finde (oder kann ich da auch ein redhat rpm nehmen?), oder rätst Du mir im Angesicht meines (Basis-) Problems eher dazu, einen ganz anderen Weg zu gehen, um zum Ziel zu kommen?

thx.
menuisier
Newbie
Newbie
Beiträge: 14
Registriert: 17. Feb 2005, 15:34

wie deinstalliere ich dann die Versionen

Beitrag von menuisier »

Sorry, hälfte vergessen: falls ich in grösserem Masse deinstallationen vornehmen muss, wie geht das von sich? Ich habe mich für keine der Installationen eines Paketverwalters bedient, weil die nicht so wollten, wie ich (fängt damit an, dass ich das Paket zum installieren nicht auswählen kann, bei allem, was man an Windows mäkelt, das war da immer einfach ...)
thx.
Antworten