Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit der Inst. von Webalizer

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
toady
Newbie
Newbie
Beiträge: 26
Registriert: 22. Dez 2004, 13:22
Wohnort: bei Hanau

Problem mit der Inst. von Webalizer

Beitrag von toady »

Moin zusammen,

ich schreib's jetzt einfach mal hier rein.

Ich hab bei der Installation vom aktuellen Webalizer (Source Distribution) folgendes Problem:
Nachdem ich den ./cofigure Befehl eingegeben hab, will er von mir "gd" installiert haben. Jetzt hab ich aber schon so ziemlich alles, was es im Yast gibt und mit gd in Verbindung zu bringen ist, nachinstalliert. Allerdings lässt sich der Webalizer davon ganz und gar nicht beeindrucken...

Dank euch!!
Gruß,
toady

ps:
SuSE 9.2, auf aktuellen Stand gepatcht
Webalizer 2.01-10
admine
Administrator
Administrator
Beiträge: 8941
Registriert: 15. Feb 2004, 21:13

Beitrag von admine »

Poste doch mal die vollständige Fehlermeldung.
Das bringt dir dann evt. eher Hilfe ;)
Grüße
-------------------------
..:: Deutsche Mugge ::..
-------------------------
Benutzeravatar
toady
Newbie
Newbie
Beiträge: 26
Registriert: 22. Dez 2004, 13:22
Wohnort: bei Hanau

Beitrag von toady »

so denn, hier ist die Ausgabe von ./config:

loading cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether ln -s works... yes
checking for a BSD compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking whether char is unsigned... no
checking for main in -l44bsd... no
checking for main in -lm... yes
checking for main in -lz... yes
checking for gzrewind in -lz... yes
checking for main in -lpng... yes
checking for gdImagePng in -lgd... no
checking for libgd.a... no
checking for libgd.so... (cached) no
configure: error: gd library not found... please install gd.

Ich hoff mal, dass damit jemand was anfangen kann...

Gruß,
toady
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

gd-devel installieren ....
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Benutzeravatar
toady
Newbie
Newbie
Beiträge: 26
Registriert: 22. Dez 2004, 13:22
Wohnort: bei Hanau

Beitrag von toady »

hab hier leider nur ein libgda-devel im Angebot und der ist bereits installiert.

Ansonsten find ich bei der Suche nach gd oder devel nichts dergleichen.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

na dann putz mal deine Brille :)

Code: Alles auswählen

apt policy gd-devel
gd-devel:
  Installed: 2.0.33-0.gbv.1
  Candidate: 2.0.33-0.gbv.1
  Version Table:
 *** 2.0.33-0.gbv.1 0
        500 http://ftp.gwdg.de SuSE/9.2-i386/suser-gbv pkglist
        100 RPM Database
     2.0.28-2.4 0
        500 http://ftp.gwdg.de SuSE/9.2-i386/base pkglist
     2.0.28-2.3 0
        500 http://ftp.gwdg.de SuSE/9.2-i386/update pkglist
     2.0.28-2.2 0
        500 http://ftp.gwdg.de SuSE/9.2-i386/update pkglist
d.h. sowohl in der Basisversion von SuSE (DVD/CDs) als auch in der update Sektion gibt es gd-devel ...
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Benutzeravatar
toady
Newbie
Newbie
Beiträge: 26
Registriert: 22. Dez 2004, 13:22
Wohnort: bei Hanau

Beitrag von toady »

naja, das Paket gd hab ich ja bereits installiert. Da wird der devel ja mit drin sein.

Beim Online-Upate finde ich den gd-devel auch. Aber im Bereich Software nachinstallieren gibt's gd nicht als devel.
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus »

toady hat geschrieben:naja, das Paket gd hab ich ja bereits installiert. Da wird der devel ja mit drin sein.

Beim Online-Upate finde ich den gd-devel auch. Aber im Bereich Software nachinstallieren gibt's gd nicht als devel.
nochmal für die Ungläubigen:
gd != gd-devel

das sind ZWEI Pakete .... klar jetzt ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User
Benutzeravatar
toady
Newbie
Newbie
Beiträge: 26
Registriert: 22. Dez 2004, 13:22
Wohnort: bei Hanau

Beitrag von toady »

ich bin an sich überhaupt nicht ungläubig. :wink:

Ich hab's bloß nicht gefunden (im Yast). Hab's jetzt aber bei SuSE direkt runtergeladen. Und kaum hat man's installiert, schon geht's...

Also, danke zusammen!!!
Gruß,
toady
Antworten