Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

WG511 nicht stabil, brauche Hilfe!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Lord
Newbie
Newbie
Beiträge: 8
Registriert: 12. Apr 2004, 13:41

WG511 nicht stabil, brauche Hilfe!

Beitrag von Lord »

Hallo,
nach längerem Studium aller Beschreibungen und endlosen Tests brauche nun doch Hilfe.
Problem:
Ich bekomme die WG511 einfach nicht stabil zum Laufen.
Habe Notebook, eingebaute Eth0 ist in Yast deinstalliert, also nur die WG511 als Eth1.
In /usr/lib/hotplug/firmware/ liegt isl3890, ist ca 91 kB groß.
Stammt vom Online-Yast-Update von Suse.
Frage: Die Firmware von der XP-CD namens WG511xx.arm ist aber 120 kB groß. Paßt das?
Karte wird in Yast sofort erkannt, habe sie mit DHCP (Netgear-Router WGR614) als PCMCIA konfiguriert mit Kanal 11 ohne Verschlüsselung.
Nach dem Aus/Einstecken brennt die güne LED, geht aber nach kurzem wieder aus.
Nach ifup eth1 wird die Schnittstelle wieder kurz aktiviert, aber ein stabiler Zustand läßt sich nicht herstellen.
Das Tool kwifimanager zeigt absolut wackelige Anzeigen an. manchmal fast Vollausschlag, dann wieder wieder keine Funkverbindung.
Was mir noch aufällt, ist daß kwifimanager im 5 sek. Takt plötzlich eine fremde Mac-Adresse (nicht die vom Router) anzeigt. Alle Versuche mit Konfigurationen über das Tool bleiben wirkungslos.
Habe mal die Ausgaben von /var/log/messages nach dem Einstecken und
die Ausgaben von ifconfig, ifwconfig und ipup eth1 gepostet.
Wäre für jede Hilfe und Idee sehr dankbar.

Vielen Dank

notebook:/home/helmut # tail -f /var/log/messages
Feb 13 17:20:23 notebook kernel: eth1: islpci_close ()
Feb 13 17:20:23 notebook dhcpcd[17104]: recvfrom: Network is down
Feb 13 17:20:23 notebook dhcpcd[17104]: dhcpStop: ioctl SIOCSIFADDR: No such device
Feb 13 17:20:23 notebook dhcpcd[17104]: dhcpStop: ioctl SIOCSIFFLAGS: No such device
Feb 13 17:20:24 notebook dhcpcd[17104]: terminating on signal 15
Feb 13 17:20:24 notebook dhcpcd[17104]: dhcpStop: ioctl SIOCSIFADDR: Bad file descriptor
Feb 13 17:20:24 notebook dhcpcd[17104]: dhcpStop: ioctl SIOCSIFFLAGS: Bad file descriptor
Feb 13 17:20:24 notebook modify_resolvconf: no matching backup found, left everything alone
Feb 13 17:20:24 notebook modify_resolvconf: no matching backup found, left everything alone
Feb 13 17:20:24 notebook dhcpcd-hook: Skipping 'ifdown $INTERFACE -o dhcp' call
Feb 13 17:20:54 notebook kernel: PCI: Enabling device 0000:02:00.0 (0000 -> 0002)
Feb 13 17:20:54 notebook kernel: eth1: prism54 driver detected card model: Netgear WG511
Feb 13 17:20:54 notebook kernel: eth1: islpci_open()
Feb 13 17:20:54 notebook kernel: eth1: resetting device...
Feb 13 17:20:54 notebook kernel: eth1: uploading firmware...
Feb 13 17:20:54 notebook kernel: eth1: firmware uploaded done, now triggering reset...
Feb 13 17:20:54 notebook kernel: eth1: mgt_commit has failed. Restart the device
Feb 13 17:20:54 notebook kernel: eth1: islpci_close ()
Feb 13 17:20:54 notebook kernel: eth1: islpci_open()
Feb 13 17:20:54 notebook kernel: eth1: resetting device...
Feb 13 17:20:54 notebook kernel: eth1: uploading firmware...
Feb 13 17:20:54 notebook kernel: eth1: firmware uploaded done, now triggering reset...
Feb 13 17:20:55 notebook kernel: eth1: mgt_commit has failed. Restart the device
Feb 13 17:21:05 notebook kernel: eth1: no IPv6 routers present
Feb 13 17:21:29 notebook kernel: eth1: mgt_commit has failed. Restart the device
Feb 13 17:21:29 notebook ifup-wireless: command 'iwconfig eth1 key off' returned
Feb 13 17:21:29 notebook ifup-wireless: Error for wireless request "Set Encode" (8B2A) :
Feb 13 17:21:29 notebook ifup-wireless: SET failed on device eth1 ; Input/output error.
Feb 13 17:21:33 notebook modify_resolvconf: Service dhcpcd modified /etc/resolv.conf. See info block in this file
Feb 13 17:21:43 notebook dhcpcd[17662]: infinite IP address lease time. Exiting
Feb 13 17:21:44 notebook kernel: eth1: Out of memory, cannot handle oid 0xecd944f9
Feb 13 17:21:44 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:21:45 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:21:45 notebook kernel: eth1: errant PIMFOR application frame
Feb 13 17:21:45 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:21:46 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:21:46 notebook kernel: eth1: mgt_commit has failed. Restart the device
Feb 13 17:21:46 notebook kernel: eth1: errant PIMFOR application frame
Feb 13 17:21:46 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:21:47 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:21:47 notebook kernel: eth1: errant PIMFOR application frame
Feb 13 17:21:47 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:21:48 notebook ifup-wireless: command 'iwconfig eth1 key off' returned
Feb 13 17:21:48 notebook ifup-wireless: Error for wireless request "Set Encode" (8B2A) :
Feb 13 17:21:48 notebook ifup-wireless: SET failed on device eth1 ; Input/output error.
Feb 13 17:21:48 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:22:15 notebook kernel: mgt_get_request(0x12000000): received data length was bigger than expected (62 > 4). Memory is probably corrupted... <7>mgt_get_request(0x12000001): received data length was bigger than expected (21 > 4). Memory is probably corrupted... <4>eth1: Out of memory, cannot handle oid 0x00000200
Feb 13 17:22:15 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:22:16 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:22:16 notebook kernel: eth1: mgt_commit has failed. Restart the device
Feb 13 17:22:16 notebook kernel: eth1: errant PIMFOR application frame
Feb 13 17:22:16 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:22:17 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:22:17 notebook kernel: eth1: errant PIMFOR application frame
Feb 13 17:22:17 notebook kernel: eth1: timeout waiting for mgmt response 1000, trigging device
Feb 13 17:22:18 notebook kernel: eth1: timeout waiting for mgmt response
Feb 13 17:22:18 notebook ifup-wireless: command 'iwconfig eth1 key off' returned
Feb 13 17:22:18 notebook ifup-wireless: Error for wireless request "Set Encode" (8B2A) :
Feb 13 17:22:18 notebook ifup-wireless: SET failed on device eth1 ; Input/output error.

notebook:/home/helmut #




notebook:/home/helmut # ifup eth1
eth1 device: Harris Semiconductor D-Links DWL-g650 A1 (rev 01)
eth1 configuration: wlan-bus-pcmcia
eth1 warning: using NO encryption
ERROR: command 'iwconfig eth1 key off' returned
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Input/output error.
DHCP client is already running on eth1
notebook:/home/helmut # ifconfig
eth1 Protokoll:Ethernet Hardware Adresse 00:09:5B:98:17:87
inet Adresse:192.168.0.5 Bcast:192.168.0.255 Maske:255.255.255.0
inet6 Adresse: fe80::209:5bff:fe98:1787/64 Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:1420 (1.3 Kb) TX bytes:4946 (4.8 Kb)
Interrupt:3

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:25004 errors:0 dropped:0 overruns:0 frame:0
TX packets:25004 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:3280045 (3.1 Mb) TX bytes:3280045 (3.1 Mb)

notebook:/home/helmut # iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11b/g Nickname:"notebook"
Mode:Managed Channel:11 Access Point: 00:00:00:00:00:00
Bit Rate:0kb/s Sensitivity=20
Fragment thr:2346 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

notebook:/home/helmut # ifup eth1
eth1 device: Harris Semiconductor D-Links DWL-g650 A1 (rev 01)
eth1 configuration: wlan-bus-pcmcia
eth1 warning: using NO encryption
ERROR: command 'iwconfig eth1 key off' returned
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; Input/output error.
Starting DHCP Client Daemon on eth1... . . . . . no IP address yet... backgrounding.notebook:/home/helmut # ifconfig
eth1 Protokoll:Ethernet Hardware Adresse 00:09:5B:98:17:87
inet Adresse:192.168.0.5 Bcast:192.168.0.255 Maske:255.255.255.0
inet6 Adresse: fe80::209:5bff:fe98:1787/64 Gültigkeitsbereich:Verbindung
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:1581 (1.5 Kb) TX bytes:9160 (8.9 Kb)
Interrupt:3

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:25004 errors:0 dropped:0 overruns:0 frame:0
TX packets:25004 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:3280045 (3.1 Mb) TX bytes:3280045 (3.1 Mb)

notebook:/home/helmut #



Nochmals vielen Dank
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Von der WG 511 gibt es verschiedene Versionen.
Wir müssen erst mal klären welche Version Du hast.

1. Vorderseite WG511 (ohne Anhang)
Rückseite "Aufdruck "Made in China" - geht nur mit ndiswrapper

2. Vorderseite WG511v2 geht mit prism54 - Treiber (bin mir aber nicht sicher)

3. Vorderseite WG511 (ohne Anhang)
Rückseite "Aufdruck "Made in Thaiwan" - > Geht mit prism54 Treiber

Gert
Lord
Newbie
Newbie
Beiträge: 8
Registriert: 12. Apr 2004, 13:41

Beitrag von Lord »

Danke für die schnelle Antwort

Punkt 3:
WG511 made in Taiwan
Mad Elk
Member
Member
Beiträge: 133
Registriert: 12. Apr 2004, 18:56

Beitrag von Mad Elk »

Hi,
ich habe die Karte mit dem gleichen Router unter der 9.1 problemlos mit der Anleitung von http://www.linux-club.de/viewtopic.php?t=4115 zum Laufen bekommen. Die Datei "firmware.agent" ist bei den angegebenen Links leider nicht mehr zu finden (wie ich erfahren habe), ich kann sie Dir aber zumailen. PM genügt.

Mad Elk
Lord
Newbie
Newbie
Beiträge: 8
Registriert: 12. Apr 2004, 13:41

Beitrag von Lord »

Hallo,
ich habe das Problem jetzt lösen können.
Die Karte habe ich an einem anderen Notebook mit Suse 9.1 sofort zum Laufen bekommen.
An meinem Notebook Fujitsu Siemens Amilo 7620 konnte ich sie jedoch weder unter Linux, noch unter XP (nur für Testzwecke!!!) zum Laufen bringen.

Nach längerer Zeit des Probierens und Testens habe ich als letzte Möglichkeit ein BIOS-Update durchgeführt.
Vorinstallierte Version 1.02C, jetztige 1.03C.

Und siehe da, alles läuft perfekt mit dem prism54-Treiber.
Stabile Netzwerkverbindung, Hotplugging, einfach alles ok.

Vielen Dank nochmal für die Hilfe.
Antworten