Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] Midi-Dateien anhören

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
rush hour
Member
Member
Beiträge: 119
Registriert: 19. Jul 2004, 20:39
Wohnort: Bei Ruth
Kontaktdaten:

[solved] Midi-Dateien anhören

Beitrag von rush hour »

und nicht nur abspielen, das wär mal was! Auch als root klappt das Hören nicht, obwohl ich sehen kann dass da was gespielt wird (so ne Art Fortschrittsbalken). Es ghet um Suse 9.2.
Woran kann da sliegen?
openSuSE 42.1 (Leap)/64-bit
ATI HD7950 1 GB GDDR5
MSI Z87-G45
Intel i5-4670K@3400
Soundblaster X-Fi Titanium (PCIe)

alle Linux-Partitionen sind ext4 formatiert
Auf sda(1): Win10/64 Pro, openSuSE/Leap 42.1 auf sdb(2); UEFI-Modus aktiv (wegen Windows)
Benutzeravatar
robi
Moderator
Moderator
Beiträge: 3175
Registriert: 25. Aug 2004, 02:13

Beitrag von robi »

siehe hier, selbes Problem.
http://www.linux-club.de/viewtopic.php?t=25687

robi
Benutzeravatar
rush hour
Member
Member
Beiträge: 119
Registriert: 19. Jul 2004, 20:39
Wohnort: Bei Ruth
Kontaktdaten:

Beitrag von rush hour »

seltsam ist: über die Konsole kann ich mit timidity <MIDI-Datei> einwandfrei hören.
Woran kann das noch liegen?
openSuSE 42.1 (Leap)/64-bit
ATI HD7950 1 GB GDDR5
MSI Z87-G45
Intel i5-4670K@3400
Soundblaster X-Fi Titanium (PCIe)

alle Linux-Partitionen sind ext4 formatiert
Auf sda(1): Win10/64 Pro, openSuSE/Leap 42.1 auf sdb(2); UEFI-Modus aktiv (wegen Windows)
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4380
Registriert: 14. Jun 2004, 09:12

Beitrag von Geier0815 »

Moin rush hour,

starte timidity doch mal im alsa-server-mode:

Code: Alles auswählen

timidity -iA -B2,8 -Os &
Danach gehst Du ins Kotrollzentrum von KDE und stellst unter 'Soundsystem' 'Hardware' 'MIDIgerät wählen' timidity ein. Nun sollte es gehen. Wenn Du timidity nach der Anleitung in deine Startdateien aufnimmst, ist das sogar dauerhaft.
Aber mal ehrlich: Das Ganze ist im Administrationshandbuch von SuSE recht ausführlich beschrieben. Hast Du da etwa nicht als erstes gesucht?
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?
Benutzeravatar
rush hour
Member
Member
Beiträge: 119
Registriert: 19. Jul 2004, 20:39
Wohnort: Bei Ruth
Kontaktdaten:

Beitrag von rush hour »

Geier0815 hat geschrieben:Moin rush hour,

starte timidity doch mal im alsa-server-mode:

Code: Alles auswählen

timidity -iA -B2,8 -Os &
Danach gehst Du ins Kotrollzentrum von KDE und stellst unter 'Soundsystem' 'Hardware' 'MIDIgerät wählen' timidity ein. Nun sollte es gehen. Wenn Du timidity nach der Anleitung in deine Startdateien aufnimmst, ist das sogar dauerhaft.
Aber mal ehrlich: Das Ganze ist im Administrationshandbuch von SuSE recht ausführlich beschrieben. Hast Du da etwa nicht als erstes gesucht?
Also: manuell den timidity gestartet und noteedit angepaßt, es funktioniert! Danke!

ABER: im Handbuch zur 9.2 steht IMHO nicht so viel drin über dieses spezielle Problem, außerdem gibt es kein Skript namens timidity, auf das man linken könnte, auch das eine Verzeichnis existiert nicht.
openSuSE 42.1 (Leap)/64-bit
ATI HD7950 1 GB GDDR5
MSI Z87-G45
Intel i5-4670K@3400
Soundblaster X-Fi Titanium (PCIe)

alle Linux-Partitionen sind ext4 formatiert
Auf sda(1): Win10/64 Pro, openSuSE/Leap 42.1 auf sdb(2); UEFI-Modus aktiv (wegen Windows)
Antworten