Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Tastaturproblem: at hat keine Funktion

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
ignoramus
Newbie
Newbie
Beiträge: 15
Registriert: 6. Feb 2005, 13:01

Tastaturproblem: at hat keine Funktion

Beitrag von ignoramus »

Hallo,

habe keine passende Forengruppe gefunden und da mir die Konsole sympatisch ist, schreibe ich einfach mal hier.

Ich habe bei SuSE Linux 9.0 ein kleines Problem mit der Eingabe des at-Zeichens. Habe die deutsche Tastaturbelegung eingestellt - alle anderen Tasten funktionieren auch wie sie sollen - nur leider das at-Zeichen nicht.

Es kann ja nun keine Dauerlösung sein, das Zeichen immer per copy&past sich zu besorgen. :wink:

Vielleicht liegt es an der Laptop-Tastatur? Habe ein Dell Inspiron 2500.

Würde mich über einen Tip sehr freuen.


Viele Grüße an die Gemeinde,

ignoramus
Benutzeravatar
regexer
Advanced Hacker
Advanced Hacker
Beiträge: 1005
Registriert: 3. Dez 2004, 09:29
Wohnort: $_

Re: Tastaturproblem: at hat keine Funktion

Beitrag von regexer »

ignoramus hat geschrieben:Vielleicht liegt es an der Laptop-Tastatur?
Gehst du mit irgendeiner Terminal-Emulation auf eine Linux-Kiste, oder ist das eine lokale Installation? Manchmal liegt es nämlich auch am Terminal-Programm. Zum Beispiel habe ich ein ähnliches Problem mit PuTTY. Hier funktionieren die F-Tasten nicht ...
tomte
Hacker
Hacker
Beiträge: 798
Registriert: 15. Nov 2003, 13:40
Wohnort: 16°08'12"E / 56°34'08"N

Beitrag von tomte »

hmm, benutzt du die Konsole in KDE? Dann könnte ien Blick ins Kontrollzentrum (kcontrol) helfen.
Ansonsten kontrollier nochmal mit sax deine Keyboardeinstellungen.
Nothing is easier than being busy - and nothing more difficult than being effective.
Benutzeravatar
TeXpert
Guru
Guru
Beiträge: 2166
Registriert: 17. Jan 2005, 11:22

Beitrag von TeXpert »

Einstellungen im KDE-Kontrollzentrum (pc105) und in /etc/X11/XF86config

Code: Alles auswählen

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "pc105"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection
ignoramus
Newbie
Newbie
Beiträge: 15
Registriert: 6. Feb 2005, 13:01

Beitrag von ignoramus »

Hallo!

Schonmal vielen Dank für die Antworten!

Ich habe hier eine lokale Installation, kein Terminal. Meine XF86Config sieht so aus:
--------
Section "InputDevice"
Driver "keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection
-----
Anderer Treiber? Sollte ich das per Hand ändern? Kann auch schief gehen, oder?

Das KDE-Kontrollzentrum konnte mir auch nicht weiterhelfen.

Habe jetzt aber noch etwas in der Beschreibung zum Konfigurationsprogramm "xf86config" im SuSE Admin-Handbuch gelesen (Seite 106) bezüglich des Wertes "ModeShift", der der rechten Alt-Taste zugeordnet werden muss, damit die über ALT-Gr erreichbaren Zeichen funktionieren.

Wo kann ich denn diese Zuordnung einsehen und ändern? Wenn ich mich richtig erinnere, arbeitet das Prog alle Parameter nacheinander ab!? Da wage ich mich nich ran. Alles andere läuft gerade so schön ;-)

Danke und viele Grüße!
Antworten