Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fehlermeldung nmbd

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Fehlermeldung nmbd

Beitrag von carsten »

Hallo,

folgendes steht in der warn.log:

Code: Alles auswählen

main nmbd nmbd/nmbd_browsesync.cfind_domain_master_name_query_fail
main nmbd: Unable to find the Domain Master Browser name W<1b> for the workgroup W.
UNd das halt regelmäßig...

Was kann das sein?
Samba 3.?? (letzes Update mit apt), SuSE 9.1, Clients Win98SE und XP SP2 prof.

Grüße
Carsten
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Benutzeravatar
mcdaniels
Member
Member
Beiträge: 90
Registriert: 14. Feb 2004, 09:52
Kontaktdaten:

Beitrag von mcdaniels »

Hi
Poste mal deine smb.conf

Welches OS Level hast du denn in der Samba Config Datei eingestellt?

Vielleicht ein Problem mit dem Masterbrowser. (Würd ich mal vermuten)

Hm heisst deine Workgroup und Computer vielleicht gleich?
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

Code: Alles auswählen

# Samba config file created using SWAT
# from 192.168.2.15 (192.168.2.15)
# Date: 2005/01/23 19:51:32

# Global parameters
[global]
	workgroup = W
	interfaces = 127.0.0.1 eth0
	bind interfaces only = Yes
	security = SHARE
        guest account = nobody
	map to guest = Bad User
	time server = Yes
	printcap name = cups
	printing = cups
	os level = 65
	preferred master = Yes
	domain master = No
	wins support = Yes
	printer admin = @ntadmin, root, administrator, admin, @ntuser
	create mask = 0777
	directory mask = 0777
	socket options = SO_KEEPALIVE SO_BROADCAST TCP_NODELAY
	null passwords = yes
	veto files = /*.eml/*.nws/riched20.dll/*.{*}/
	comment = Server wi-mi.del
	min password length = 0

[homes]
	comment = Home Directories
	valid users = %S
	read only = No
	browseable = No

[users]
	comment = All users
	path = /home
	read only = No
	writeable = yes
	browseable = yes
	inherit permissions = Yes
	guest ok = Yes
	veto files = /aquota.user/groups/shares/

[groups]
	comment = All groups
	path = /home/groups
	read only = No
	inherit permissions = Yes
	guest ok = Yes

[pdf]
	comment = PDF creator
	path = /var/tmp
	create mask = 0600
	guest ok = Yes
	printable = Yes
	print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z

[printers]
	comment = All Printers
	path = /var/tmp
	create mask = 0666
	guest ok = Yes
	printable = Yes
	browseable = No
	writeable = no
	hosts allow = 192.168.2.0/24 127.0.0.0/8

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin, root
	force group = ntadmin, nobody
	create mask = 0664
	directory mask = 0775
	guest ok = Yes

[Ablage]
	comment = Ablage
	path = /Ablage
	read only = No
	guest ok = Yes
Workgroup ist gleich, denn auf "Ablage" kann ich zugreifen ohne Probleme.

Ach ja, Samba ist KEIN PDC; sowas hab /brauch ich nicht.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Benutzeravatar
holi
Newbie
Newbie
Beiträge: 12
Registriert: 27. Dez 2004, 14:38
Kontaktdaten:

Gleiches Problem

Beitrag von holi »

carsten hat geschrieben:

Code: Alles auswählen

# Samba config file created using SWAT
# from 192.168.2.15 (192.168.2.15)
# Date: 2005/01/23 19:51:32

# Global parameters
[global]
	workgroup = W
	interfaces = 127.0.0.1 eth0
	bind interfaces only = Yes
	security = SHARE
        guest account = nobody
	map to guest = Bad User
	time server = Yes
	printcap name = cups
	printing = cups
	os level = 65
	preferred master = Yes
	domain master = No
	wins support = Yes
	printer admin = @ntadmin, root, administrator, admin, @ntuser
	create mask = 0777
	directory mask = 0777
	socket options = SO_KEEPALIVE SO_BROADCAST TCP_NODELAY
	null passwords = yes
	veto files = /*.eml/*.nws/riched20.dll/*.{*}/
	comment = Server wi-mi.del
	min password length = 0

[homes]
	comment = Home Directories
	valid users = %S
	read only = No
	browseable = No

[users]
	comment = All users
	path = /home
	read only = No
	writeable = yes
	browseable = yes
	inherit permissions = Yes
	guest ok = Yes
	veto files = /aquota.user/groups/shares/

[groups]
	comment = All groups
	path = /home/groups
	read only = No
	inherit permissions = Yes
	guest ok = Yes

[pdf]
	comment = PDF creator
	path = /var/tmp
	create mask = 0600
	guest ok = Yes
	printable = Yes
	print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z

[printers]
	comment = All Printers
	path = /var/tmp
	create mask = 0666
	guest ok = Yes
	printable = Yes
	browseable = No
	writeable = no
	hosts allow = 192.168.2.0/24 127.0.0.0/8

[print$]
	comment = Printer Drivers
	path = /var/lib/samba/drivers
	write list = @ntadmin, root
	force group = ntadmin, nobody
	create mask = 0664
	directory mask = 0775
	guest ok = Yes

[Ablage]
	comment = Ablage
	path = /Ablage
	read only = No
	guest ok = Yes
Workgroup ist gleich, denn auf "Ablage" kann ich zugreifen ohne Probleme.

Ach ja, Samba ist KEIN PDC; sowas hab /brauch ich nicht.

Grüße
Auch ich habe das gleiche Problem, die smb.conf sieht fast gleich aus. Ichh hab auch schon verschiedene Params durchgespielt z.b. keep alive = 120.

In log.smbd habe ich auch noch Internal Error: signal 11 in pid udn panic errors.

Das ganze resultiert auch in verlorenen Netzwerkverbindungen und insbesondere in Drucker die manchmal nicht drucken. Nach einigen aktualisierungen mit F5 auf den Cleints gehts dann wieder bis zum nächsten Verbindungsabruch. Meine samba Version ist 2.2.8

give me help

holi
carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten »

ich hab domain master = yes eingestellt. Damit gings dann.

Ansonsten empfehle ich mal ein Update auf Samba 3.x
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)
Benutzeravatar
holi
Newbie
Newbie
Beiträge: 12
Registriert: 27. Dez 2004, 14:38
Kontaktdaten:

Beitrag von holi »

Danke für den Hinweis aber domain master browser = yes hab ich schon eingestellt. das hilft beim nmb und der läuft jetzt einwandfrei. beim smb hab ich immer noch: :(
lib/util.c:smb_panic(1135)
PANIC: internal error
und
lib/fault.c:fault_report(39)
INTERNAL ERROR: Signal 11 in pid 2944

Guido
Antworten