Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Ndiswrapper erkennt Karte falsch eth0 statt wlan0 NOT READY!

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Du hast jetzt 2 verschiedene Config-Dateien für Deine Karte in

/etc/sysconfig/network

Die richtige mus heißen Ifcfg-wlan0 !

Ändere mal die Dateinahmen von allem was irgendwie eth zum Inhalt hat.
Also sowas wie Ifcfg-eth0. Wenn Du eine Datei mit -pcmcia- hast, dann die auch mal ändern.
Soweit ich das überblicke, wird bei Dir das Modul prism54 geladen. Das funktioniert auf keinen Fall mit Deiner Karte.


Nochmal.

Egal was scan wlan0 anzeigt. Ohne die Lampe geht die Karte nicht!
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Ich hab Dir doch in dem anderen Tread den Inhalt von Ifcfg-wlan0

gepostet. Mach mal eine Datei Ifcfg-wlan0 daraus, kopiere Sie Dir in /etc/sysconfig/network

Dann Linux neu starten -> modprobe ndiswrapper -> und Ergebnis posten

Do must bei IWconfig den Key 1111111111..... sehen.

Die 26 Stellen bedeuten, das Du 128 bit verschlüsselst.

Must Deinen Router natürlich auf den gleichen Schlüssel bringen.

Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

Hallo,
aus unerfindlichen Gründen habe ich jetzt nicht mal mehr eine ISDN-Verbindung, lässt sich einfach nicht mehr starten.
Ich werde jetzt einfach mal eine komplette Neuinstallation durchführen.
Leider wird prism54 automatisch mitinstalliert, glaube ich, kann man das nicht verhindern?
Werde es dann nochmal mit ndiswrapper versuchen ,wenn`s dann nicht klappt werd ich wohl wieder zu win zurückkehren müssen . :cry:
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Der prism54- Treiber wird nur geladen, wenn die config-Datei Deiner Karte auf das Modul "prism54" verweist.
Daher hab ich Dir meine config-Datei gepostet, denn die verweist nicht auf den prism54.

Ndiswrapper scheint bei Dir zu funktionieren, nur wird die Firmware der Karte beim Start der Netzwerkkonfiguration halt von den prism54 überschrieben und funktioniert dann nicht.

Ich bin sicher auch nicht der Linux-Profi aber poste doch mal ob Du die Dateien in /etc/sysconfig/network gefunden hast.
Da scheint auch Dein ISDN-Problem zu liegen. Die ISDN-Karte wird normalerweise als Netzzwerkkarte eingebunden oder irre ich da?

Du brauchst in dem genannten Verzeichnis eine Ifcfg-wlan0
Liste doch mal auf, was alles in dem verzeichnis so rumliegt und mit Ifcfg- beginnt


Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

Hallo, nach Neuinstallation und Einrichtung des ndiswrapper in 5 Minuten ohne irgendeine Fehlermeldung bin ich jetzt wieder bereit.
Also, da liegen:
ifcfg-eth-id-00:e0:18:e1:24:b(onboard Netzwerkkarte)
ifcfg-ippp0
ifcfg-lo
ifcfg-wlan0
ifcfg.template
Der Inhalt von ifcfg-wlan0 lautet:
BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='auto'
UNIQUE='bSAa.Ui4o+yu+DtE'
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='mein Name'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK=''
_nm_name='bus-pci-0000:00:0a.0'

wobei mich der Eintrag WIRELESS_KEY_LENGTH=`128`
wundert, habe keine Verschlüsselung ausgewählt, auch der Router läuft ohne Schlüssel und unter win funktioniert es so auch wunderbar.
Kannst Du damit was anfangen?
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

In der ifcfg-wlan0 folgendes ändern:



Wichtig! Der Eintrag
_nm_name='bus-pci-0000:00:0a.0'

muss raus. Du must aber noch in /etc/sysconfig/hardware/ die Datei bus-pci-* löschen.


WIRELESS_AP='BUNDESTAG' # Den Namen Deines ESSD (Router)

Der Eintrag WIRELESS_KEY_LENGTH=`128`
Sagt nur aus, das bei verwendeten Key die Schlüssellänge 128 Bit ist.

Die restlichen Einträge sind erst mal nicht so wichtig, Du willst ja erst Deine Karte zum Laufen bringen.

Dann Rechner neu booten. Beobachte mal den Bildschirm. Nach PCI Scan *****XX***
Meldet sich die Netzwerkkonfiguration und zählt von 20 runter
Also 20 18 15 10 und so weiter. Das liegt daran, das ndiswrapper ja noch nicht gestartet ist.

Ist der Rechner oben, als root anmelden und modprobe ndiswrapper eingeben
Jetzt muss die Lampe angehen.



Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

O.K,versuche ich gleich mal, die fehlenden DHCLIENT-Einträge machen nichts?
Habe wie gesagt die komplette dhcp-Software installiert.
Danke erstmal für die Hilfe.
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Ich hab einen Fehler gemacht,

Bei
WIRELESS_AP=''
brauchst Du nichts einzutragen. Da kann normalerweise die Mac des AP rein.
Der Eintrag für ESSD ist weiter unten -> da kommt der WLAN-Name des Routers rein

DHCP hast dDu doch mit "Auto" konfiguriert.

Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

Hallo
das mit dem AP hab ich mir schon gedacht, wenn Du mir noch verrätst wo ich DHCP auf AUTO stelle verrate ich Dir ob es so ist / wwar.
Sorry, aber ich bin echt Anfänger und jahrelang windowsgeschädigt.....
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Der Eintrag

BOOTPROTO='dhcp'

sorgt für die Abfrage beim Router, natürlich funktioniert das nur
wenn Dein Router DHCP unterstützt.

Aber das ist alles der 2. Schritt, die LAMPE mus brennen!

Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

Hatte ich auch so eingestellt, brennt aber nicht.
Ich weiss jetzt echt nicht mehr weiter.
Wenn ich die bus-pci- Datei lösche geht wieder gar nix mehr, sprich die alte NOT READY Meldung erscheint.
Was muss eigentlich bei der Konfiguration der Karte unter Hardwaredetails- Konfigurationsname stehen?
Das Feld ist nämlich leer.
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Die not ready- Meldung ist erst mal richtig,Ist beim Hochfahren das runterzählen
20 18 15 12 usw. zu sehen?

Wenn ja, dann
ndiswrapper -l
eingeben da müßte die meldung kommen, das der Treiber installiert ist
dann ndiswrapper -m
dann

modprobe ndiswrapper
eingeben und jetzt muß die Lampe leuchten.


Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

O.K
Bevor ich anfange -wie soll ich die Karte konfigurieren?
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Die Konfiguration für die Karte ist die Datei ifcfg-wlan0

Da kann vorerst alles mögliche drinstehen den solange der Treiber und damit die Firmware der karte nicht geladen ist geht nichts.

Die Firmware von WLAn-Karten stellt ein eigenes Betriebssystem in der Karte bereit, änlich einem BIOS.
Du lädst also mit dem ndiswrapper das "!bios" der Karte in diese.
Im Bios sind verschiedene Konfigurationseinstellungen möglich.
Die speichert LINUX in der ifcfg-wlan0- Datei und schickt sie bei Änderung der Werte an definierte Adressen in dem Bios.

Hast Du jetzt ein falsches Bios in der Karte bekommt LINUX das erst mal nicht mit. Der Speicher der Karte gibt ja nur das zurüch, was Linux vorher reingeschrieben hat. Auf hardwareseitigen Funktionen der Karte kann linux nicht direkt zugreifen. Die sind in der 2802w.sys Datei als Binärcode enthalten, die hast du nur in Linux, sagen wir mal als Blackbox eingebunden.

Dein Problem ist nun diesen Treiber in die Karte zu bekommen, sie einfach einzuschalten. Das funktioniert halt nur mit dem richtigen Treiber.

Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

Hallo,
also ich weiss nicht , ich habe das Gefühl, dass mit dem ndiswrapper alles stimmt, er wird über ndiswrapper -m immer mitgeladen(hardware present, driver present), dhcp ist eingestellt,
IN DER IFCFG-WLAN0 STEHT ALS MODUL DER NDISWRAPPER, über /etc/sysconfig habe ich alles soweit eingestellt,habe allerdings eine Pfad wlan0 , in dem ich alle Einstellungen vorgenommen habe und ein Pfad wireless in dem alle Einstellungen fehlen.
Im Suse plugger steht die Karte richtigerkannt mit namen und allem, allerdings ist dort immer noch prism54 als aktiver Treiber angegeben.
Driver Info #0:
Driver Status: prism54 is active
Driver Activation Cmd: "modprobe prism54"

Die Netzwerkschnittstellen kann ich anklicken aber nicht bearbeiten etc.
iwconfig zeigt auch alles richtig an, nur kein AP und auch die ESSID fehlt/ist falsch.
wlan0 IEEE 802.11g ESSID:off/any Nickname:"lukas"
Mode:Managed Frequency:2.457 GHz Access Point: 00:00:00:00:00:00
Wie kriege ich den Treiber richtig eingebunden, oder muss ich irgendwelche firmware nachinstallieren, habe ich aber bis jetzt nur im Zusammenhang mit prism54 gelesen.
Bei den wenigen erfolgreichen Installationen hats offenbar reibungslos geklappt.Vielleicht ist mir ein grundlegender Fehler unterlaufen ,aber ich wüsste nicht was.
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Der Suse Plugger sagt bei mir das Gleiche.

Geh mal in YAST -> Netzwerkkarten -> Bereits konfigurierte Geräte auf "Ändern"

Dann Die Netzwerkkarte auswählen und "Bearbeiten"

Da muß dann oben Stehen "Typ des Netzwerkes "wlan0"

In Diesem Fenster unten auf "Erweitert" -> "Hasrdwaredetails" auswählen.

Hier darf nur ganz oben in Konfigurationsname "wlan0" stehen
Alle anderen Felder müssen leer sein.

Mach das erst mal, dann sehen wir weiter
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Ich glaube wir haben was vergessen!

Suche Dir bitte mal das Verzeichnis:

/etc/hotplug

Da findest Du eine Datei mit Namen: blacklist

Die machst Du mit einem Texteditor auf und gibst folgendes ein:

# Treiber für prism54 Chipsatz
prism54

Dann Die Datei schließen und Rechner neu starten.

Die Treiber- Einträge in der Blacklist werden nicht geladen!
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

alles so gemacht, keine Reaktion der Karte.
Woher bekommst du in deiner sysconfig-Datei die dhclient-einträge?
kawa0815
Newbie
Newbie
Beiträge: 19
Registriert: 2. Feb 2005, 11:52

Beitrag von kawa0815 »

Poste mal den nhalt der datei /var/log/boot.msg

Muss nicht alles sein so ungefähr ab:
coldplug scanning input: ***done
scanning pci: **.***WW*done
scanning usb: done

Die Geschichte mit dem dhcp kannst Du erst mal vergessen. Ich glaube, Du willst gerade einen DHCP-Server unter Linux einrichten. Den gibt es schon in Deinem Router und 2 Server in einem Netzwerk gehen nicht.

Im moment ist wirklich nur wichtig, die Kontrollampe auf dem Slotblech zum leuchten zu bringen.

Lass Linux ma neu starten. Gib dann als root auf der Konsole
modprobe ndiswrapper
ein
anschließend gibst Du
dmesg
ein.
Da kommen ein Haufen Ausgaben.
Poste mal nur die Zeilen, die nach
ndiswrapper kommen. Bei mir sieht das ungefähr so aus:

ndiswrapper: driver 2802w (SMC,04/29/2004, 3.0.11.1) added
PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
PCI: Setting latency timer of device 0000:01:00.0 to 64
ndiswrapper: using irq 9
wlan0: ndiswrapper ethernet device 00:0x:xx:b4:2b using driver 2802w
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP

Gert M
Benutzeravatar
DonManfredo
Newbie
Newbie
Beiträge: 34
Registriert: 30. Jan 2005, 17:20

Beitrag von DonManfredo »

Hallo,
hier der Auszug :
ndiswrapper: unsupported module, tainting kernel.
ndiswrapper version 1.0 loaded (preempt=no,smp=no)
ndiswrapper: driver 2802w (SMC,11/25/2003, 2.1.13.0) added
ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 5 (level, low) -> IRQ 5
ndiswrapper: using irq 5
wlan0: ndiswrapper ethernet device 00:04:e2:a5:a8:28 using driver 2802w
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP
NET: Registered protocol family 17
wlan0: no IPv6 routers present
Loaded prism54 driver, version 1.2
eth0: link down
eth0: no IPv6 routers present
wlan0: no IPv6 routers present


eth0 habe ich abgeschaltet, prism54 auf die blacklist gesetzt.
Antworten