Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[solved] KDETV, neue ATI-Treiber -> schwarzer Bildschirm

Alles rund um das Thema Multimedia unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
ba0645
Member
Member
Beiträge: 117
Registriert: 21. Mai 2004, 18:34

[solved] KDETV, neue ATI-Treiber -> schwarzer Bildschirm

Beitrag von ba0645 »

Hallo

ich habe bei meinem System das Problem, dass beim Starten von KDETV unter SuSE 9.2 und mit den aktuellen ATI Grafikkartentreibern für X.ORG 6.8.1 der Bildschirm komplett schwarz wird. Man hört die TV-Ausgabe nur noch. Nach dem Umschalten auf eine Textkonsole und anschließendem zurückschalten auf die Grafische Konsole bekommt man ein ganz normales Bild und wie gewünscht auch KDETV als Fenster mit Bild.

in der XF86Config (xorg.conf) steht folgendes drin:

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
Load "dri"
EndSection

Section "Device"
...
Driver "fglrx"
Option "UseInternalAGPGART" "no"
...
EndSection

Section "ServerLayout"
...
option "Clone" "off"
option "Xinerama" "off"
...
EndSection

Section "DRI"
Group "video"
Mode "0660"
EndSection

Es spielt auch keine Rolle welche Optionen ich im KDE TV Programm einstelle: OPEN GL, XVIDEO, XVIDEO shared mem, .....
Ergebnis ist immer das gleiche.

Hat jemand eine Idee, woran das liegen könnte ? Googlen hat mir nicht wirklich weitergeholfen. Vor dem Update auf die neuen ATI-Treiber hat alles funktioniert. Sollte also vermutlich am Treiber oder Einstellungen in xorg.conf liegen.

Ach ja nochwas, ich habe eine Radeon 9600 und eine miro PCTV Karte in meinem Rechner. Asus A7N8X Deluxe Motherboard.

mfg
Markus
taki
Advanced Hacker
Advanced Hacker
Beiträge: 974
Registriert: 30. Apr 2004, 17:40
Wohnort: Berlin

Beitrag von taki »

Bei mir war wichtig, beim Laden des Moduls extmod die DGA-Initialisierung auszuschalten. Wenn ich das nicht mache, ist der Treiber instabil. Einiges geht einfach nicht, das ist erst mal zwar doof, aber nicht so schlimm. Wenn aber das fglrx-Modul erfolgreich geladen ist und man versucht auf GL zuzugreifen, friert der Rechner komplett ein.

Vielleicht hilft Dir auch die Option beim Modul extmod. S. auch hier:
http://www.linux-club.de/viewtopic.php?p=132346#132346

:!: ABER VORSICHT mit den Optionen in der unteren Section... Wenn Du den Thread weiterliest, wirst Du feststellen, dass Einstellungen, die bei einem (mir) funktionieren u.U. beim anderen eher noch mehr Fehler auslösen :( :!:
Antworten