Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Postfix: connect to localhost[127.0.0.1]: Connection refused

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Gesperrt
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Postfix: connect to localhost[127.0.0.1]: Connection refused

Beitrag von XeN »

Hallo

habe einen openxchange laufen mit Cyrus und Postfix. Abgeholt werden die mails mit Fetchmail und einsortiert mit Procmail. Das hat auch alles wunderbar geklappt. Bis gestern. Seit dem kann ich keine Mails vehr verschicken. Weder intern noch Extern. Soweit ich mit erinnere habe ich aber nichts an den cfgs geändert.

Habe 2 Mails in der queue. Eine externe und eine Interne. Bei beiden kommt

Code: Alles auswählen

connect to localhost[127.0.0.1]: Connection refused
Hier ein auszug aus der mail wenn ich mailq -q eingebe

Code: Alles auswählen

Feb  3 10:27:02 mail postfix/qmgr[433]: EF9335727: from=<intern@server.com>, size=827, nrcpt=1 (queue active)
Feb  3 10:27:02 mail postfix/qmgr[433]: E5B5480C7: from=<intern@server.com>, size=820, nrcpt=1 (queue active)
Feb  3 10:27:02 mail postfix/smtp[436]: connect to localhost[127.0.0.1]: Connection refused (port 10024)
Feb  3 10:27:02 mail postfix/smtp[437]: connect to localhost[127.0.0.1]: Connection refused (port 10024)
Feb  3 10:27:02 mail postfix/smtp[437]: E5B5480C7: to=<intern@server.com>, relay=none, delay=3855, status=deferred (connect to localhost[127.0.0.1]: Connection refused)
Feb  3 10:27:02 mail postfix/smtp[436]: EF9335727: to=<extern@server.de>, relay=none, delay=4369, status=deferred (connect to localhost[127.0.0.1]: Connection refused)


EDIT:
Hatte vergessen den Amavis zu starten

nun erhalte ich folgenden fehler:

Code: Alles auswählen

EA80416531: to=<extern@server.de>, relay=smtp.udag.de[62.146.33.70], delay=4, status=deferred (Authentication failed: cannot SASL authenticate to server smtp.udag.de[62.146.33.70]: generic failure)
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Hast du vielleicht mal eine Authentifizierung über LDAP eingerichtet?

Mfg. Mercedesdriver
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

Das Problem habe ich inzwischen behoben bekommen.

Ich hatte die alle verschlüßelungsmethoden bei suse installiert und seitdem gings wohl nicht mehr. Habe alle deinstalliert bis auf die die ich brauche und nun gehts wieder einwandfrei.


mfg XeN
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Da ja das Problem behoben ist, nur aus Interesse, hattest du den eine LDAP Authentifizierung eingerichtet?

Mfg. Mercedesdriver :)
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

Nein habe keine LDAP Auth eingerichtet. Würde ich aber gerne. Am Liebsten würde ich alles über LDAP Laufen lassen.

Kurz zur situation. Wir haben einen Server auf dem unsere Wahrenwirtschaft läuft, und da sind alle user per Passwd und Shadow angelegt. Von daher ist es einfacher die dateien einfach rüber zu kopieren. Allerdings läuft auf dem Mailserver noch ein OpenXchange und das braucht zwangsläufig LDAP. Der Postfix bzw. der Cyrus greifen aber auf die Passwd und Shadow zu. Wenn ich die beiden programme noch auf LDAP gemünzt bekomme muss ich zwar alle user in LDAP hinzufügen, aber das kostet mich einen Tag und dann hab ich ruhe. Eine Arbeit die ich aus Administrativer sicht gerne in kauf nehmen würde.

Mal sehen ob, bzw. wie ich das gebacken bekomme. Vielleicht bestellen wir für die Groupware auch einen größeren neuen server (wolten sowieso einen neuen bestellen, der server läuft im mom auf einer P3 SLES 9 workstation) der dann auch für die Wahrenwirtschaft die Authentifizierug übernimmt.
Aber mal schauen, dann könnte man ja noch ein Samba file server andenken aber das steht erstmal noch in der Planung und soll auch erstmal nicht mein problem sein. Ich will den server jedenfalls komplett auf LDAP umstellen wenns möglich ist.

Hast du ein Paar howtos wo sowas drin steht? Am besten währe deutsch, englisch ginge natürlich auch =).

mfg XeN
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Leider habe ich keine HowTos zu dem Thema ich stehe nämlich fast vor genau demselben Problem.
Bei Postfix kann man das relativ einfach in der main.cf einstellen indem du die LDAP-Konfigurationsdatei auslagerst. Nur bei Cyrus weiß ich irgendwie nicht weiter. Dort macht man das angeblich über pwcheck_pam, nur ich weiß nicht wie :(.
Mal schauen, wenn ich mehr weiß schreibe ich es. Ansonsten, wir freuen uns über jede Hilfe ... :)

Mfg. Mercedesdriver :)
XeN
Newbie
Newbie
Beiträge: 49
Registriert: 29. Dez 2004, 11:23

Beitrag von XeN »

bei cyrus gab es glaub ich noch irgendwie eine smtpd.conf wo man auch nochmal pwcheck einstellen konnte. Aber es kann auch sein das ich da jetzt wiedermal was mit SASL zusammenwürfel.

Ich werd mal suchen und schauen wies mit Postfix geht. Und wenn ich das geschafft habe wage ich mich mal an Cyrus ran.

Muss allerdings bis mittwoch nachmittag warten. Hab morgen noch urlaub und Mittwoch morgen schule.

mfg
Benutzer 14843 gelöscht

Beitrag von Benutzer 14843 gelöscht »

Ich werde mal inzwischen noch nach ein paar Informationen sehen ...

Mfg. Mercedesdriver :)
Gesperrt