Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Flash... ein stiller Zeitgenosse unter Linux ?!?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
rethus
Advanced Hacker
Advanced Hacker
Beiträge: 1028
Registriert: 17. Sep 2004, 10:21
Wohnort: Kerpen
Kontaktdaten:

Flash... ein stiller Zeitgenosse unter Linux ?!?

Beitrag von rethus »

Hi @ all,
wenn ich im I-net unterwegs bin, herscht bei mir immer Totenstille, denn irgendwie gibt das System keinen Ton von sich.

Ich nutze Suse 9.1, die Soundkarte ist richtig konfiguriert, und funzt im lokalen betrieb weunderbar.
Aber wie gesagt bzw. geschrieben wird im Inet kein Tönchen ausgegeben.
Hat jemand eine Lösung zur Situation parrat???

PS: Nutze KaMix als AudioMixer ( und ja, es ist alles eingeschaltet
:roll: )

:wink: Vielen Dank schon mal...
rethus
Advanced Hacker
Advanced Hacker
Beiträge: 1028
Registriert: 17. Sep 2004, 10:21
Wohnort: Kerpen
Kontaktdaten:

[Problem gelöst]... Globallösung für Soundprobleme

Beitrag von rethus »

Wenn du das Problem hast, das die Soundausgabe für das System selbst funktioniert, jedoch weder im Web, noch bei Spielen Sound ausgegeben wird, dann .... ja dann hab ich eine mögliche Lösung:

Schuld ist meist arts (ein Modulbasiertes soundSystem für KDE).
Arts hat die Angewohnheit, die exclusive Kontrolle über das Soundsystem zu übernehmen, und Anfragen die direkt an die Hardware gehen zu blocken.

:idea:2 Lösungsmöglichkeiten: (bei mir SUSE9.1)
  • 1. artsdsp gefolgt von dem Programm (Achtung muss ein binary-File sein) das Ihr aufrufen wollt:
    z.B. artsdsp /opt/Realplayer/realplay.bin
  • 2. Menü :arrow: Kontrollzentrum :arrow: Sound & Multimedia :arrow: Soundsystem aufrufen.
    Die Checkbox "Automatisches Abschalten" aktivieren...FERTIG!!!
Nachdem ich die Einstellung im Kontrollzentrum vorgenommen habe, habe ich wieder überall Sound... im Realplayer, in Flash-Anwendungen etc.

Ich hoffe bei euch klappt's auch...

Gruß
rethus
Belial
Newbie
Newbie
Beiträge: 4
Registriert: 13. Jan 2005, 08:23

Beitrag von Belial »

Hab dasselbe Problem: Flash ohne Ton - auch nach Lösungsmöglichkeit 2.

@rethus: soweit ich die Beschreibung verstanden habe, bewirkt die Einstellung genau das Gegenteil:
Das KDE-Soundsystem übernimmt die exklusive Kontrolle über Ihre Audio-Hardware. Dadurch können andere Programme geblockt werden, sobald sie die Hardware direkt nutzen wollen. Wenn sich das Soundsystem im Leerlauf befindet, kann es seine exklusive Kontrolle aufgeben."

Autom. Abschalten, wenn inaktiv für...
Das heisst doch: wenn die Option gewählt ist, dann gibt das System im Leerlauf die Kontrolle frei. Wenn nicht aktiviert, gibt das System die Kontrolle nie frei.

Hat jemand noch einen Vorschlag?
rethus
Advanced Hacker
Advanced Hacker
Beiträge: 1028
Registriert: 17. Sep 2004, 10:21
Wohnort: Kerpen
Kontaktdaten:

Eher andersrum...

Beitrag von rethus »

Beim Start von KDE wird auch der Sound-Deamon von KDE gestartet. Mit der Option sagst du ihm praktisch: Wenn der KDE-eigene Sound-Deamon "xx" Sekunden nicht mehr gebraucht wurde, brauchst du den auch nicht weiter in Beschlag zu nehmen... also lass den Zugriff auf die Hardware auch über andere Programme zu....

Bei mir war es dieses Problem, was es genau bei dir ist, kann ich nicht sagen, ich weiß weder welche Distri du nutzt, noch welchen Browser, welche Plugins du installiert hast usw.

Solltest du z.B. Firefox nutzen, empfehle ich dir die Website : http://plugindoc.mozdev.org/de-DE/faqs/ ... linux.html... da bekommt man schon mal die Basisinfos.

Greetings
rethus
Antworten