Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

samba smbmount problem

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
gameace
Newbie
Newbie
Beiträge: 6
Registriert: 13. Nov 2004, 17:21

samba smbmount problem

Beitrag von gameace »

Tach erstmal zusammen...
Ich habe folgendes Problem,wobei ihr mir bestimmt und freundlicherweise helfen könnt.
Also ich mounte mit nem suseclient ne samba Freigabe und muss dann verwundert festellen das als Besitzer der Freigabe die UID 500 angezeigt wird,dies ist auch der eigentliche lokale Besitzer auf dem Server,dadurch habe ich dann logischerweise keine Schreibrechte im meinen Home verz..Dass heisst dann,dass irgendwie beim mounten kein usermapping statt findet.Wenn ich aber stattdessen über smb://host/freigabe gehe,ist alles so wie es sein sollte,der richtige user wird als besitzer angezeigt wo er es sein soll und Schreibrechte usw.
Schon mal vorab ich benutze kein NFS weil dort ja die UID identisch sein müssen und ich habe nur ein kleines LAN wo sich ein LDAP net lohnen würde.

Hier mal meine smbfstab

Code: Alles auswählen

# service       moint-point     vfstype options

;//fjall/test    /data/test      cifs    username=tridge,password=foobar
//ip62/archiv   /mnt/server     smbfs   username=jackson,password=********
//ip62/homepage   /mnt/homepage     smbfs   username=jackson,password=********
//ip62/gameace   /home/gameace/home    smbfs   username=jackson,password=********
Ich habe auch mal statt smbfs cifs probiert damit hat aber nur die console kein problem alle anderen Programme schon und ausserdem scheint dann auch kein usermapping stattzufinden.
Gamic
Member
Member
Beiträge: 109
Registriert: 26. Jun 2004, 15:16

Beitrag von Gamic »

Hallo,

versuch doch mal die zusätzlichen Optionen uid und gid: z.B.
smbmount //DeinRechner/Freigabe /mnt -o uid=1000,gid=100

uid und gid kannst du dann frei wählen und so (hoffentlich) das Mapping durchführen
craano
Newbie
Newbie
Beiträge: 17
Registriert: 12. Jan 2005, 11:38

Beitrag von craano »

Du mußt noch weitere Optionen mit angeben:

-o rw,uid=userxy,gid=groupxy,dmask=0775,fmask=0775,umask=0002

Ich hatte gestern genau dasselbe Problem. Damit sollte es funktionieren.

Gruß,
craano.
gameace
Newbie
Newbie
Beiträge: 6
Registriert: 13. Nov 2004, 17:21

Beitrag von gameace »

Hab das Problem immer noch,trotz eurer hilfreichen Antworten.
Eigentlich hatte ich mich damit abgefunden aber jetzt es mir wieder mal sauer aufgestossen :evil:
Deswegen flehe ich nochmal um Hilfe :oops:
Also hab noch ein paar Symtome ausmachen können.
1.Dauert das kopieren ewigkeiten( und drei Tage),weil der vorher irgendwas anderes zu machen scheint.
2.
mv: Erhalten der Zeiten für ,,/mnt/server/archiv2/theballadofjackandrose_m480.mov": Die Operation ist nicht erlaubt
mv: preserving permissions for ,,/mnt/server/archiv2/theballadofjackandrose_m480.mov": Die Operation ist nicht erlaubt
Antworten