Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Squid.conf + cache_peer

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

[gelöst] Squid.conf + cache_peer

Beitrag von Desti »

Hallo zusammen,

da mein erster versuch hier Hilfe für Squid zu bekommen wohl in die Hose ging, versuch ichs nun nochmal mit genaueren Infos.

Ich bin azubi und hab die Aufgabe bekommen nen Squidserver so aufzusetzten, dass er die Anfragen weiter an unseren "wirklichen" Proxy übergibt.

Also Informationsquelle habe ich www.squid-handbuch.de genommen.

Also, mein Squid lauscht nun auf Port 8080 (http_port 8080).

Wenn ich ihn also anspreche kommt nun die Nachricht:
"Access Denieded. Access Control configuration prevents your request from being allowed at this time."

So nun die "relay" - Einstellungen:

Unser Proxy hier lauscht auf Port 3128, so wie ich es nach dem squidhandbuch verstanden habe muss ich die Übergabe via "cache_peer" machen.


So solls sein:
cache_peer

Hiermit werden Verbindungen zu Nachbar-Proxys eingerichtet.

Syntax: cache_peer hostname type http_port icp_port [options ...]

Die Angabe type bestimmt die Art der Nachbarbeziehung und kann parent, sibling oder multicast sein. Parent ist ein übergeordneter Proxy (z.B. eine Firewall), Sibling ist ein gleichwertiger Nachbar-Proxy und Multicast bestimmt eine Multicast-Gruppe.
Meine Zeile:

Code: Alles auswählen


cache_peer 192.168.254.106 parent 3128 7 proxy-only
Nur ändert sich nichts an der Situation, ich komm bis zum squid und dann kommt die gleiche Nachricht, als würd ich die Zeile wech lassen.

HILFE :)

greetz
Desti
Wenn Windows XP die Antwort ist...,

...wie blöd ist dann die Frage gewesen?
Desti
Member
Member
Beiträge: 85
Registriert: 11. Jan 2005, 14:40
Wohnort: Duisburg

Beitrag von Desti »

Kleine Korrektur, hatte vergessen die Option in Klammern zu setzten.

nun schaut die Zeile wiefolgt aus:

Code: Alles auswählen

cache_peer 192.168.254.106 parent 3128 7 [proxy-only] 
Und jetzt spuckt er mir auch ne dicke Fehlermeldung aus die ich aber nicht deuten kann.
root@TWsTestDebian:/home/tweber# /etc/rc2.d/S30squid restart
Restarting proxy server: 2005/01/20 16:06:31| parse_peer: token='[proxy-only]'
FATAL: Bungled squid.conf line 192: cache_peer 192.168.254.106 parent 3128 7 [proxy-only]
Squid Cache (Version 2.5.STABLE7): Terminated abnormally.
CPU Usage: 0.010 seconds = 0.000 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 394
/etc/rc2.d/S30squid: line 174: 1949 Abgebrochen start-stop-daemon --quiet --start --pidfile $PIDFILE --chuid $CHUID --exec $DAEMON -- $SQUID_ARGS </dev/null
squid.
root@TWsTestDebian:/home/tweber#
Hoffe da draussen ist einer der weiter weiß, ich verzweifel hier nämlich :(
tonosinai
Newbie
Newbie
Beiträge: 15
Registriert: 12. Jan 2005, 20:03
Wohnort: Mühltal
Kontaktdaten:

Beitrag von tonosinai »

Hallo erst mal. Die Option muss ohne Klammer angehängt werden.

cache_peer 192.168.254.106 parent 3128 7 proxy-only

"Access Denieded. Access Control configuration prevents your request from being allowed at this time."

Um zugriff über den Proxy-Server zu bekommen musst du noch die Accesscontrollisten anpassen.

ACLs erstellen:

Name Source Netzwerkadresse
acl Proxy src 10.54.1.195/255.255.255.255
acl localnet src 10.54.1.0/255.255.255.0

Zugriff erlauben:

http_access allow manager qmanux02
http_access allow localnet
http_access deny all

In der Grundkonfigurartion sperrt Squid jegliche Zugriff

Gruss

Stefan
Antworten